]> git.pld-linux.org Git - packages/domoticz.git/blob - domoticz.spec
- fix building with boost 1.70
[packages/domoticz.git] / domoticz.spec
1 Summary:        Open source Home Automation System
2 Name:           domoticz
3 Version:        4.9700
4 Release:        3
5 License:        GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6 Group:          Base
7 URL:            http://www.domoticz.com
8 Source0:        https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
9 # Source0-md5:  726d838d5d80eed4335b0dfeefb2af6c
10 Source1:        %{name}.service
11 Source2:        %{name}.conf
12 # Source says its version 3.5876, but it's really 3.8153
13 Patch1:         %{name}-version.patch
14 # Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
15 Patch2:         %{name}-tinyxpath.patch
16 # Use system openzwave includes
17 Patch3:         %{name}-openzwave.patch
18 # Work against Dev branch of OpenZWave upstream
19 Patch4:         %{name}-openzwave-Dev.patch
20 # Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
21 Patch5:         %{name}-python.patch
22 Patch6:         domoticz-ozw-barrier-support-0002.patch
23 Patch7:         domoticz-cp-js.patch
24 Patch8:         boost-1.70.patch
25 BuildRequires:  boost-devel
26 BuildRequires:  cmake
27 BuildRequires:  curl-devel
28 BuildRequires:  libmosquitto-devel
29 BuildRequires:  libmosquittopp-devel
30 BuildRequires:  libopenzwave-devel >= 1.5.0
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libusb-devel
33 BuildRequires:  lua-devel
34 BuildRequires:  openssl-devel
35 BuildRequires:  python3-devel
36 BuildRequires:  sqlite-devel
37 BuildRequires:  systemd-devel
38 BuildRequires:  tinyxpath-devel
39 BuildRequires:  zlib-devel
40 Requires(pre):  /usr/sbin/groupadd
41 Requires(pre):  /usr/sbin/useradd
42 Requires(post): systemd
43 Requires(postun):       systemd
44 Requires(preun):        systemd
45 Requires:       fonts-TTF-Google-Droid
46 Provides:       bundled(js-ace)
47 Provides:       bundled(js-angular-ui-bootstrap) = 0.13.4
48 Provides:       bundled(js-angularamd) = 0.2.1
49 Provides:       bundled(js-angularjs) = 1.5.8
50 Provides:       bundled(js-blockly)
51 Provides:       bundled(js-bootbox)
52 Provides:       bundled(js-bootstrap) = 3.2.0
53 Provides:       bundled(js-colpick)
54 Provides:       bundled(js-d3)
55 Provides:       bundled(js-datatables-datatools) = 2.2.3
56 Provides:       bundled(js-dateformat) = 1.2.3
57 Provides:       bundled(js-filesaver) = 0.0-git20140725
58 Provides:       bundled(js-highcharts) = 4.2.6
59 Provides:       bundled(js-html5shiv) = 3.6.2
60 Provides:       bundled(js-i18next) = 1.8.0
61 Provides:       bundled(js-ion-sound) = 3.0.6
62 Provides:       bundled(js-jquery) = 1.12.0
63 Provides:       bundled(js-jquery-noty) = 2.1.0
64 Provides:       bundled(js-less) = 1.3.0
65 Provides:       bundled(js-ngdraggable)
66 Provides:       bundled(js-nggrid)
67 Provides:       bundled(js-ozwcp)
68 Provides:       bundled(js-require) = 2.1.14
69 Provides:       bundled(js-respond) = 1.1.0
70 Provides:       bundled(js-wow) = 0.1.9
71 Provides:       bundled(js-zeroclipboard) = 1.0.4
72
73 %description
74 Domoticz is a Home Automation System that lets you monitor and
75 configure various devices like: Lights, Switches, various
76 sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
77 and much more. Notifications/Alerts can be sent to any mobile device
78
79 %prep
80 %setup -q
81 %patch1 -p1 -b.version
82 %patch2 -p1 -b.tinyxpath
83 %patch3 -p1 -b.openzwave
84 %patch4 -p1 -b.openzwave-Dev
85 %patch5 -p1 -b.python
86 %patch6 -p1
87 %patch7 -p1
88 %patch8 -p1
89 rm -f hardware/openzwave/*.h
90 rm -rf hardware/openzwave/aes
91 rm -rf hardware/openzwave/command_classes
92 rm -rf hardware/openzwave/platform
93 rm -rf hardware/openzwave/value_classes
94 rm -rf sqlite/
95 rm -rf tinyxpath/
96
97 %build
98 install -d build && cd build
99 %cmake \
100         -DUSE_OPENSSL_STATIC=NO \
101         -DUSE_STATIC_LIBSTDCXX=NO \
102         -DUSE_STATIC_OPENZWAVE=NO \
103         -DUSE_BUILTIN_LUA=NO \
104         -DUSE_BUILTIN_MQTT=NO \
105         -DUSE_BUILTIN_SQLITE=NO \
106         -DUSE_BUILTIN_TINYXPATH=NO \
107         -DUSE_STATIC_BOOST=NO \
108         -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
109         ..
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 %{__make} -C build install \
116       DESTDIR=$RPM_BUILD_ROOT
117
118 # remove docs, we grab them in files below
119 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
120
121 # move binary to standard directory
122 install -d $RPM_BUILD_ROOT%{_bindir}/
123 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/
124
125 # install systemd service and config
126 install -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
127 install -d $RPM_BUILD_ROOT%{systemdunitdir}/
128 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/
129 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
130
131 # create database/ssl cert directory
132 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/
133
134 # Disable the app's self-update script
135
136 # Unbundle DroidSans.ttf
137 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/DroidSans.ttf
138 ln -s /usr/share/fonts/TTF/DroidSans.ttf \
139       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/
140 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/DroidSans.ttf
141 ln -s /usr/share/fonts/TTF/DroidSans.ttf \
142       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/
143 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/DroidSans.ttf
144 ln -s /usr/share/fonts/TTF/DroidSans.ttf \
145       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/
146
147 # OpenZWave Control Panel temp file
148 ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
149       $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %pre
155 getent group domoticz >/dev/null || groupadd -r domoticz
156 getent passwd domoticz >/dev/null || \
157 useradd -r -g domoticz -d %{_datadir}/%{name} -s /sbin/nologin \
158 -c "Domoticz Home Automation Server" domoticz
159 # For OpenZWave USB access (/dev/ttyACM#)
160 usermod -G domoticz,dialout domoticz
161
162 %post
163 %systemd_post %{name}.service
164
165 %preun
166 %systemd_preun %{name}.service
167
168 %postun
169 %systemd_postun_with_restart %{name}.service
170
171 %files
172 %defattr(644,root,root,755)
173 %doc License.txt
174 %doc README.md History.txt
175 %attr(755,root,root) %{_bindir}/%{name}
176 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
177 %{_datadir}/%{name}/
178 %attr(755,domoticz,domoticz) %{_sharedstatedir}/%{name}/
179 %{systemdunitdir}/%{name}.service
This page took 0.080113 seconds and 4 git commands to generate.