]> git.pld-linux.org Git - packages/domoticz.git/blob - domoticz.spec
- rel 4; fix python 3.8 build
[packages/domoticz.git] / domoticz.spec
1 Summary:        Open source Home Automation System
2 Name:           domoticz
3 Version:        4.10717
4 Release:        4
5 License:        GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6 Group:          Base
7 URL:            http://www.domoticz.com
8 Source0:        https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
9 # Source0-md5:  1d5f5572ae43379a6d62023cb8da0e9b
10 Source1:        %{name}.service
11 Source2:        %{name}.conf
12 # Source says its version 4.9700, but it's really 4.10717
13 Patch1:         %{name}-version.patch
14 # Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
15 Patch2:         %{name}-tinyxpath.patch
16 # Use system openzwave includes
17 Patch3:         %{name}-openzwave.patch
18 # Work against Dev branch of OpenZWave upstream
19 Patch4:         %{name}-openzwave-Dev.patch
20 # Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
21 Patch5:         %{name}-python.patch
22 Patch6:         domoticz-ozw-barrier-support-0002.patch
23 Patch7:         domoticz-cp-js.patch
24 BuildRequires:  boost-devel
25 BuildRequires:  cmake
26 BuildRequires:  curl-devel
27 BuildRequires:  libmosquitto-devel
28 BuildRequires:  libmosquittopp-devel
29 BuildRequires:  libopenzwave-devel >= 1.5.0
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libusb-devel
32 BuildRequires:  lua-devel
33 BuildRequires:  openssl-devel
34 BuildRequires:  python3-devel
35 BuildRequires:  sqlite-devel
36 BuildRequires:  systemd-devel
37 BuildRequires:  tinyxpath-devel
38 BuildRequires:  zlib-devel
39 Requires(pre):  /usr/sbin/groupadd
40 Requires(pre):  /usr/sbin/useradd
41 Requires(post): systemd
42 Requires(postun):       systemd
43 Requires(preun):        systemd
44 Requires:       fonts-TTF-Google-Droid
45 Provides:       bundled(js-ace)
46 Provides:       bundled(js-angular-ui-bootstrap) = 0.13.4
47 Provides:       bundled(js-angularamd) = 0.2.1
48 Provides:       bundled(js-angularjs) = 1.5.8
49 Provides:       bundled(js-blockly)
50 Provides:       bundled(js-bootbox)
51 Provides:       bundled(js-bootstrap) = 3.2.0
52 Provides:       bundled(js-colpick)
53 Provides:       bundled(js-d3)
54 Provides:       bundled(js-datatables-datatools) = 2.2.3
55 Provides:       bundled(js-dateformat) = 1.2.3
56 Provides:       bundled(js-filesaver) = 0.0-git20140725
57 Provides:       bundled(js-highcharts) = 4.2.6
58 Provides:       bundled(js-html5shiv) = 3.6.2
59 Provides:       bundled(js-i18next) = 1.8.0
60 Provides:       bundled(js-ion-sound) = 3.0.6
61 Provides:       bundled(js-jquery) = 1.12.0
62 Provides:       bundled(js-jquery-noty) = 2.1.0
63 Provides:       bundled(js-less) = 1.3.0
64 Provides:       bundled(js-ngdraggable)
65 Provides:       bundled(js-nggrid)
66 Provides:       bundled(js-ozwcp)
67 Provides:       bundled(js-require) = 2.1.14
68 Provides:       bundled(js-respond) = 1.1.0
69 Provides:       bundled(js-wow) = 0.1.9
70 Provides:       bundled(js-zeroclipboard) = 1.0.4
71
72 %description
73 Domoticz is a Home Automation System that lets you monitor and
74 configure various devices like: Lights, Switches, various
75 sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
76 and much more. Notifications/Alerts can be sent to any mobile device
77
78 %prep
79 %setup -q
80 %patch1 -p1 -b.version
81 %patch2 -p1 -b.tinyxpath
82 %patch3 -p1 -b.openzwave
83 #%patch4 -p1 -b.openzwave-Dev
84 %patch5 -p1 -b.python
85 %patch6 -p1
86 %patch7 -p1
87 rm -f hardware/openzwave/*.h
88 rm -rf hardware/openzwave/aes
89 rm -rf hardware/openzwave/command_classes
90 rm -rf hardware/openzwave/platform
91 rm -rf hardware/openzwave/value_classes
92 rm -rf sqlite/
93 rm -rf tinyxpath/
94
95 %build
96 install -d build && cd build
97 %cmake \
98         -DUSE_OPENSSL_STATIC=NO \
99         -DUSE_STATIC_LIBSTDCXX=NO \
100         -DUSE_STATIC_OPENZWAVE=NO \
101         -DUSE_BUILTIN_LUA=NO \
102         -DUSE_BUILTIN_MQTT=NO \
103         -DUSE_BUILTIN_SQLITE=NO \
104         -DUSE_BUILTIN_TINYXPATH=NO \
105         -DUSE_STATIC_BOOST=NO \
106         -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
107         ..
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 %{__make} -C build install \
114       DESTDIR=$RPM_BUILD_ROOT
115
116 # remove docs, we grab them in files below
117 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
118
119 # move binary to standard directory
120 install -d $RPM_BUILD_ROOT%{_bindir}/
121 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/
122
123 # install systemd service and config
124 install -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
125 install -d $RPM_BUILD_ROOT%{systemdunitdir}/
126 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/
127 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
128
129 # create database/ssl cert directory
130 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/
131
132 # Disable the app's self-update script
133
134 # Unbundle DroidSans.ttf
135 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/DroidSans.ttf
136 ln -s /usr/share/fonts/TTF/DroidSans.ttf \
137       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/
138 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/DroidSans.ttf
139 ln -s /usr/share/fonts/TTF/DroidSans.ttf \
140       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/
141 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/DroidSans.ttf
142 ln -s /usr/share/fonts/TTF/DroidSans.ttf \
143       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/
144
145 # OpenZWave Control Panel temp file
146 ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
147       $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %pre
153 getent group domoticz >/dev/null || groupadd -r domoticz
154 getent passwd domoticz >/dev/null || \
155 useradd -r -g domoticz -d %{_datadir}/%{name} -s /sbin/nologin \
156 -c "Domoticz Home Automation Server" domoticz
157 # For OpenZWave USB access (/dev/ttyACM#)
158 usermod -G domoticz,dialout domoticz
159
160 %post
161 %systemd_post %{name}.service
162
163 %preun
164 %systemd_preun %{name}.service
165
166 %postun
167 %systemd_postun_with_restart %{name}.service
168
169 %files
170 %defattr(644,root,root,755)
171 %doc License.txt
172 %doc README.md History.txt
173 %attr(755,root,root) %{_bindir}/%{name}
174 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
175 %{_datadir}/%{name}/
176 %attr(755,domoticz,domoticz) %{_sharedstatedir}/%{name}/
177 %{systemdunitdir}/%{name}.service
This page took 0.082665 seconds and 4 git commands to generate.