]> git.pld-linux.org Git - packages/domoticz.git/blob - domoticz.spec
- fix building with boost 1.73
[packages/domoticz.git] / domoticz.spec
1 Summary:        Open source Home Automation System
2 Name:           domoticz
3 Version:        2020.2
4 Release:        3
5 License:        GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6 Group:          Base
7 URL:            http://www.domoticz.com
8 Source0:        https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
9 # Source0-md5:  fd383a13d13d0976c72f332d6db1d24e
10 Source1:        %{name}.service
11 Source2:        %{name}.conf
12
13 # Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
14 Patch2:         %{name}-tinyxpath.patch
15 # Use system openzwave includes
16 Patch3:         %{name}-openzwave.patch
17 # Work against Dev branch of OpenZWave upstream
18 Patch4:         %{name}-openzwave-Dev.patch
19 # Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
20 Patch5:         %{name}-python.patch
21 Patch6:         no-git.patch
22 Patch7:         boost-1.73.patch
23 BuildRequires:  boost-devel
24 BuildRequires:  cereal-devel
25 BuildRequires:  cmake
26 BuildRequires:  curl-devel
27 BuildRequires:  libmosquitto-devel
28 BuildRequires:  libmosquittopp-devel
29 BuildRequires:  libopenzwave-devel >= 1.5.0
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libusb-devel
32 BuildRequires:  lua-devel
33 BuildRequires:  minizip-devel
34 BuildRequires:  openssl-devel
35 BuildRequires:  python3-devel
36 BuildRequires:  sqlite-devel
37 BuildRequires:  systemd-devel
38 BuildRequires:  tinyxpath-devel
39 BuildRequires:  zlib-devel
40 Requires(pre):  /usr/sbin/groupadd
41 Requires(pre):  /usr/sbin/useradd
42 Requires(post): systemd
43 Requires(postun):       systemd
44 Requires(preun):        systemd
45 Requires:       fonts-TTF-Google-Droid
46 Provides:       bundled(js-ace)
47 Provides:       bundled(js-angular-ui-bootstrap) = 0.13.4
48 Provides:       bundled(js-angularamd) = 0.2.1
49 Provides:       bundled(js-angularjs) = 1.5.8
50 Provides:       bundled(js-blockly)
51 Provides:       bundled(js-bootbox)
52 Provides:       bundled(js-bootstrap) = 3.2.0
53 Provides:       bundled(js-colpick)
54 Provides:       bundled(js-d3)
55 Provides:       bundled(js-datatables-datatools) = 2.2.3
56 Provides:       bundled(js-dateformat) = 1.2.3
57 Provides:       bundled(js-filesaver) = 0.0-git20140725
58 Provides:       bundled(js-highcharts) = 4.2.6
59 Provides:       bundled(js-html5shiv) = 3.6.2
60 Provides:       bundled(js-i18next) = 1.8.0
61 Provides:       bundled(js-ion-sound) = 3.0.6
62 Provides:       bundled(js-jquery) = 1.12.0
63 Provides:       bundled(js-jquery-noty) = 2.1.0
64 Provides:       bundled(js-less) = 1.3.0
65 Provides:       bundled(js-ngdraggable)
66 Provides:       bundled(js-nggrid)
67 Provides:       bundled(js-ozwcp)
68 Provides:       bundled(js-require) = 2.1.14
69 Provides:       bundled(js-respond) = 1.1.0
70 Provides:       bundled(js-wow) = 0.1.9
71 Provides:       bundled(js-zeroclipboard) = 1.0.4
72
73 %description
74 Domoticz is a Home Automation System that lets you monitor and
75 configure various devices like: Lights, Switches, various
76 sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
77 and much more. Notifications/Alerts can be sent to any mobile device
78
79 %prep
80 %setup -q
81
82 APPVERSION="%{version}"
83 echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
84 echo '#define APPHASH "%{snap}"' >> appversion.h
85 APPDATE=$(date --date="%{date}" "+%s")
86 echo "#define APPDATE ${APPDATE}" >> appversion.h
87
88 %patch2 -p1 -b.tinyxpath
89 %patch3 -p1 -b.openzwave
90 #%patch4 -p1 -b.openzwave-Dev
91 %patch5 -p1 -b.python
92 %patch6 -p1
93 %patch7 -p1
94
95 rm -f hardware/openzwave/*.h
96 rm -rf hardware/openzwave/aes
97 rm -rf hardware/openzwave/command_classes
98 rm -rf hardware/openzwave/platform
99 rm -rf hardware/openzwave/value_classes
100 rm -rf sqlite/
101 rm -rf tinyxpath/
102
103 %build
104 install -d build && cd build
105 %cmake \
106         -DUSE_OPENSSL_STATIC=NO \
107         -DUSE_STATIC_LIBSTDCXX=NO \
108         -DUSE_STATIC_OPENZWAVE=NO \
109         -DUSE_OPENSSL_STATIC=NO \
110         -DUSE_BUILTIN_JSONCPP=NO \
111         -DUSE_BUILTIN_LUA=NO \
112         -DUSE_BUILTIN_MINIZIP=NO \
113         -DUSE_BUILTIN_MQTT=NO \
114         -DUSE_BUILTIN_SQLITE=NO \
115         -DUSE_BUILTIN_TINYXPATH=NO \
116         -DUSE_STATIC_BOOST=NO \
117         -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
118         ..
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 %{__make} -C build install \
125       DESTDIR=$RPM_BUILD_ROOT
126
127 # remove docs, we grab them in files below
128 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
129
130 # move binary to standard directory
131 install -d $RPM_BUILD_ROOT%{_bindir}/
132 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/
133
134 # install systemd service and config
135 install -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
136 install -d $RPM_BUILD_ROOT%{systemdunitdir}/
137 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/
138 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
139
140 # create database/ssl cert directory
141 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/
142
143 # Disable the app's self-update script
144
145 # Unbundle DroidSans.ttf
146 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/DroidSans.ttf
147 ln -s /usr/share/fonts/TTF/DroidSans.ttf \
148       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/
149 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/DroidSans.ttf
150 ln -s /usr/share/fonts/TTF/DroidSans.ttf \
151       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/
152 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/DroidSans.ttf
153 ln -s /usr/share/fonts/TTF/DroidSans.ttf \
154       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/
155
156 # OpenZWave Control Panel temp file
157 ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
158       $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %pre
164 getent group domoticz >/dev/null || groupadd -r domoticz
165 getent passwd domoticz >/dev/null || \
166 useradd -r -g domoticz -d %{_datadir}/%{name} -s /sbin/nologin \
167 -c "Domoticz Home Automation Server" domoticz
168 # For OpenZWave USB access (/dev/ttyACM#)
169 usermod -G domoticz,dialout domoticz
170
171 %post
172 %systemd_post %{name}.service
173
174 %preun
175 %systemd_preun %{name}.service
176
177 %postun
178 %systemd_reload
179
180 %files
181 %defattr(644,root,root,755)
182 %doc License.txt
183 %doc README.md History.txt
184 %attr(755,root,root) %{_bindir}/%{name}
185 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
186 %{_datadir}/%{name}/
187 %attr(755,domoticz,domoticz) %{_sharedstatedir}/%{name}/
188 %{systemdunitdir}/%{name}.service
This page took 0.089956 seconds and 4 git commands to generate.