]> git.pld-linux.org Git - packages/domoticz.git/blob - domoticz.spec
- update deps and fonts
[packages/domoticz.git] / domoticz.spec
1 Summary:        Open source Home Automation System
2 Name:           domoticz
3 Version:        3.8153
4 Release:        0.1
5 License:        GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6 Group:          Base
7 URL:            http://www.domoticz.com
8 Source0:        https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
9 # Source0-md5:  ad7b1d0491cd17e54bbe7368bcfd5170
10 Source1:        %{name}.service
11 Source2:        %{name}.conf
12 # Source says its version 3.5876, but it's really 3.8153
13 Patch1:         %{name}-version.patch
14 # Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
15 Patch2:         %{name}-tinyxpath.patch
16 # Use system openzwave includes
17 Patch3:         %{name}-openzwave.patch
18 # Work against Dev branch of OpenZWave upstream
19 Patch4:         %{name}-openzwave-Dev.patch
20 # Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
21 Patch5:         %{name}-python.patch
22 BuildRequires:  boost-devel
23 BuildRequires:  cmake
24 BuildRequires:  curl-devel
25 BuildRequires:  libmosquitto-devel
26 BuildRequires:  libmosquittopp-devel
27 BuildRequires:  libopenzwave-devel >= 1.5.0
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libusb-devel
30 BuildRequires:  lua-devel
31 BuildRequires:  openssl-devel
32 BuildRequires:  python3-devel
33 BuildRequires:  sqlite-devel
34 BuildRequires:  systemd-devel
35 BuildRequires:  tinyxpath-devel
36 BuildRequires:  zlib-devel
37 Requires(pre):  /usr/sbin/groupadd
38 Requires(pre):  /usr/sbin/useradd
39 Requires(post): systemd
40 Requires(postun):       systemd
41 Requires(preun):        systemd
42 Requires:       fonts-TTF-Google-Droid
43 Provides:       bundled(js-ace)
44 Provides:       bundled(js-angular-ui-bootstrap) = 0.13.4
45 Provides:       bundled(js-angularamd) = 0.2.1
46 Provides:       bundled(js-angularjs) = 1.5.8
47 Provides:       bundled(js-blockly)
48 Provides:       bundled(js-bootbox)
49 Provides:       bundled(js-bootstrap) = 3.2.0
50 Provides:       bundled(js-colpick)
51 Provides:       bundled(js-d3)
52 Provides:       bundled(js-datatables-datatools) = 2.2.3
53 Provides:       bundled(js-dateformat) = 1.2.3
54 Provides:       bundled(js-filesaver) = 0.0-git20140725
55 Provides:       bundled(js-highcharts) = 4.2.6
56 Provides:       bundled(js-html5shiv) = 3.6.2
57 Provides:       bundled(js-i18next) = 1.8.0
58 Provides:       bundled(js-ion-sound) = 3.0.6
59 Provides:       bundled(js-jquery) = 1.12.0
60 Provides:       bundled(js-jquery-noty) = 2.1.0
61 Provides:       bundled(js-less) = 1.3.0
62 Provides:       bundled(js-ngdraggable)
63 Provides:       bundled(js-nggrid)
64 Provides:       bundled(js-ozwcp)
65 Provides:       bundled(js-require) = 2.1.14
66 Provides:       bundled(js-respond) = 1.1.0
67 Provides:       bundled(js-wow) = 0.1.9
68 Provides:       bundled(js-zeroclipboard) = 1.0.4
69
70 %description
71 Domoticz is a Home Automation System that lets you monitor and
72 configure various devices like: Lights, Switches, various
73 sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
74 and much more. Notifications/Alerts can be sent to any mobile device
75
76 %prep
77 %setup -q
78 %patch1 -p1 -b.version
79 %patch2 -p1 -b.tinyxpath
80 %patch3 -p1 -b.openzwave
81 %patch4 -p1 -b.openzwave-Dev
82 %patch5 -p1 -b.python
83 rm -f hardware/openzwave/*.h
84 rm -rf hardware/openzwave/aes
85 rm -rf hardware/openzwave/command_classes
86 rm -rf hardware/openzwave/platform
87 rm -rf hardware/openzwave/value_classes
88 rm -rf sqlite/
89 rm -rf tinyxpath/
90
91 %build
92 install -d build && cd build
93 %cmake \
94       -DUSE_STATIC_LIBSTDCXX=NO \
95       -DUSE_STATIC_OPENZWAVE=NO \
96       -DUSE_BUILTIN_LUA=NO \
97       -DUSE_BUILTIN_MQTT=NO \
98       -DUSE_BUILTIN_SQLITE=NO \
99       -DUSE_BUILTIN_TINYXPATH=NO \
100       -DUSE_STATIC_BOOST=NO \
101       -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
102       ..
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 %{__make} -C build install \
109       DESTDIR=$RPM_BUILD_ROOT
110
111 # remove docs, we grab them in files below
112 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
113
114 # move binary to standard directory
115 install -d $RPM_BUILD_ROOT%{_bindir}/
116 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/
117
118 # install systemd service and config
119 install -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
120 install -d $RPM_BUILD_ROOT%{systemdunitdir}/
121 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/
122 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
123
124 # create database/ssl cert directory
125 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/
126
127 # Disable the app's self-update script
128
129 # Unbundle DroidSans.ttf
130 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/DroidSans.ttf
131 ln -s /usr/share/fonts/TTF/DroidSans.ttf \
132       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/
133 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/DroidSans.ttf
134 ln -s /usr/share/fonts/TTF/DroidSans.ttf \
135       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/
136 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/DroidSans.ttf
137 ln -s /usr/share/fonts/TTF/DroidSans.ttf \
138       $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/
139
140 # OpenZWave Control Panel temp file
141 ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
142       $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %pre
148 getent group domoticz >/dev/null || groupadd -r domoticz
149 getent passwd domoticz >/dev/null || \
150 useradd -r -g domoticz -d %{_datadir}/%{name} -s /sbin/nologin \
151 -c "Domoticz Home Automation Server" domoticz
152 # For OpenZWave USB access (/dev/ttyACM#)
153 usermod -G domoticz,dialout domoticz
154
155 %post
156 %systemd_post %{name}.service
157
158 %preun
159 %systemd_preun %{name}.service
160
161 %postun
162 %systemd_postun_with_restart %{name}.service
163
164 %files
165 %defattr(644,root,root,755)
166 %doc License.txt
167 %doc README.md History.txt
168 %attr(755,root,root) %{_bindir}/%{name}
169 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
170 %{_datadir}/%{name}/
171 %attr(755,domoticz,domoticz) %{_sharedstatedir}/%{name}/
172 %{systemdunitdir}/%{name}.service
This page took 0.074033 seconds and 4 git commands to generate.