]> git.pld-linux.org Git - packages/domoticz.git/blob - domoticz.spec
handle user/group correctly
[packages/domoticz.git] / domoticz.spec
1 Summary:        Open source Home Automation System
2 Name:           domoticz
3 Version:        2020.2
4 Release:        3
5 License:        GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6 Group:          Base
7 URL:            http://www.domoticz.com
8 Source0:        https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
9 # Source0-md5:  fd383a13d13d0976c72f332d6db1d24e
10 Source1:        %{name}.service
11 Source2:        %{name}.conf
12 # Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
13 Patch0:         %{name}-tinyxpath.patch
14 # Use system openzwave includes
15 Patch1:         %{name}-openzwave.patch
16 # Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
17 Patch2:         %{name}-python.patch
18 Patch3:         no-git.patch
19 Patch4:         boost-1.73.patch
20 BuildRequires:  boost-devel >= 1.66.0
21 BuildRequires:  cereal-devel
22 BuildRequires:  cmake >= 3.16.0
23 BuildRequires:  curl-devel
24 BuildRequires:  jsoncpp-devel
25 BuildRequires:  libmosquitto-devel
26 BuildRequires:  libopenzwave-devel >= 1.5.0
27 BuildRequires:  libstdc++-devel >= 6:4.8.1
28 BuildRequires:  libusb-compat-devel
29 BuildRequires:  linux-libc-headers
30 BuildRequires:  lua53-devel
31 BuildRequires:  minizip-devel
32 BuildRequires:  openssl-devel
33 BuildRequires:  pkgconfig
34 BuildRequires:  python3 >= 1:3.4
35 BuildRequires:  python3-devel >= 1:3.4
36 BuildRequires:  sqlite3-devel
37 BuildRequires:  tinyxml-devel
38 BuildRequires:  tinyxpath-devel
39 BuildRequires:  zlib-devel
40 Requires(pre):  /usr/sbin/groupadd
41 Requires(pre):  /usr/sbin/useradd
42 Requires(post,preun,postun):    systemd-units >= 38
43 Requires:       fonts-TTF-Google-Droid
44 Requires:       libopenzwave >= 1.5.0
45 Provides:       group(domoticz)
46 Provides:       user(domoticz)
47
48 %description
49 Domoticz is a Home Automation System that lets you monitor and
50 configure various devices like: Lights, Switches, various
51 sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
52 and much more. Notifications/Alerts can be sent to any mobile device
53
54 %prep
55 %setup -q
56 %patch0 -p1
57 %patch1 -p1
58 %patch2 -p1
59 %patch3 -p1
60 %patch4 -p1
61
62 APPVERSION="%{version}"
63 echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
64 echo '#define APPHASH "%{snap}"' >> appversion.h
65 APPDATE=$(date --date="%{date}" "+%s")
66 echo "#define APPDATE ${APPDATE}" >> appversion.h
67
68 %{__rm} -r extern tinyxpath
69
70 %build
71 install -d build && cd build
72 %cmake \
73         -DUSE_BUILTIN_JSONCPP=NO \
74         -DUSE_BUILTIN_MINIZIP=NO \
75         -DUSE_BUILTIN_MQTT=NO \
76         -DUSE_BUILTIN_SQLITE=NO \
77         -DUSE_BUILTIN_TINYXPATH=NO \
78         -DUSE_LUA_STATIC=NO \
79         -DUSE_OPENSSL_STATIC=NO \
80         -DUSE_STATIC_BOOST=NO \
81         -DUSE_STATIC_LIBSTDCXX=NO \
82         -DUSE_STATIC_OPENZWAVE=NO \
83         -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
84         ..
85
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} -C build install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/sysconfig,%{systemdunitdir},%{_sharedstatedir}/%{name}}
95
96 # remove docs, we grab them in files below
97 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
98
99 # move binary to standard directory
100 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}
101
102 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}
103 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
104
105 # Unbundle DroidSans.ttf
106 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element{al,-light,-dark}/fonts/DroidSans.ttf
107 ln -s %{_fontsdir}/TTF/DroidSans.ttf \
108         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts
109 ln -s %{_fontsdir}/TTF/DroidSans.ttf \
110         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts
111 ln -s %{_fontsdir}/TTF/DroidSans.ttf \
112         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts
113
114 # OpenZWave Control Panel temp file
115 ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
116         $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %pre
122 %groupadd -g 342 domoticz
123 %useradd -u 342 -r -d %{_datadir} -s /bin/false -c "Domoticz Home Automation Server" -G dialout -g domoticz domoticz
124
125 %post
126 %systemd_post %{name}.service
127
128 %preun
129 %systemd_preun %{name}.service
130
131 %postun
132 if [ "$1" = "0" ]; then
133         %userremove mpd
134         %groupremove mpd
135 fi
136 %systemd_reload
137
138 %files
139 %defattr(644,root,root,755)
140 %doc License.txt README.md History.txt
141 %attr(755,root,root) %{_bindir}/%{name}
142 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
143 %{_datadir}/%{name}
144 %dir %attr(750,domoticz,domoticz) %{_sharedstatedir}/%{name}
145 %{systemdunitdir}/%{name}.service
This page took 0.074245 seconds and 3 git commands to generate.