]> git.pld-linux.org Git - packages/domoticz.git/blame - domoticz.spec
boost rebuild
[packages/domoticz.git] / domoticz.spec
CommitLineData
9dda6696
AM
1Summary: Open source Home Automation System
2Name: domoticz
cd9dc7ee 3Version: 2022.1
8708f6e0 4Release: 2
9dda6696
AM
5License: GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6Group: Base
7URL: http://www.domoticz.com
40563459 8Source0: https://github.com/domoticz/domoticz/archive/%{version}/%{name}-%{version}.tar.gz
cd9dc7ee 9# Source0-md5: 03ebcd9af34fbd2737725303a50ad9fd
9dda6696
AM
10Source1: %{name}.service
11Source2: %{name}.conf
9dda6696 12# Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
bc226567 13Patch0: %{name}-tinyxpath.patch
9dda6696 14# Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
9a71e0cb
JP
15Patch1: %{name}-python.patch
16Patch2: no-git.patch
cd9dc7ee
JP
17Patch3: %{name}-no_updates.patch
18Patch4: strstr.patch
3a1bb43e 19Patch5: config.patch
4987f952 20BuildRequires: boost-devel >= 1.66.0
72784cf7 21BuildRequires: cereal-devel
4987f952 22BuildRequires: cmake >= 3.16.0
9dda6696 23BuildRequires: curl-devel
4987f952 24BuildRequires: jsoncpp-devel
9dda6696 25BuildRequires: libmosquitto-devel
9dda6696 26BuildRequires: libopenzwave-devel >= 1.5.0
9a71e0cb 27BuildRequires: libstdc++-devel >= 6:4.9
4987f952
JP
28BuildRequires: libusb-compat-devel
29BuildRequires: linux-libc-headers
30BuildRequires: lua53-devel
72784cf7 31BuildRequires: minizip-devel
9dda6696 32BuildRequires: openssl-devel
4987f952
JP
33BuildRequires: pkgconfig
34BuildRequires: python3 >= 1:3.4
35BuildRequires: python3-devel >= 1:3.4
f5d0e494 36BuildRequires: rpmbuild(macros) >= 1.644
4987f952
JP
37BuildRequires: sqlite3-devel
38BuildRequires: tinyxml-devel
9dda6696
AM
39BuildRequires: tinyxpath-devel
40BuildRequires: zlib-devel
0e22aa87
JP
41Requires(pre): /usr/sbin/groupadd
42Requires(pre): /usr/sbin/useradd
43Requires(post,preun,postun): systemd-units >= 38
44Requires: fonts-TTF-Google-Droid
e9c32406 45Requires: fonts-TTF-OpenSans
4987f952 46Requires: libopenzwave >= 1.5.0
a1c25c45 47Requires: setup >= 2.10.1
77898dff 48Suggests: python3-libs
ed4fe787
JP
49Provides: group(domoticz)
50Provides: user(domoticz)
4f49453f 51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9dda6696
AM
52
53%description
54Domoticz is a Home Automation System that lets you monitor and
55configure various devices like: Lights, Switches, various
56sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
57and much more. Notifications/Alerts can be sent to any mobile device
58
59%prep
72784cf7 60%setup -q
bc226567
JP
61%patch0 -p1
62%patch1 -p1
63%patch2 -p1
64%patch3 -p1
65%patch4 -p1
3a1bb43e 66%patch5 -p1
10f7a92e
AM
67
68APPVERSION="%{version}"
69echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
70echo '#define APPHASH "%{snap}"' >> appversion.h
71APPDATE=$(date --date="%{date}" "+%s")
72echo "#define APPDATE ${APPDATE}" >> appversion.h
73
0e22aa87 74%{__rm} -r extern tinyxpath
9dda6696
AM
75
76%build
77install -d build && cd build
109876d2 78export CXXFLAGS="%{rpmcxxflags} -DPYTHON_LIBDIR=\\\"%{_libdir}\\\""
9dda6696 79%cmake \
4987f952
JP
80 -DUSE_BUILTIN_JSONCPP=NO \
81 -DUSE_BUILTIN_MINIZIP=NO \
71593ba7
JR
82 -DUSE_BUILTIN_MQTT=NO \
83 -DUSE_BUILTIN_SQLITE=NO \
84 -DUSE_BUILTIN_TINYXPATH=NO \
4987f952
JP
85 -DUSE_LUA_STATIC=NO \
86 -DUSE_OPENSSL_STATIC=NO \
71593ba7 87 -DUSE_STATIC_BOOST=NO \
4987f952
JP
88 -DUSE_STATIC_LIBSTDCXX=NO \
89 -DUSE_STATIC_OPENZWAVE=NO \
cd9dc7ee 90 -DFORCE_WITH_GPIO:BOOL=TRUE \
71593ba7
JR
91 -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
92 ..
00bce45c 93
9dda6696
AM
94%{__make}
95
96%install
97rm -rf $RPM_BUILD_ROOT
0e22aa87 98
00bce45c 99%{__make} -C build install \
0e22aa87
JP
100 DESTDIR=$RPM_BUILD_ROOT
101
3a1bb43e 102install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/{domoticz,sysconfig},%{systemdunitdir},%{_sharedstatedir}/%{name}}
9dda6696
AM
103
104# remove docs, we grab them in files below
0e22aa87 105%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
9dda6696
AM
106
107# move binary to standard directory
0e22aa87 108mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}
9dda6696 109
3a1bb43e
JP
110sed -e 's#@DOMOTICZ_DIR@#%{_datadir}/%{name}#g' %{SOURCE1} > $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
111sed -e 's#@DOMOTICZ_DIR@#%{_datadir}/%{name}#g' scripts/domoticz.conf > $RPM_BUILD_ROOT%{_sysconfdir}/domoticz/domoticz.conf
112sed -e 's#@DOMOTICZ_CONF_DIR@#%{_sysconfdir}/%{name}#' %{SOURCE2} > $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
9dda6696 113
9dda6696 114# Unbundle DroidSans.ttf
e9c32406 115%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element{al,-light,-dark}/fonts/{Droid,Open}Sans.ttf
0e22aa87
JP
116ln -s %{_fontsdir}/TTF/DroidSans.ttf \
117 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts
e9c32406
JP
118ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
119 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/OpenSans.ttf
0e22aa87
JP
120ln -s %{_fontsdir}/TTF/DroidSans.ttf \
121 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts
e9c32406
JP
122ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
123 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/OpenSans.ttf
0e22aa87
JP
124ln -s %{_fontsdir}/TTF/DroidSans.ttf \
125 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts
e9c32406
JP
126ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
127 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/OpenSans.ttf
9dda6696
AM
128
129# OpenZWave Control Panel temp file
130ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
0e22aa87 131 $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
9dda6696
AM
132
133%clean
134rm -rf $RPM_BUILD_ROOT
135
136%pre
ed4fe787 137%groupadd -g 342 domoticz
a1c25c45 138%useradd -u 342 -r -d %{_datadir} -s /bin/false -c "Domoticz Home Automation Server" -G dialout,i2c -g domoticz domoticz
9dda6696
AM
139
140%post
141%systemd_post %{name}.service
142
143%preun
144%systemd_preun %{name}.service
145
146%postun
ed4fe787 147if [ "$1" = "0" ]; then
f3eaf224
JP
148 %userremove domoticz
149 %groupremove domoticz
ed4fe787 150fi
5ac2f181 151%systemd_reload
9dda6696 152
3a1bb43e
JP
153%triggerpostun -- domoticz < 2022.1
154if [ -f /etc/sysconfig/domoticz.rpmnew ] && [ -f /etc/sysconfig/domoticz ] && ! grep -q '^DOMOTICZ_CONF=' /etc/sysconfig/domoticz; then
155 (
156 . /etc/sysconfig/domoticz
157 for c in WWW_PORT:http_port SSL_PORT:ssl_port SSLCERT:ssl_cert SSLPASS:ssl_pass SSLMETHOD:ssl_method SSLOPTIONS:ssl_options SSLDHPARAM:ssl_dhparam WWW_ROOT:http_root DBASE:dbase_file USERDATA:userdata_path LOG:log_file; do
158 cn_before=${c%:*}
159 cn_after=${c#*:}
160 eval cn_value=\"\$$cn_before\"
161 test -n "$cn_value" && sed -i -e "s|^[[:space:]#]*$cn_after=.*|$cn_after=$cn_value|" %{_sysconfdir}/%{name}/%{name}.conf
162 done
163 )
164 mv -f /etc/sysconfig/domoticz{,.rpmsave}
165 mv /etc/sysconfig/domoticz{.rpmnew,}
166fi
167
9dda6696
AM
168%files
169%defattr(644,root,root,755)
0e22aa87 170%doc License.txt README.md History.txt
9dda6696 171%attr(755,root,root) %{_bindir}/%{name}
3a1bb43e
JP
172%dir %attr(750,domoticz,domoticz) %{_sysconfdir}/%{name}
173%attr(640,domoticz,domoticz) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.conf
9dda6696 174%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
0e22aa87
JP
175%{_datadir}/%{name}
176%dir %attr(750,domoticz,domoticz) %{_sharedstatedir}/%{name}
9dda6696 177%{systemdunitdir}/%{name}.service
This page took 0.139359 seconds and 4 git commands to generate.