]> git.pld-linux.org Git - packages/domoticz.git/blame - domoticz.spec
drop unused patches
[packages/domoticz.git] / domoticz.spec
CommitLineData
9dda6696
AM
1Summary: Open source Home Automation System
2Name: domoticz
72784cf7 3Version: 2020.2
0abc31de 4Release: 3
9dda6696
AM
5License: GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6Group: Base
7URL: http://www.domoticz.com
72784cf7
AM
8Source0: https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
9# Source0-md5: fd383a13d13d0976c72f332d6db1d24e
9dda6696
AM
10Source1: %{name}.service
11Source2: %{name}.conf
9dda6696 12# Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
bc226567 13Patch0: %{name}-tinyxpath.patch
9dda6696 14# Use system openzwave includes
bc226567 15Patch1: %{name}-openzwave.patch
9dda6696 16# Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
bc226567
JP
17Patch2: %{name}-python.patch
18Patch3: no-git.patch
19Patch4: boost-1.73.patch
4987f952 20BuildRequires: boost-devel >= 1.66.0
72784cf7 21BuildRequires: cereal-devel
4987f952 22BuildRequires: cmake >= 3.16.0
9dda6696 23BuildRequires: curl-devel
4987f952 24BuildRequires: jsoncpp-devel
9dda6696 25BuildRequires: libmosquitto-devel
9dda6696 26BuildRequires: libopenzwave-devel >= 1.5.0
4987f952
JP
27BuildRequires: libstdc++-devel >= 6:4.8.1
28BuildRequires: libusb-compat-devel
29BuildRequires: linux-libc-headers
30BuildRequires: lua53-devel
72784cf7 31BuildRequires: minizip-devel
9dda6696 32BuildRequires: openssl-devel
4987f952
JP
33BuildRequires: pkgconfig
34BuildRequires: python3 >= 1:3.4
35BuildRequires: python3-devel >= 1:3.4
36BuildRequires: sqlite3-devel
37BuildRequires: tinyxml-devel
9dda6696
AM
38BuildRequires: tinyxpath-devel
39BuildRequires: zlib-devel
06cb1c68
AM
40Requires(pre): /usr/sbin/groupadd
41Requires(pre): /usr/sbin/useradd
9dda6696
AM
42Requires(post): systemd
43Requires(postun): systemd
44Requires(preun): systemd
06cb1c68 45Requires: fonts-TTF-Google-Droid
4987f952 46Requires: libopenzwave >= 1.5.0
9dda6696
AM
47Provides: bundled(js-ace)
48Provides: bundled(js-angular-ui-bootstrap) = 0.13.4
49Provides: bundled(js-angularamd) = 0.2.1
50Provides: bundled(js-angularjs) = 1.5.8
51Provides: bundled(js-blockly)
52Provides: bundled(js-bootbox)
53Provides: bundled(js-bootstrap) = 3.2.0
54Provides: bundled(js-colpick)
55Provides: bundled(js-d3)
56Provides: bundled(js-datatables-datatools) = 2.2.3
57Provides: bundled(js-dateformat) = 1.2.3
58Provides: bundled(js-filesaver) = 0.0-git20140725
59Provides: bundled(js-highcharts) = 4.2.6
60Provides: bundled(js-html5shiv) = 3.6.2
61Provides: bundled(js-i18next) = 1.8.0
62Provides: bundled(js-ion-sound) = 3.0.6
63Provides: bundled(js-jquery) = 1.12.0
64Provides: bundled(js-jquery-noty) = 2.1.0
65Provides: bundled(js-less) = 1.3.0
66Provides: bundled(js-ngdraggable)
67Provides: bundled(js-nggrid)
68Provides: bundled(js-ozwcp)
69Provides: bundled(js-require) = 2.1.14
70Provides: bundled(js-respond) = 1.1.0
71Provides: bundled(js-wow) = 0.1.9
72Provides: bundled(js-zeroclipboard) = 1.0.4
73
74%description
75Domoticz is a Home Automation System that lets you monitor and
76configure various devices like: Lights, Switches, various
77sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
78and much more. Notifications/Alerts can be sent to any mobile device
79
80%prep
72784cf7 81%setup -q
bc226567
JP
82%patch0 -p1
83%patch1 -p1
84%patch2 -p1
85%patch3 -p1
86%patch4 -p1
10f7a92e
AM
87
88APPVERSION="%{version}"
89echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
90echo '#define APPHASH "%{snap}"' >> appversion.h
91APPDATE=$(date --date="%{date}" "+%s")
92echo "#define APPDATE ${APPDATE}" >> appversion.h
93
9dda6696
AM
94rm -f hardware/openzwave/*.h
95rm -rf hardware/openzwave/aes
96rm -rf hardware/openzwave/command_classes
97rm -rf hardware/openzwave/platform
98rm -rf hardware/openzwave/value_classes
99rm -rf sqlite/
100rm -rf tinyxpath/
101
102%build
103install -d build && cd build
104%cmake \
4987f952
JP
105 -DUSE_BUILTIN_JSONCPP=NO \
106 -DUSE_BUILTIN_MINIZIP=NO \
71593ba7
JR
107 -DUSE_BUILTIN_MQTT=NO \
108 -DUSE_BUILTIN_SQLITE=NO \
109 -DUSE_BUILTIN_TINYXPATH=NO \
4987f952
JP
110 -DUSE_LUA_STATIC=NO \
111 -DUSE_OPENSSL_STATIC=NO \
71593ba7 112 -DUSE_STATIC_BOOST=NO \
4987f952
JP
113 -DUSE_STATIC_LIBSTDCXX=NO \
114 -DUSE_STATIC_OPENZWAVE=NO \
71593ba7
JR
115 -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
116 ..
00bce45c 117
9dda6696
AM
118%{__make}
119
120%install
121rm -rf $RPM_BUILD_ROOT
00bce45c
AM
122%{__make} -C build install \
123 DESTDIR=$RPM_BUILD_ROOT
9dda6696
AM
124
125# remove docs, we grab them in files below
126rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
127
128# move binary to standard directory
129install -d $RPM_BUILD_ROOT%{_bindir}/
130mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/
131
132# install systemd service and config
133install -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
134install -d $RPM_BUILD_ROOT%{systemdunitdir}/
135cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/
136cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
137
138# create database/ssl cert directory
139install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/
140
141# Disable the app's self-update script
142
143# Unbundle DroidSans.ttf
144rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/DroidSans.ttf
06cb1c68 145ln -s /usr/share/fonts/TTF/DroidSans.ttf \
9dda6696
AM
146 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/
147rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/DroidSans.ttf
06cb1c68 148ln -s /usr/share/fonts/TTF/DroidSans.ttf \
9dda6696
AM
149 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/
150rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/DroidSans.ttf
06cb1c68 151ln -s /usr/share/fonts/TTF/DroidSans.ttf \
9dda6696
AM
152 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/
153
154# OpenZWave Control Panel temp file
155ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
156 $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
157
158%clean
159rm -rf $RPM_BUILD_ROOT
160
161%pre
162getent group domoticz >/dev/null || groupadd -r domoticz
163getent passwd domoticz >/dev/null || \
164useradd -r -g domoticz -d %{_datadir}/%{name} -s /sbin/nologin \
165-c "Domoticz Home Automation Server" domoticz
166# For OpenZWave USB access (/dev/ttyACM#)
167usermod -G domoticz,dialout domoticz
168
169%post
170%systemd_post %{name}.service
171
172%preun
173%systemd_preun %{name}.service
174
175%postun
5ac2f181 176%systemd_reload
9dda6696
AM
177
178%files
179%defattr(644,root,root,755)
180%doc License.txt
181%doc README.md History.txt
182%attr(755,root,root) %{_bindir}/%{name}
183%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
184%{_datadir}/%{name}/
185%attr(755,domoticz,domoticz) %{_sharedstatedir}/%{name}/
186%{systemdunitdir}/%{name}.service
This page took 0.112069 seconds and 4 git commands to generate.