]> git.pld-linux.org Git - packages/domoticz.git/blame - domoticz.spec
fix build with python 3.9
[packages/domoticz.git] / domoticz.spec
CommitLineData
9dda6696
AM
1Summary: Open source Home Automation System
2Name: domoticz
72784cf7 3Version: 2020.2
0abc31de 4Release: 3
9dda6696
AM
5License: GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6Group: Base
7URL: http://www.domoticz.com
72784cf7
AM
8Source0: https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
9# Source0-md5: fd383a13d13d0976c72f332d6db1d24e
9dda6696
AM
10Source1: %{name}.service
11Source2: %{name}.conf
9dda6696 12# Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
bc226567 13Patch0: %{name}-tinyxpath.patch
9dda6696 14# Use system openzwave includes
bc226567 15Patch1: %{name}-openzwave.patch
9dda6696 16# Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
bc226567
JP
17Patch2: %{name}-python.patch
18Patch3: no-git.patch
19Patch4: boost-1.73.patch
c8cb4cfe 20Patch5: %{name}-gpio.patch
2fd2c1d4 21Patch6: python3.9.patch
4987f952 22BuildRequires: boost-devel >= 1.66.0
72784cf7 23BuildRequires: cereal-devel
4987f952 24BuildRequires: cmake >= 3.16.0
9dda6696 25BuildRequires: curl-devel
4987f952 26BuildRequires: jsoncpp-devel
9dda6696 27BuildRequires: libmosquitto-devel
9dda6696 28BuildRequires: libopenzwave-devel >= 1.5.0
4987f952
JP
29BuildRequires: libstdc++-devel >= 6:4.8.1
30BuildRequires: libusb-compat-devel
31BuildRequires: linux-libc-headers
32BuildRequires: lua53-devel
72784cf7 33BuildRequires: minizip-devel
9dda6696 34BuildRequires: openssl-devel
4987f952
JP
35BuildRequires: pkgconfig
36BuildRequires: python3 >= 1:3.4
37BuildRequires: python3-devel >= 1:3.4
f5d0e494 38BuildRequires: rpmbuild(macros) >= 1.644
4987f952
JP
39BuildRequires: sqlite3-devel
40BuildRequires: tinyxml-devel
9dda6696
AM
41BuildRequires: tinyxpath-devel
42BuildRequires: zlib-devel
0e22aa87
JP
43Requires(pre): /usr/sbin/groupadd
44Requires(pre): /usr/sbin/useradd
45Requires(post,preun,postun): systemd-units >= 38
46Requires: fonts-TTF-Google-Droid
4987f952 47Requires: libopenzwave >= 1.5.0
ed4fe787
JP
48Provides: group(domoticz)
49Provides: user(domoticz)
9dda6696
AM
50
51%description
52Domoticz is a Home Automation System that lets you monitor and
53configure various devices like: Lights, Switches, various
54sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
55and much more. Notifications/Alerts can be sent to any mobile device
56
57%prep
72784cf7 58%setup -q
bc226567
JP
59%patch0 -p1
60%patch1 -p1
61%patch2 -p1
62%patch3 -p1
63%patch4 -p1
c8cb4cfe 64%patch5 -p1
2fd2c1d4 65%patch6 -p1
10f7a92e
AM
66
67APPVERSION="%{version}"
68echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
69echo '#define APPHASH "%{snap}"' >> appversion.h
70APPDATE=$(date --date="%{date}" "+%s")
71echo "#define APPDATE ${APPDATE}" >> appversion.h
72
0e22aa87 73%{__rm} -r extern tinyxpath
9dda6696
AM
74
75%build
76install -d build && cd build
77%cmake \
4987f952
JP
78 -DUSE_BUILTIN_JSONCPP=NO \
79 -DUSE_BUILTIN_MINIZIP=NO \
71593ba7
JR
80 -DUSE_BUILTIN_MQTT=NO \
81 -DUSE_BUILTIN_SQLITE=NO \
82 -DUSE_BUILTIN_TINYXPATH=NO \
4987f952
JP
83 -DUSE_LUA_STATIC=NO \
84 -DUSE_OPENSSL_STATIC=NO \
71593ba7 85 -DUSE_STATIC_BOOST=NO \
4987f952
JP
86 -DUSE_STATIC_LIBSTDCXX=NO \
87 -DUSE_STATIC_OPENZWAVE=NO \
71593ba7
JR
88 -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
89 ..
00bce45c 90
9dda6696
AM
91%{__make}
92
93%install
94rm -rf $RPM_BUILD_ROOT
0e22aa87 95
00bce45c 96%{__make} -C build install \
0e22aa87
JP
97 DESTDIR=$RPM_BUILD_ROOT
98
99install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/sysconfig,%{systemdunitdir},%{_sharedstatedir}/%{name}}
9dda6696
AM
100
101# remove docs, we grab them in files below
0e22aa87 102%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
9dda6696
AM
103
104# move binary to standard directory
0e22aa87 105mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}
9dda6696 106
0e22aa87 107cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}
9dda6696
AM
108cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
109
9dda6696 110# Unbundle DroidSans.ttf
0e22aa87
JP
111%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element{al,-light,-dark}/fonts/DroidSans.ttf
112ln -s %{_fontsdir}/TTF/DroidSans.ttf \
113 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts
114ln -s %{_fontsdir}/TTF/DroidSans.ttf \
115 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts
116ln -s %{_fontsdir}/TTF/DroidSans.ttf \
117 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts
9dda6696
AM
118
119# OpenZWave Control Panel temp file
120ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
0e22aa87 121 $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
9dda6696
AM
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%pre
ed4fe787
JP
127%groupadd -g 342 domoticz
128%useradd -u 342 -r -d %{_datadir} -s /bin/false -c "Domoticz Home Automation Server" -G dialout -g domoticz domoticz
9dda6696
AM
129
130%post
131%systemd_post %{name}.service
132
133%preun
134%systemd_preun %{name}.service
135
136%postun
ed4fe787
JP
137if [ "$1" = "0" ]; then
138 %userremove mpd
139 %groupremove mpd
140fi
5ac2f181 141%systemd_reload
9dda6696
AM
142
143%files
144%defattr(644,root,root,755)
0e22aa87 145%doc License.txt README.md History.txt
9dda6696
AM
146%attr(755,root,root) %{_bindir}/%{name}
147%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
0e22aa87
JP
148%{_datadir}/%{name}
149%dir %attr(750,domoticz,domoticz) %{_sharedstatedir}/%{name}
9dda6696 150%{systemdunitdir}/%{name}.service
This page took 0.144178 seconds and 4 git commands to generate.