]> git.pld-linux.org Git - packages/doldaconnect.git/blob - doldaconnect.spec
- typo
[packages/doldaconnect.git] / doldaconnect.spec
1 # TODO:
2 # - use the same macros as in other gaim plugins packages
3 # - separate subpackage with backend? pam-file and init-script from gentoo is in contrib
4 # - build with guile extension and add dchub:// guile module
5 # - add desktop
6 # - some findlang needed
7 Summary:        Direct Connect client
8 Name:           doldaconnect
9 Version:        0.1
10 Release:        0.4
11 License:        GPL v2
12 Group:          X11/Applications/Networking
13 Source0:        http://www.dolda2000.com/~fredrik/doldaconnect/%{name}-%{version}.tar.gz
14 # Source0-md5:  8920593ede9d7866937cd2feb95923a8
15 #Source1:       %{name}.desktop
16 URL:            http://www.dolda2000.com/~fredrik/doldaconnect/
17 BuildRequires:  automake
18 BuildRequires:  bzip2-devel
19 BuildRequires:  gaim-devel
20 BuildRequires:  gnome-panel-devel
21 BuildRequires:  libtool
22 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _appconfdir     /etc/%{name}
26
27 %description
28 Dolda Connect is a client program for the Direct Connect peer-to-peer filesharing network, written for GNU/Linux systems. It is possible that it may run on other Unix systems as well, as long as it is compiled with GCC, but this is untested so far. It is licensed under the GPL, version 2 or later.
29
30 It consists of two parts - the client daemon and the user interface. The daemon is what does all the job of sharing files, searching, connecting to hubs, etc., while the user interface is a simple program that connects to the daemon in order to control it and give the user the current status of the daemon (such as the file transfers currently in progress, etc.). These two program run independently of each other, and the user interface can therefore be made to connect to a daemon running on another computer, over the internet or otherwise. For the average user, this yields two primary advantages:
31
32  * The daemon can be made to run on another computer, which can be on all the time (a server, if you will), while the user interface can run on the user's workstation. That way, the user can turn off his workstation at night, while the server will continue all transfers in progress during that time.
33  * A user can control his daemon from another location, such as from work, school, a friend, etc.
34
35 This architecture also has many other advantages in store for the more advanced users; since the user interface communicates with the daemon using a well-defined protocol, other user interfaces can be written, such as an automatic downloader, a chatbot, etc. It is also designed for secure multiuser operation.
36
37 %package libs
38 Summary:        Libraries for %{name}
39 Group:          Libraries
40
41 %description libs
42 Libraries for %{name}.
43
44 %package -n gaim-plugin-%{name}
45 Summary:        Gaim plugin for %{name}
46 Group:          Applications/Communications
47 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
48
49 %description -n gaim-plugin-%{name}
50 Gaim plugin for %{name}.
51
52 %package devel
53 Summary:        %{name} library header files
54 Group:          Development/Libraries
55 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
56
57 %description devel
58 %{name} library header files.
59
60 %package static
61 Summary:        Static %{name} library
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
64
65 %description static
66 Static %{name} library.
67
68 %prep
69 %setup -q
70
71 %build
72 %configure \
73         --sysconfdir=%{_appconfdir} \
74         --disable-rpath \
75         --enable-gtk2ui \
76         --enable-gtk2pbar \
77         --enable-gnomeapplet \
78         --enable-gaimplugin
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 #install -d $RPM_BUILD_ROOT%{_desktopdir}
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 #install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
90
91 %find_lang %{name}
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   libs -p /sbin/ldconfig
97 %postun libs -p /sbin/ldconfig
98
99 %files -f %{name}.lang
100 %defattr(644,root,root,755)
101 %doc AUTHORS ChangeLog INSTALL README 
102 %dir %{_appconfdir}
103 %config(noreplace) %{_appconfdir}/*
104 %attr(755,root,root) %{_bindir}/*
105 %attr(755,root,root) %{_libdir}/bonobo/servers/*.server
106 %attr(755,root,root) %{_libdir}/dolcon-trans-applet
107 %attr(755,root,root) %{_libdir}/speedrec
108 #%{_desktopdir}/%{name}.desktop
109 %{_pixmapsdir}/*.jpg
110
111 %files libs
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_libdir}/*.so.*.*.*
114
115 %files -n gaim-plugin-%{name}
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/gaim/libdolcon-gaim.so
118
119 %files devel
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/lib*.so
122 %{_libdir}/lib*.la
123 %dir %{_includedir}/%{name}
124 %{_includedir}/%{name}/*.h
125
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/lib*.a
129 %{_libdir}/gaim/*.a
This page took 0.07358 seconds and 3 git commands to generate.