]> git.pld-linux.org Git - packages/doldaconnect.git/blob - doldaconnect.spec
- more BR
[packages/doldaconnect.git] / doldaconnect.spec
1 # TODO:
2 # - use the same macros as in other gaim plugins packages
3 # - package guile app to some subpackage
4 # - package gnome applet to separate package
5 Summary:        Direct Connect client
6 Name:           doldaconnect
7 Version:        0.1
8 Release:        0.7
9 License:        GPL v2
10 Group:          X11/Applications/Networking
11 Source0:        http://www.dolda2000.com/~fredrik/doldaconnect/%{name}-%{version}.tar.gz
12 # Source0-md5:  8920593ede9d7866937cd2feb95923a8
13 Source1:        %{name}.desktop
14 Source2:        %{name}.init
15 Source3:        %{name}.pam
16 URL:            http://www.dolda2000.com/~fredrik/doldaconnect/
17 BuildRequires:  automake
18 BuildRequires:  bzip2-devel
19 BuildRequires:  gaim-devel
20 BuildRequires:  gnome-panel-devel
21 BuildRequires:  guile-devel
22 BuildRequires:  libltdl-devel
23 BuildRequires:  libtool
24 BuildRequires:  pam-devel
25 BuildRequires:  rpmbuild(macros) >= 1.268
26 Requires:       %{name}-libs = %{version}-%{release}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _appconfdir     /etc/%{name}
30
31 %description
32 Dolda Connect is a client program for the Direct Connect peer-to-peer
33 filesharing network, written for GNU/Linux systems. It is possible
34 that it may run on other Unix systems as well, as long as it is
35 compiled with GCC, but this is untested so far.
36
37 It consists of two parts - the client daemon and the user interface.
38 The daemon is what does all the job of sharing files, searching,
39 connecting to hubs, etc., while the user interface is a simple program
40 that connects to the daemon in order to control it and give the user
41 the current status of the daemon (such as the file transfers currently
42 in progress, etc.). These two program run independently of each other,
43 and the user interface can therefore be made to connect to a daemon
44 running on another computer, over the internet or otherwise. For the
45 average user, this yields two primary advantages:
46
47 - The daemon can be made to run on another computer, which can be on
48   all the time (a server, if you will), while the user interface can run
49   on the user's workstation. That way, the user can turn off his
50   workstation at night, while the server will continue all transfers in
51   progress during that time.
52 - A user can control his daemon from another location, such as from
53   work, school, a friend, etc.
54
55 This architecture also has many other advantages in store for the more
56 advanced users; since the user interface communicates with the daemon
57 using a well-defined protocol, other user interfaces can be written,
58 such as an automatic downloader, a chatbot, etc. It is also designed
59 for secure multiuser operation.
60
61 %package libs
62 Summary:        Libraries for %{name}
63 Group:          Libraries
64
65 %description libs
66 Libraries for %{name}.
67
68 %package -n doldacond
69 Summary:        Daemon for %{name}
70 Group:          Daemons
71 Requires(post,preun):   /sbin/chkconfig
72 Requires:       rc-scripts
73
74 %description -n doldacond
75 Daemon for %{name} that handles all of the network connections.
76
77 %package -n gaim-plugin-%{name}
78 Summary:        Gaim plugin for %{name}
79 Group:          Applications/Communications
80 Requires:       %{name}-libs = %{version}-%{release}
81
82 %description -n gaim-plugin-%{name}
83 Gaim plugin for %{name}.
84
85 %package devel
86 Summary:        %{name} library header files
87 Group:          Development/Libraries
88 Requires:       %{name}-libs = %{version}-%{release}
89
90 %description devel
91 %{name} library header files.
92
93 %package static
94 Summary:        Static %{name} library
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97
98 %description static
99 Static %{name} library.
100
101 %prep
102 %setup -q
103
104 %build
105 %configure \
106         --sysconfdir=%{_appconfdir} \
107         --disable-rpath \
108         --with-guile \
109         --enable-gtk2ui \
110         --enable-gtk2pbar \
111         --enable-gnomeapplet \
112         --enable-gaimplugin
113
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT{%{_desktopdir},/etc/{rc.d/init.d,pam.d,sysconfig}}
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
124 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/doldacond
125 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/doldacond
126
127 %find_lang %{name}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   libs -p /sbin/ldconfig
133 %postun libs -p /sbin/ldconfig
134
135 %post -n doldacond
136 /sbin/chkconfig --add doldacond
137 %service doldacond restart
138
139 %preun -n doldacond
140 if [ "$1" = 0 ]; then
141         %service doldacond stop
142         /sbin/chkconfig --del doldacond
143 fi
144
145 %files -f %{name}.lang
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/dolcon
148 %attr(755,root,root) %{_libdir}/bonobo/servers/*.server
149 %attr(755,root,root) %{_libdir}/dolcon-trans-applet
150 %attr(755,root,root) %{_libdir}/speedrec
151 %{_desktopdir}/%{name}.desktop
152 %{_pixmapsdir}/*.jpg
153
154 %files libs
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/*.so.*.*.*
157
158 %files -n doldacond
159 %defattr(644,root,root,755)
160 %doc AUTHORS ChangeLog INSTALL README
161 %dir %{_appconfdir}
162 %config(noreplace) %verify(not md5 mtime size) %{_appconfdir}/*
163 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/doldacond
164 %attr(754,root,root) /etc/rc.d/init.d/doldacond
165 %attr(755,root,root) %{_bindir}/doldacond
166 %attr(755,root,root) %{_bindir}/locktouch
167 %attr(755,root,root) %{_bindir}/tthsum
168
169 %files -n gaim-plugin-%{name}
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/gaim/libdolcon-gaim.so
172
173 %files devel
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/lib*.so
176 %{_libdir}/lib*.la
177 %dir %{_includedir}/%{name}
178 %{_includedir}/%{name}/*.h
179
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/lib*.a
183 %{_libdir}/gaim/*.a
This page took 0.066021 seconds and 3 git commands to generate.