]> git.pld-linux.org Git - packages/dokuwiki.git/commitdiff
Allow lowercase authorization header
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 28 Apr 2023 21:54:42 +0000 (00:54 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Fri, 28 Apr 2023 21:54:42 +0000 (00:54 +0300)
dokuwiki.spec
tokenauth-lowercase-header.patch [new file with mode: 0644]

index 1521337a0f5cd519f8f0c7ba530de1de937faf39..737444aadc7d6a73cd467c2e1986a5ff3d247b3d 100644 (file)
@@ -44,6 +44,7 @@ Patch24:      more-buttons.patch
 Patch27:       iconsizes-dump.patch
 Patch28:       https://github.com/dokuwiki/dokuwiki/pull/2432.diff
 # Patch28-md5: 5afbddfdd2b5c3a72377ead41da555af
+Patch29:       tokenauth-lowercase-header.patch
 URL:           https://www.dokuwiki.org/
 BuildRequires: fslint
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
@@ -137,6 +138,7 @@ echo '====== PlayGround ======' >  data/pages/playground/playground.txt
 #%patch24 -p1
 %patch27 -p1
 %patch28 -p1
+%patch29 -p1
 %patch66 -p1
 
 # package as basenames, upgrade overwrite protected with .rpmnew
diff --git a/tokenauth-lowercase-header.patch b/tokenauth-lowercase-header.patch
new file mode 100644 (file)
index 0000000..b835e2b
--- /dev/null
@@ -0,0 +1,10 @@
+--- dokuwiki-2023-04-04/inc/auth.php~  2023-04-28 23:43:03.000000000 +0300
++++ dokuwiki-2023-04-04/inc/auth.php   2023-04-29 00:53:43.324078441 +0300
+@@ -177,6 +177,7 @@
+         // Authorization headers are not in $_SERVER for mod_php
+         $headers = apache_request_headers();
+         if(isset($headers['Authorization'])) $header = $headers['Authorization'];
++        if(!$header && isset($headers['authorization'])) $header = $headers['authorization'];
+     } else {
+         $header = $INPUT->server->str('HTTP_AUTHORIZATION');
+     }
This page took 0.15331 seconds and 4 git commands to generate.