]> git.pld-linux.org Git - packages/dokuwiki.git/blobdiff - dokuwiki.spec
- migrate to apache 2.4
[packages/dokuwiki.git] / dokuwiki.spec
index 4f70fe23830356796c5d59190de4dce3b849e15f..9d4d6bc57600537bd420223dfa41e83e355f83d6 100644 (file)
@@ -1,18 +1,18 @@
-%define                subver  2012-07-19
+%define                subver  2012-10-13
 %define                ver             %(echo %{subver} | tr -d -)
-%define                snap    1
+#define                snap    1
 %define                php_min_version 5.2.4
 %include       /usr/lib/rpm/macros.php
 Summary:       PHP-based Wiki webapplication
 Summary(pl.UTF-8):     Aplikacja WWW Wiki oparta na PHP
 Name:          dokuwiki
 Version:       %{ver}
-Release:       0.6
+Release:       3
 License:       GPL v2
 Group:         Applications/WWW
-#Source0:      http://www.splitbrain.org/_media/projects/dokuwiki/%{name}-%{subver}.tgz
-Source0:       http://github.com/splitbrain/dokuwiki/tarball/master/%{name}-%{subver}.tgz
-# Source0-md5: 81b5f839ae2c3ac8f664ebf87d29638a
+Source0:       http://www.splitbrain.org/_media/projects/dokuwiki/%{name}-%{subver}.tgz
+# Source0-md5: a910ebb2fcca13c0337ed672304c4ad4
+#Source0:      http://github.com/splitbrain/dokuwiki/tarball/master/%{name}-%{subver}.tgz
 Source1:       %{name}-apache.conf
 Source2:       %{name}-lighttpd.conf
 Source3:       http://glen.alkohol.ee/pld/jude.png
@@ -27,9 +27,11 @@ Source9:     http://trac.edgewall.org/export/9404/trunk/doc/trac_icon_16x16.png
 Source10:      pld.gif
 Source11:      http://glen.alkohol.ee/pld/astah.png
 # Source11-md5:        b1c999e6988440c9e2af6a12e9a56451
+Source12:      %{name}-httpd.conf
 Patch66:       %{name}-config.patch
 Patch0:                %{name}-paths.patch
 Patch1:                system-jquery.patch
+Patch2:                style-width.patch
 Patch4:                %{name}-geshi.patch
 Patch5:                %{name}-http_auth-option.patch
 Patch6:                %{name}-nice_exit.patch
@@ -37,7 +39,6 @@ Patch8:               %{name}-notify-respect-minor.patch
 Patch10:       %{name}-mailtext.patch
 Patch11:       %{name}-notifyns.patch
 Patch12:       %{name}-mailthreads.patch
-Patch13:       %{name}-media-directlink.patch
 Patch14:       interwiki-outputonly.patch
 Patch15:       simplepie.patch
 Patch19:       pld-branding.patch
@@ -46,18 +47,18 @@ Patch21:    task-1821.patch
 Patch22:       adldap.patch
 Patch23:       backlink-rightside.patch
 Patch24:       more-buttons.patch
-URL:           http://www.dokuwiki.org/dokuwiki
+URL:           https://www.dokuwiki.org/
 BuildRequires: fslint
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
 BuildRequires: rpmbuild(macros) >= 1.520
 Requires:      jquery >= 1.6
 Requires:      jquery-cookie
 Requires:      jquery-ui
-Requires:      php-common >= 4:%{php_min_version}
+Requires:      php(core) >= %{php_min_version}
+Requires:      php(session)
+Requires:      php(xml)
 Requires:      php-geshi >= 1.0.7.19
-Requires:      php-session
 Requires:      php-simplepie >= 1.0.1
-Requires:      php-xml
 Requires:      webapps
 Requires:      webserver(access)
 Requires:      webserver(alias)
@@ -65,6 +66,8 @@ Requires:     webserver(php)
 Suggests:      php-adldap >= 3.3.1
 Suggests:      php-gd
 Obsoletes:     dokuwiki-plugin-jquery
+Conflicts:     apache-base < 2.4.0-1
+Conflicts:     dokuwiki-plugin-icalevents < 20120909
 # can use gz compression to store attic pages
 Suggests:      php-zlib
 BuildArch:     noarch
@@ -79,7 +82,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                find_lang       %{_usrlibrpm}/dokuwiki-find-lang.sh %{buildroot}
 
 # bad depsolver
-%define                _noautopear     pear(/usr/share/php/geshi.php) pear(/usr/share/php/adLDAP.php)
+%define                _noautopear     pear./usr/share/php/geshi.php pear./usr/share/php/adLDAP.php
 
 # exclude optional php dependencies
 %define                _noautophp      php-bzip2 php-bcmath php-zip php-date php-ftp php-hash php-ldap php-mbstring php-mysql php-pgsql php-tokenizer
@@ -129,6 +132,7 @@ touch data/pages/playground/playground.txt
 %endif
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
@@ -136,7 +140,6 @@ touch data/pages/playground/playground.txt
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
-%patch13 -p1
 %patch14 -p1
 %patch15 -p1
 %patch19 -p1
@@ -155,7 +158,7 @@ mv conf/users.auth.php{.dist,}
 mv conf/mysql.conf.php{.example,}
 
 find -name _dummy | xargs rm
-%{__rm} lib/index.html lib/plugins/index.html inc/lang/.htaccess
+%{__rm} lib/index.html lib/plugins/index.html lib/images/index.html inc/lang/.htaccess
 
 # we just don't package deleted files, these get removed automatically on rpm upgrades
 %{__rm} data/deleted.files
@@ -201,7 +204,7 @@ cp -a$l lib/* $RPM_BUILD_ROOT%{_appdir}/lib
 cp -a$l conf/* $RPM_BUILD_ROOT%{_sysconfdir}
 cp -a$l data/* $RPM_BUILD_ROOT%{_localstatedir}
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
-cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
+cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
 touch $RPM_BUILD_ROOT%{_sysconfdir}/acronyms.local.conf
 touch $RPM_BUILD_ROOT%{_sysconfdir}/entities.local.conf
@@ -223,7 +226,8 @@ cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_appdir}/lib/images/interwiki/pld.gif
 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_appdir}/lib/images/fileicons/jude.png
 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{_appdir}/lib/images/fileicons/asta.png
 
-cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_appdir}/lib/tpl/default/images/button-pld.png
+cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_appdir}/lib/tpl/dokuwiki/images/button-pld.png
+ln $RPM_BUILD_ROOT%{_appdir}/lib/tpl/{dokuwiki,default}/images/button-pld.png
 
 # hardlink identical icons.
 findup -m $RPM_BUILD_ROOT
@@ -254,10 +258,10 @@ fi
 %triggerun -- apache1 < 1.3.37-3, apache1-base
 %webapp_unregister apache %{_webapp}
 
-%triggerin -- apache < 2.2.0, apache-base
+%triggerin -- apache-base
 %webapp_register httpd %{_webapp}
 
-%triggerun -- apache < 2.2.0, apache-base
+%triggerun -- apache-base
 %webapp_unregister httpd %{_webapp}
 
 %triggerin -- lighttpd
@@ -340,7 +344,9 @@ exit 0
 %{_appdir}/inc/parser
 
 %dir %{_appdir}/lib
-%dir %{_appdir}/lib/plugins
+# allow plugins dir permission change to allow installation of plugins from admin
+# however does not work with rpm 4.5
+%dir %config %verify(not group mode) %{_appdir}/lib/plugins
 %dir %{_appdir}/lib/plugins/acl
 %{_appdir}/lib/plugins/acl/*.*
 %{_appdir}/lib/plugins/acl/pix
This page took 0.139292 seconds and 4 git commands to generate.