]> git.pld-linux.org Git - packages/dokuwiki-plugin-s5.git/commitdiff
up to 2016-02-03 auto/th/dokuwiki-plugin-s5-20160203-1
authorElan Ruusamäe <glen@delfi.ee>
Thu, 17 Aug 2017 19:17:00 +0000 (22:17 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 17 Aug 2017 19:17:17 +0000 (22:17 +0300)
dokuwiki-find-lang.sh [deleted file]
dokuwiki-plugin-s5.spec

diff --git a/dokuwiki-find-lang.sh b/dokuwiki-find-lang.sh
deleted file mode 100644 (file)
index db54c83..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-#!/bin/sh
-PROG=${0##*/}
-dir=$RPM_BUILD_ROOT/usr/share/dokuwiki
-langfile=$1
-tmp=$(mktemp) || exit 1
-rc=0
-
-find $dir -type d -name lang > $tmp
-
-echo '%defattr(644,root,root,755)' > $langfile
-while read dir; do
-       echo "%dir ${dir#$RPM_BUILD_ROOT}" >> $langfile
-       for dir in $dir/*; do
-               lang=${dir##*/}
-               dir=${dir#$RPM_BUILD_ROOT}
-               case "$lang" in
-               zh-tw)
-                       lang=zh_TW
-               ;;
-               pt-br)
-                       lang=pt_BR
-               ;;
-               sl-si)
-                       lang=sl
-               ;;
-               id-ni)
-                       lang=id_NI
-               ;;
-               ca-va)
-                       lang=ca_VA
-               ;;
-               *-*)
-                       echo >&2 "ERROR: Need mapping for $lang!"
-                       rc=1
-               ;;
-               esac
-               echo "%lang($lang) ${dir#$RPM_BUILD_ROOT}" >> $langfile
-       done
-done < $tmp
-
-if [ "$(egrep -v '(^%defattr|^$)' $langfile | wc -l)" -le 0 ]; then
-       echo >&2 "$PROG: Error: international files not found!"
-       rc=1
-fi
-
-rm -f $tmp
-exit $rc
index d0116be842f844ce495fac77f0e9f369c08e50f0..d0afdb817cdf9b6015fb2f5c9a687452716a3a73 100644 (file)
@@ -1,41 +1,46 @@
+%define                subver  2016-02-03
+%define                ver             %(echo %{subver} | tr -d -)
 %define                plugin          s5
+%define                php_min_version 5.3.0
+%include       /usr/lib/rpm/macros.php
 Summary:       S5 Slideshow Plugin
 Name:          dokuwiki-plugin-%{plugin}
-Version:       20080620
+Version:       %{ver}
 Release:       1
 License:       GPL v2
 Group:         Applications/WWW
-Source0:       http://dev.splitbrain.org/download/snapshots/s5-plugin-latest.tgz
-# Source0-md5: c6d8ac79fec6a5095d0bce69c1c4d407
-Source1:       dokuwiki-find-lang.sh
-URL:           http://wiki.splitbrain.org/plugin:s5
-Requires:      dokuwiki >= 20061106
+Source0:       https://github.com/splitbrain/dokuwiki-plugin-s5/archive/%{subver}/%{plugin}-%{subver}.tar.gz
+# Source0-md5: 97cb941d3e53cbccada7005dc7fde6d1
+URL:           https://www.dokuwiki.org/plugin:s5
+BuildRequires: rpmbuild(macros) >= 1.553
+Requires:      php(core) >= %{php_min_version}
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                dokuconf        /etc/webapps/dokuwiki
 %define                dokudir         /usr/share/dokuwiki
 %define                plugindir       %{dokudir}/lib/plugins/%{plugin}
+%define                find_lang       %{_usrlibrpm}/dokuwiki-find-lang.sh %{buildroot}
 
 %description
-S5 is a slide show format based entirely on XHTML, CSS, and JavaScript. With
-one file, you can run a complete slide show and have a printer-friendly version
-as well. 
+S5 is a slide show format based entirely on XHTML, CSS, and
+JavaScript. With one file, you can run a complete slide show and have
+a printer-friendly version as well.
 
-This plugin can create S5 slide show presentations from any DokuWiki page. 
+This plugin can create S5 slide show presentations from any DokuWiki
+page.
 
 %prep
-%setup -q -n %{plugin}
+%setup -qc
+mv *-%{plugin}-*/* .
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{plugindir}
-rm -f %{name}.lang
 cp -a . $RPM_BUILD_ROOT%{plugindir}
-rm -f $RPM_BUILD_ROOT%{plugindir}/{COPYING,README,VERSION}
+rm $RPM_BUILD_ROOT%{plugindir}/README
 
-# find locales
-sh %{SOURCE1} %{name}.lang
+%find_lang %{name}.lang
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.054608 seconds and 4 git commands to generate.