]> git.pld-linux.org Git - packages/dokuwiki-plugin-orphanswanted.git/blob - dokuwiki-plugin-orphanswanted.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/dokuwiki-plugin-orphanswanted.git] / dokuwiki-plugin-orphanswanted.spec
1 %define         subver  2017-06-25
2 %define         ver             %(echo %{subver} | tr -d -)
3 %define         plugin          orphanswanted
4 %define         php_min_version 5.3.0
5 Summary:        DokuWiki plugin to find orphan pages, Wanted pages with reference counts
6 Name:           dokuwiki-plugin-%{plugin}
7 Version:        %{ver}
8 Release:        1
9 License:        GPL v2
10 Group:          Applications/WWW
11 Source0:        https://github.com/lupo49/dokuwiki-plugin-orphanswanted/archive/163625f/%{plugin}-%{subver}.tar.gz
12 # Source0-md5:  b14fbb365e9b9e0dfcde770e7b50a0d3
13 URL:            https://www.dokuwiki.org/plugin:orphanswanted
14 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
15 BuildRequires:  rpmbuild(macros) >= 1.553
16 Requires:       dokuwiki >= 20131208
17 Requires:       php(core) >= %{php_min_version}
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         dokuconf        /etc/webapps/dokuwiki
22 %define         dokudir         /usr/share/dokuwiki
23 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
24 %define         find_lang       %{_usrlibrpm}/dokuwiki-find-lang.sh %{buildroot}
25
26 %description
27 Use this plugin to find orphan pages and wanted pages.
28
29 OrphansWanted show which pages are:
30 - Orphans (the page exists, but it has no links to it)
31 - Wanted (the page does not exist, but there are link(s) to it
32   elsewhere on the site)
33 - Valid (the page exists, and it can be reached through a link)
34
35 Each table shows the reference count and a link to backlinks.
36
37 %prep
38 %setup -qc
39 mv *-%{plugin}-*/* .
40
41 %build
42 version=$(awk '/^date/{print $2}' plugin.info.txt)
43 if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
44         : %%{version} mismatch
45         exit 1
46 fi
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{plugindir}
51 cp -a . $RPM_BUILD_ROOT%{plugindir}
52 rm $RPM_BUILD_ROOT%{plugindir}/{COPYING,README}
53
54 %find_lang %{name}.lang
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files -f %{name}.lang
60 %defattr(644,root,root,755)
61 %doc README
62 %dir %{plugindir}
63 %{plugindir}/*.php
64 %{plugindir}/*.txt
65 %{plugindir}/conf
This page took 0.953607 seconds and 3 git commands to generate.