]> git.pld-linux.org Git - packages/dokuwiki-plugin-move.git/blame - dokuwiki-plugin-move.spec
New version 2015-10-17 released. Bug fixes and translation updates.
[packages/dokuwiki-plugin-move.git] / dokuwiki-plugin-move.spec
CommitLineData
4492f0b8
ER
1%define plugin move
2Summary: Move pages, media files and namespaces while maintaining the link structure
3Name: dokuwiki-plugin-%{plugin}
1d9d0ef3 4Version: 20151017
4492f0b8
ER
5Release: 1
6License: GPL v2
7Group: Applications/WWW
8Source0: https://github.com/michitux/dokuwiki-plugin-move/archive/master/%{plugin}-%{version}.tar.gz
1d9d0ef3 9# Source0-md5: 65d57798bd6059f0c0ab6be5cc0390a6
4492f0b8
ER
10URL: https://www.dokuwiki.org/plugin:move
11BuildRequires: sed >= 4.0
12BuildRequires: unzip
13Requires: dokuwiki >= 20131208
14BuildArch: noarch
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%define dokuconf /etc/webapps/dokuwiki
18%define dokudir /usr/share/dokuwiki
19%define plugindir %{dokudir}/lib/plugins/%{plugin}
20
21%description
22This plugin allows to move pages and namespaces including media files
23and automatically adjusts all links and media references that point to
24these pages. Unlike the old pagemove plugin this plugin uses the
25DokuWiki parser which allows it to correctly identify all links and
26nothing else.
27
28Parts of this plugin like some of the translated strings, some parts
29of the structure of the code and parts of the user interface have been
30taken from the old pagemove plugin by Gary Owen, Arno Puschmann and
31Christoph Jähnigen.
32
33Warning: This plugin does not update ACL rules. For example if you had
34an ACL rule that read-protected a certain wiki page this rule won't
35have any effect anymore after moving that page.
36
37%prep
38%setup -qc
39mv dokuwiki-plugin-move-*/* .
4492f0b8
ER
40
41# cleanup backups after patching
42find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
43
44%build
45version=$(awk '/^date/{print $2}' plugin.info.txt)
46if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
47 : %%{version} mismatch
48 exit 1
49fi
50
51%install
52rm -rf $RPM_BUILD_ROOT
53install -d $RPM_BUILD_ROOT%{plugindir}
54cp -a . $RPM_BUILD_ROOT%{plugindir}
55
56%{__rm} $RPM_BUILD_ROOT%{plugindir}/README
57%{__rm} -r $RPM_BUILD_ROOT%{plugindir}/_test
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files
63%defattr(644,root,root,755)
64%doc README
65%dir %{plugindir}
66%{plugindir}/*.js
67%{plugindir}/*.less
68%{plugindir}/*.txt
69%{plugindir}/action
70%{plugindir}/admin
71%{plugindir}/conf
72%{plugindir}/helper
73%{plugindir}/images
74%{plugindir}/script
75
76%dir %{plugindir}/lang
77%{plugindir}/lang/en
78%lang(cs) %{plugindir}/lang/cs
79%lang(de) %{plugindir}/lang/de
80%lang(es) %{plugindir}/lang/es
81%lang(fr) %{plugindir}/lang/fr
82%lang(it) %{plugindir}/lang/it
83%lang(ja) %{plugindir}/lang/ja
84%lang(ko) %{plugindir}/lang/ko
85%lang(lv) %{plugindir}/lang/lv
86%lang(nl) %{plugindir}/lang/nl
87%lang(no) %{plugindir}/lang/no
88%lang(pl) %{plugindir}/lang/pl
89%lang(ru) %{plugindir}/lang/ru
90%lang(sl) %{plugindir}/lang/sl
91%lang(sv) %{plugindir}/lang/sv
92%lang(zh_CN) %{plugindir}/lang/zh
This page took 0.108963 seconds and 4 git commands to generate.