]> git.pld-linux.org Git - packages/dokuwiki-plugin-editx.git/blob - dokuwiki-plugin-editx.spec
e585f9c826c35dee7957d58093da9353451b45b5
[packages/dokuwiki-plugin-editx.git] / dokuwiki-plugin-editx.spec
1 %define         plugin          editx
2 %define         php_min_version 5.0.0
3 %include        /usr/lib/rpm/macros.php
4 Summary:        DokuWiki editx plugin
5 Name:           dokuwiki-plugin-%{plugin}
6 Version:        20140919
7 Release:        1
8 License:        GPL v2
9 Group:          Applications/WWW
10 Source0:        https://github.com/danny0838/dw-editx/tarball/master/%{plugin}-%{version}.tar.gz
11 # Source0-md5:  ea5edbf984caf7ed901979bb8051a94b
12 URL:            https://www.dokuwiki.org/plugin:editx
13 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
14 BuildRequires:  rpmbuild(macros) >= 1.553
15 BuildRequires:  unzip
16 Requires:       dokuwiki >= 20061106
17 Requires:       php(core) >= %{php_min_version}
18 Requires:       php(date)
19 Requires:       php(pcre)
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         dokuconf        /etc/webapps/dokuwiki
24 %define         dokudir         /usr/share/dokuwiki
25 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
26 %define         find_lang       %{_usrlibrpm}/dokuwiki-find-lang.sh %{buildroot}
27
28 %description
29 Extended edit functions such as renaming or deleting a page.
30
31 %prep
32 %setup -qc
33 mv *%{plugin}*/* .
34 %undos -f php
35
36 version=$(awk '/^date/{print $2}' plugin.info.txt)
37 if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
38         : %%{version} mismatch
39         exit 1
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{plugindir}
45 cp -a . $RPM_BUILD_ROOT%{plugindir}
46
47 %find_lang %{name}.lang
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 # use this post section if you package .css or .js files
53 %post
54 # force js/css cache refresh
55 if [ -f %{dokuconf}/local.php ]; then
56         touch %{dokuconf}/local.php
57 fi
58
59 %files -f %{name}.lang
60 %defattr(644,root,root,755)
61 %dir %{plugindir}
62 %{plugindir}/*.php
63 %{plugindir}/*.txt
64 %{plugindir}/conf
This page took 0.034234 seconds and 2 git commands to generate.