]> git.pld-linux.org Git - packages/dokuwiki-plugin-database.git/blob - dokuwiki-plugin-database.spec
84b4832e2ae5170f448c2aa40d55066bcccd29e6
[packages/dokuwiki-plugin-database.git] / dokuwiki-plugin-database.spec
1 %define         plugin          database
2 Summary:        Design your own database and manage the data within the wiki
3 Summary(pl.UTF-8):      Wtyczka database dla DokuWiki
4 Name:           dokuwiki-plugin-%{plugin}
5 Version:        1.0.4
6 Release:        0.1
7 License:        GPL v2
8 Group:          Applications/WWW
9 Source0:        http://www.langhamassociates.com/media/database.tgz
10 # Source0-md5:  14ae5bb2f6c40a525220a815611892ee
11 URL:            http://wiki.splitbrain.org/plugin:database
12 BuildRequires:  rpmbuild(macros) >= 1.520
13 BuildRequires:  sed >= 4.0
14 Requires:       dokuwiki >= 20061106
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         dokuconf        /etc/webapps/dokuwiki
19 %define         dokudir /usr/share/dokuwiki
20 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
21 %define         find_lang       %{_usrlibrpm}/dokuwiki-find-lang.sh %{buildroot}
22
23 %description
24 The database Plugin lets you create tables and columns and to populate
25 them with content.
26
27 The content can then be sorted and filtered by any of the columns.
28
29 There are a number of built-in lookups such as Gender, i.e. Male and
30 Female, Title, i.e. Mr., Ms, etc.
31
32 You can also use the contents of one table as a reference table, for
33 example a table of countries can be used so that the name of the
34 country is only held once in one table and other tables refer to it...
35
36 %prep
37 %setup -q -cn %{plugin}
38 %{__sed} -i -e 's,\r$,,' lib/plugins/%{plugin}/*.php
39
40 version=$(awk -Fv '$0 == " * v%{version}"{print $2}' lib/plugins/%{plugin}/action.php)
41 if [ "$version" != %{version} ]; then
42         : %%{version} mismatch
43         exit 1
44 fi
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT%{plugindir}
49 cp -a lib/plugins/%{plugin}/* $RPM_BUILD_ROOT%{plugindir}
50 rm -f $RPM_BUILD_ROOT%{plugindir}/{CREDITS,changelog}
51 rm -f $RPM_BUILD_ROOT%{plugindir}/{COPYING,README,VERSION}
52
53 # find locales
54 %find_lang %{name}.lang
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 # force css cache refresh
61 if [ -f %{dokuconf}/local.php ]; then
62         touch %{dokuconf}/local.php
63 fi
64
65 %files -f %{name}.lang
66 %defattr(644,root,root,755)
67 %dir %{plugindir}
68 %{plugindir}/*.php
69 %{plugindir}/images
This page took 0.078261 seconds and 2 git commands to generate.