]> git.pld-linux.org Git - packages/docutils.git/blobdiff - docutils.spec
- rel 3; up deps for python 3.5
[packages/docutils.git] / docutils.spec
index 60e0903e9e5c8e4719755f33fe12dfd5681e9b1d..878ae96fbc2bb553849f74dcc63d33bbd98c59ce 100644 (file)
@@ -1,15 +1,20 @@
 Summary:       Documentation Utilities
-Summary(pl):   Narzêdzia do tworzenia dokumentacji
+Summary(pl.UTF-8):     Narzędzia do tworzenia dokumentacji
 Name:          docutils
-Version:       0.3.9
-Release:       1
+Version:       0.12
+Release:       3
 License:       Public Domain, BSD, GPL (see COPYING.txt)
 Group:         Development/Tools
-Source0:       http://dl.sourceforge.net/docutils/%{name}-%{version}.tar.gz
-# Source0-md5: 3b6727e4f53e88ae7cea7c296694fc6c
+Source0:       http://downloads.sourceforge.net/docutils/%{name}-%{version}.tar.gz
+# Source0-md5: 4622263b62c5c771c03502afa3157768
 URL:           http://docutils.sourceforge.net/
-BuildRequires: python-devel
-%pyrequires_eq python-libs
+BuildRequires: python-devel >= 2.3
+BuildRequires: python3-2to3 >= 1:3.5
+BuildRequires: python3-2to3 < 1:3.6
+BuildRequires: python3-devel >= 3.5
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.219
+Requires:      python-%{name} = %{version}-%{release}
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -19,26 +24,102 @@ autodocumentation of Python modules. Includes reStructuredText, the
 easy to read, easy to use, what-you-see-is-what-you-get plaintext
 markup language.
 
-%description -l pl
-Narzêdzia do ogólnego i specjalnego dokumentowania, w³±czaj±c
-autodokumentacjê modu³ów pythona. Zawiera reScructeredText, ³atwy do
-odczytania, ³atwy w u¿yciu, WYSIWYG jêzyk opisu tekstu.
+%description -l pl.UTF-8
+Narzędzia do dokumentowania ogólnego i specjalnego zastosowania, w tym
+autodokumentacji modułów Pythona. Zawierają reStructuredText - łatwy
+do odczytania, łatwy w użyciu język opisu tekstu typu WYSIWYG.
+
+%package -n python-%{name}
+Summary:        Text documents processing modules for Python 2.x
+Summary(pl.UTF-8):      Moduły Pythona 2.x do przetwarzania dokumentów tekstowych
+Group:          Development/Languages/Python
+%pyrequires_eq python-libs
+
+%description -n python-%{name}
+Docutils are utilities for general- and special-purpose documentation,
+including autodocumentation of Python modules. Includes
+reStructuredText, the easy to read, easy to use,
+what-you-see-is-what-you-get plaintext markup language.
+
+This package provides the Docutils modules for Python 2.
+
+%description -n python-%{name} -l pl.UTF-8
+Narzędzia do dokumentowania ogólnego i specjalnego zastosowania, w tym
+autodokumentacji modułów Pythona. Zawierają reStructuredText - łatwy
+do odczytania, łatwy w użyciu język opisu tekstu typu WYSIWYG.
+
+Ten pakiet dostarcza moduły Docutils dla Pythona 2.
+
+%package 3
+Summary:        Documentation Utilities for Python 3.x
+Summary(pl.UTF-8):     Narzędzia do tworzenia dokumentacji dla Pythona 3.x
+Group:         Development/Tools
+Requires:      python3-%{name} = %{version}-%{release}
+
+%description 3
+Utilities for general- and special-purpose documentation, including
+autodocumentation of Python modules. Includes reStructuredText, the
+easy to read, easy to use, what-you-see-is-what-you-get plaintext
+markup language.
+
+This package provides the Docutils for Python 3.
+
+%description 3 -l pl.UTF-8
+Narzędzia do dokumentowania ogólnego i specjalnego zastosowania, w tym
+autodokumentacji modułów Pythona. Zawierają reStructuredText - łatwy
+do odczytania, łatwy w użyciu język opisu tekstu typu WYSIWYG.
+
+Ten pakiet zawiera Docutils dla Pythona 3.
+
+%package -n python3-%{name}
+Summary:        Text documents processing modules for Python 3.x
+Summary(pl.UTF-8):      Moduły Pythona 3.x do przetwarzania dokumentów tekstowych
+Group:          Development/Languages/Python
+
+%description -n python3-%{name}
+Docutils are utilities for general- and special-purpose documentation,
+including autodocumentation of Python modules. Includes
+reStructuredText, the easy to read, easy to use,
+what-you-see-is-what-you-get plaintext markup language.
+
+This package provides the Docutils modules for Python 3.
+
+%description -n python3-%{name} -l pl.UTF-8
+Narzędzia do dokumentowania ogólnego i specjalnego zastosowania, w tym
+autodokumentacji modułów Pythona. Zawierają reStructuredText - łatwy
+do odczytania, łatwy w użyciu język opisu tekstu typu WYSIWYG.
+
+Ten pakiet dostarcza moduły Docutils dla Pythona 3.
 
 %prep
 %setup -q
 
 %build
-python setup.py config
-python setup.py build
+%{__python} setup.py config build -b build-2
+%{__python3} setup.py config build -b build-3
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-python setup.py install \
+%{__python} setup.py build -b build-2 install \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
+
+for f in $RPM_BUILD_ROOT%{_bindir}/*.py ; do
+       mv "${f}" "${f%.py}"
+done
+
+%{__python3} setup.py build -b build-3 install \
        --optimize=2 \
        --root=$RPM_BUILD_ROOT
 
-install tools/rst2newlatex.py tools/rst2xml.py $RPM_BUILD_ROOT%{_bindir}
+for f in $RPM_BUILD_ROOT%{_bindir}/*.py ; do
+       mv "${f}" "${f%.py}-3"
+done
+
+%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
+%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
+%py_postclean
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -46,25 +127,28 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc PKG-INFO *.txt docs
-%attr(755,root,root) %{_bindir}/*
-%dir %{py_sitescriptdir}/%{name}
-%dir %{py_sitescriptdir}/%{name}/languages
-%dir %{py_sitescriptdir}/%{name}/parsers
-%dir %{py_sitescriptdir}/%{name}/parsers/rst
-%dir %{py_sitescriptdir}/%{name}/parsers/rst/directives
-%dir %{py_sitescriptdir}/%{name}/parsers/rst/languages
-%dir %{py_sitescriptdir}/%{name}/readers
-%dir %{py_sitescriptdir}/%{name}/readers/python
-%dir %{py_sitescriptdir}/%{name}/writers
-%dir %{py_sitescriptdir}/%{name}/transforms
-%{py_sitescriptdir}/*.py[oc]
-%{py_sitescriptdir}/%{name}/*.py[oc]
-%{py_sitescriptdir}/%{name}/languages/*.py[oc]
-%{py_sitescriptdir}/%{name}/parsers/*.py[oc]
-%{py_sitescriptdir}/%{name}/parsers/rst/*.py[oc]
-%{py_sitescriptdir}/%{name}/parsers/rst/directives/*.py[oc]
-%{py_sitescriptdir}/%{name}/parsers/rst/languages/*.py[oc]
-%{py_sitescriptdir}/%{name}/readers/*.py[oc]
-%{py_sitescriptdir}/%{name}/readers/python/*.py[oc]
-%{py_sitescriptdir}/%{name}/writers/*.py[oc]
-%{py_sitescriptdir}/%{name}/transforms/*.py[oc]
+%attr(755,root,root) %{_bindir}/rst2html
+%attr(755,root,root) %{_bindir}/rst2latex
+%attr(755,root,root) %{_bindir}/rst2man
+%attr(755,root,root) %{_bindir}/rst2odt
+%attr(755,root,root) %{_bindir}/rst2odt_prepstyles
+%attr(755,root,root) %{_bindir}/rst2pseudoxml
+%attr(755,root,root) %{_bindir}/rst2s5
+%attr(755,root,root) %{_bindir}/rst2xetex
+%attr(755,root,root) %{_bindir}/rst2xml
+%attr(755,root,root) %{_bindir}/rstpep2html
+
+%files 3
+%defattr(644,root,root,755)
+%doc PKG-INFO *.txt docs
+%attr(755,root,root) %{_bindir}/rst*-3
+
+%files -n python-%{name}
+%defattr(644,root,root,755)
+%{py_sitescriptdir}/docutils
+%{py_sitescriptdir}/docutils-%{version}-py*.egg-info
+
+%files -n python3-%{name}
+%defattr(644,root,root,755)
+%{py3_sitescriptdir}/docutils
+%{py3_sitescriptdir}/docutils-%{version}-py*.egg-info
This page took 1.078798 seconds and 4 git commands to generate.