]> git.pld-linux.org Git - packages/docker.git/blobdiff - docker.spec
up to 1.12.6, Fix runC privilege escalation (CVE-2016-9962)
[packages/docker.git] / docker.spec
index 4d04a7f4c270ee07ab45b023b9503d6ea2d6b8c8..77359a7df4736aa206479d6c776031a6ae04ff10 100644 (file)
@@ -7,25 +7,25 @@
 # NOTES
 # https://github.com/docker/docker/blob/master/project/PACKAGERS.md#build-dependencies
 
-# v1.0.0-rc2-6-g02f8fa7
-%define        runc_commit 02f8fa7
-# v0.2.4-6-g0366d7e
-%define        containerd_commit 0366d7e
+# v1.0.0-rc2-9-g50a19c6
+%define        runc_commit 50a19c6
+# v0.2.4-10-g2a5e70c
+%define        containerd_commit 2a5e70c
 #define        subver -rc2
 Summary:       Docker: the open-source application container engine
 Name:          docker
-Version:       1.12.2
+Version:       1.12.6
 Release:       1
 License:       Apache v2.0
 Group:         Applications/System
 # https://github.com/docker/docker/releases
 Source0:       https://github.com/docker/docker/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 019efbcb88c9f76790ca28d990179f6a
-Source1:       https://github.com/opencontainers/runc/archive/%{runc_commit}/runc-%{runc_commit}.tar.gz
-# Source1-md5: f8ab0976c658243c61d7636ebbe4087c
+# Source0-md5: 2db317ab9811641449784fe0fb29d74f
+Source1:       https://github.com/docker/runc/archive/%{runc_commit}/runc-%{runc_commit}.tar.gz
+# Source1-md5: b8f0f19983f641c53a997a58b37dc63e
 Source2:       https://github.com/docker/containerd/archive/%{containerd_commit}/containerd-%{containerd_commit}.tar.gz
-# Source2-md5: 9e7690cc09625bdb34f7a9fedff270eb
-Source4:       %{name}.sh
+# Source2-md5: 143556e1e7a4e8fa678dce1e0b766e12
+Source4:       %{name}d.sh
 Source7:       %{name}.init
 Source8:       %{name}.sysconfig
 Patch0:                systemd.patch
@@ -40,6 +40,7 @@ Requires(post,preun): /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
+Requires:      ca-certificates
 Requires:      iproute2 >= 3.5
 Requires:      iptables
 Requires:      rc-scripts >= 0.4.0.10
@@ -181,7 +182,7 @@ install -p containerd/bin/ctr $RPM_BUILD_ROOT%{_sbindir}/docker-containerd-ctr
 cp -p contrib/init/systemd/docker.service $RPM_BUILD_ROOT%{systemdunitdir}
 cp -p contrib/init/systemd/docker.socket $RPM_BUILD_ROOT%{systemdunitdir}
 install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/docker
-install -p %{SOURCE4} $RPM_BUILD_ROOT%{_libexecdir}/docker
+install -p %{SOURCE4} $RPM_BUILD_ROOT%{_libexecdir}/dockerd
 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/sysconfig/docker
 
 # install udev rules
@@ -237,7 +238,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_sbindir}/docker-proxy
 %attr(755,root,root) %{_sbindir}/docker-runc
 %attr(755,root,root) %{_sbindir}/dockerd
-%attr(755,root,root) %{_libexecdir}/docker
+%attr(755,root,root) %{_libexecdir}/dockerd
 %{systemdunitdir}/docker.service
 %{systemdunitdir}/docker.socket
 /lib/udev/rules.d/80-docker.rules
This page took 0.073119 seconds and 4 git commands to generate.