]> git.pld-linux.org Git - packages/docker.git/blob - lxc-docker.spec
x86-64 only for now
[packages/docker.git] / lxc-docker.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        Docker: the Linux container engine
6 Name:           lxc-docker
7 Version:        0.6.1
8 Release:        2
9 License:        Apache v2.0
10 Group:          Applications/System
11 Source0:        https://github.com/dotcloud/docker/archive/v%{version}.tar.gz
12 # Source0-md5:  487262eae6627971e9181886d65fae1a
13 Source100:      https://raw.github.com/dotcloud/docker/v0.5.3/Makefile
14 # Source100-md5:        44cc86a37fc5dfe59596076d346da20d
15 Source1:        https://github.com/gorilla/context/archive/master.tar.gz?/gorilla-context.tgz
16 # Source1-md5:  621f599f7a49f56ca89c25a6d01ecc3a
17 Source2:        https://github.com/gorilla/mux/archive/master.tar.gz?/gorilla-mux.tgz
18 # Source2-md5:  e908c7da6b4b8b61b4733d4a348f015c
19 Source3:        https://github.com/kr/pty/archive/master.tar.gz?/kr-pty.tgz
20 # Source3-md5:  ffdcacc582c7b6404e71c2dce638869e
21 Source4:        https://github.com/dotcloud/tar/archive/master.tar.gz?/tar.tgz
22 # Source4-md5:  7458ecaa777e56d124b61638d597b37f
23 # $ PKG=code.google.com/p/go.net/ REV=84a4013f96e0; hg clone http://$PKG go.net && cd go.net && hg checkout $REV && cd .. && tar -cjf go.net.tar.gz2 --exclude-vcs go.net
24 Source5:        go.net.tar.bz2
25 # Source5-md5:  c8fd9d068430ddfa42d28d4772260eda
26 Patch0:         bash-comp-2.patch
27 URL:            http://github.com/dotcloud/docker
28 BuildRequires:  golang >= 1.1
29 Requires:       iptables
30 Requires:       lxc
31 Requires:       tar
32 Requires:       uname(release) >= 3.8
33 Requires:       xz
34 # only runs on x64 hosts for now:
35 # https://github.com/dotcloud/docker/issues/136
36 # https://github.com/dotcloud/docker/issues/611
37 ExclusiveArch   %{x8664}
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         bash_compdir    %{_datadir}/bash-completion/completions
41
42 # binary stripped or something
43 %define         _enable_debug_packages 0
44
45 %description
46 Docker complements LXC with a high-level API which operates at the
47 process level. It runs unix processes with strong guarantees of
48 isolation and repeatability across servers.
49
50 Docker is a great building block for automating distributed systems:
51 large-scale web deployments, database clusters, continuous deployment
52 systems, private PaaS, service-oriented architectures, etc.
53
54 %package -n bash-completion-lxc-docker
55 Summary:        bash-completion for Docker
56 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla Dockera
57 Group:          Applications/Shells
58 Requires:       %{name}
59 Requires:       bash-completion >= 2.0
60 %if "%{_rpmversion}" >= "5"
61 BuildArch:      noarch
62 %endif
63
64 %description -n bash-completion-lxc-docker
65 This package provides bash-completion for Docker.
66
67 %description -n bash-completion-lxc-docker -l pl.UTF-8
68 Pakiet ten dostarcza bashowe uzupełnianie nazw dla Dockera.
69
70 %prep
71 %setup -q -n docker-%{version} -a1 -a2 -a3 -a4 -a5
72 cp -p %{SOURCE100} .
73 %patch0 -p1
74
75 # handle external deps offline, these are taken from Dockerfile
76 install -d .gopath/src/github.com/{gorilla,kr,dotcloud}
77 # git clone https://github.com/gorilla/context .gopath/src/github.com/gorilla/context
78 mv context-master .gopath/src/github.com/gorilla/context
79 # git clone https://github.com/gorilla/mux .gopath/src/github.com/gorilla/mux
80 mv mux-master .gopath/src/github.com/gorilla/mux
81 # git clone https://github.com/kr/pty .gopath/src/github.com/kr/pty
82 mv pty-master .gopath/src/github.com/kr/pty
83 # git clone https://github.com/dotcloud/tar .gopath/src/github.com/dotcloud/tar
84 mv tar-master .gopath/src/github.com/dotcloud/tar
85 # PKG=code.google.com/p/go.net/
86 install -d .gopath/src/code.google.com/p
87 mv go.net .gopath/src/code.google.com/p/go.net
88
89 %build
90 # avoid interfering with builder env
91 unset GIT_WORK_TREE
92 unset GIT_DIR
93 %{__make} VERBOSE=1
94
95 %if %{with tests}
96 %{__make} test
97 %endif
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/var/lib/docker/{containers,graph,volumes}}
102 install -p bin/docker $RPM_BUILD_ROOT%{_bindir}/lxc-docker
103 ln -s lxc-docker $RPM_BUILD_ROOT%{_bindir}/docker
104 cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
105
106 # bash completion
107 install -d $RPM_BUILD_ROOT%{bash_compdir}
108 cp -p contrib/docker.bash $RPM_BUILD_ROOT%{bash_compdir}/lxc-docker
109 ln -s lxc-docker $RPM_BUILD_ROOT%{bash_compdir}/docker
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 %defattr(644,root,root,755)
116 %doc README.md CHANGELOG.md CONTRIBUTING.md FIXME LICENSE AUTHORS NOTICE MAINTAINERS
117 %attr(755,root,root) %{_bindir}/lxc-docker
118 %attr(755,root,root) %{_bindir}/docker
119 %{_mandir}/man1/lxc-docker.1*
120 %dir %attr(700,root,root) /var/lib/docker
121 %dir %attr(700,root,root) /var/lib/docker/containers
122 %dir %attr(700,root,root) /var/lib/docker/graph
123 %dir %attr(700,root,root) /var/lib/docker/volumes
124
125 %files -n bash-completion-lxc-docker
126 %defattr(644,root,root,755)
127 %{bash_compdir}/lxc-docker
128 %{bash_compdir}/docker
This page took 0.088575 seconds and 4 git commands to generate.