]> git.pld-linux.org Git - packages/docker.git/blob - lxc-docker.spec
release 1, docker 0.6.0 needs docker to build, so we go what is here
[packages/docker.git] / lxc-docker.spec
1 Summary:        Docker: the Linux container engine
2 Name:           lxc-docker
3 Version:        0.5.3
4 Release:        1
5 License:        Apache v2.0
6 Group:          Applications/System
7 Source0:        https://github.com/dotcloud/docker/archive/v%{version}.tar.gz
8 # Source0-md5:  ff7b814574bbaf9e55dfe1c266ae991e
9 Source1:        https://github.com/gorilla/context/archive/master.tar.gz?/gorilla-context.tgz
10 # Source1-md5:  621f599f7a49f56ca89c25a6d01ecc3a
11 Source2:        https://github.com/gorilla/mux/archive/master.tar.gz?/gorilla-mux.tgz
12 # Source2-md5:  e908c7da6b4b8b61b4733d4a348f015c
13 Source3:        https://github.com/kr/pty/archive/master.tar.gz?/kr-pty.tgz
14 # Source3-md5:  ffdcacc582c7b6404e71c2dce638869e
15 URL:            http://github.com/dotcloud/docker
16 BuildRequires:  git-core
17 BuildRequires:  golang >= 1.1
18 Requires:       iptables
19 Requires:       lxc
20 Requires:       uname(release) >= 3.8
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # binary stripped or something
24 %define         _enable_debug_packages 0
25
26 %description
27 Docker complements LXC with a high-level API which operates at the
28 process level. It runs unix processes with strong guarantees of
29 isolation and repeatability across servers.
30
31 Docker is a great building block for automating distributed systems:
32 large-scale web deployments, database clusters, continuous deployment
33 systems, private PaaS, service-oriented architectures, etc.
34
35 %prep
36 %setup -q -n docker-%{version} -a1 -a2 -a3
37
38 # handle external deps offline
39 install -d .gopath/src/github.com/{gorilla,kr}
40 # git clone https://github.com/gorilla/context .gopath/src/github.com/gorilla/context
41 mv context-master .gopath/src/github.com/gorilla/context
42 # git clone https://github.com/gorilla/mux .gopath/src/github.com/gorilla/mux
43 mv mux-master .gopath/src/github.com/gorilla/mux
44 # git clone https://github.com/kr/pty .gopath/src/github.com/kr/pty
45 mv pty-master .gopath/src/github.com/kr/pty
46
47 %build
48 # avoid interfering with builder env
49 unset GIT_WORK_TREE
50 unset GIT_DIR
51 %{__make} VERBOSE=1
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/var/lib/docker/{containers,graph,volumes}}
56 install -p bin/docker $RPM_BUILD_ROOT%{_bindir}/lxc-docker
57 ln -s lxc-docker $RPM_BUILD_ROOT%{_bindir}/docker
58 cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc README.md CHANGELOG.md CONTRIBUTING.md FIXME LICENSE AUTHORS NOTICE MAINTAINERS
66 %attr(755,root,root) %{_bindir}/lxc-docker
67 %attr(755,root,root) %{_bindir}/docker
68 %{_mandir}/man1/lxc-docker.1*
69 %dir %attr(700,root,root) /var/lib/docker
70 %dir %attr(700,root,root) /var/lib/docker/containers
71 %dir %attr(700,root,root) /var/lib/docker/graph
72 %dir %attr(700,root,root) /var/lib/docker/volumes
This page took 0.049652 seconds and 4 git commands to generate.