]> git.pld-linux.org Git - packages/docker.git/blob - lxc-docker.spec
handle external deps offline
[packages/docker.git] / lxc-docker.spec
1 Summary:        Docker: the Linux container engine
2 Name:           lxc-docker
3 Version:        0.5.3
4 Release:        0.1
5 License:        Apache v2.0
6 Group:          Applications/System
7 Source0:        https://github.com/dotcloud/docker/archive/v%{version}.tar.gz
8 # Source0-md5:  ff7b814574bbaf9e55dfe1c266ae991e
9 Source1:        https://github.com/gorilla/context/archive/master.tar.gz?/gorilla-context.tgz
10 # Source1-md5:  621f599f7a49f56ca89c25a6d01ecc3a
11 Source2:        https://github.com/gorilla/mux/archive/master.tar.gz?/gorilla-mux.tgz
12 # Source2-md5:  e908c7da6b4b8b61b4733d4a348f015c
13 Source3:        https://github.com/kr/pty/archive/master.tar.gz?/kr-pty.tgz
14 # Source3-md5:  ffdcacc582c7b6404e71c2dce638869e
15 URL:            http://github.com/dotcloud/docker
16 BuildRequires:  git-core
17 BuildRequires:  golang >= 1.1
18 Requires:       lxc
19 Requires:       uname(release) >= 3.8
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Docker complements LXC with a high-level API which operates at the
24 process level. It runs unix processes with strong guarantees of
25 isolation and repeatability across servers.
26
27 Docker is a great building block for automating distributed systems:
28 large-scale web deployments, database clusters, continuous deployment
29 systems, private PaaS, service-oriented architectures, etc.
30
31 %prep
32 %setup -q -n docker-%{version} -a1 -a2 -a3
33
34 # handle external deps offline
35 install -d .gopath/src/github.com/{gorilla,kr}
36 # git clone https://github.com/gorilla/context .gopath/src/github.com/gorilla/context
37 mv context-master .gopath/src/github.com/gorilla/context
38 # git clone https://github.com/gorilla/mux .gopath/src/github.com/gorilla/mux
39 mv mux-master .gopath/src/github.com/gorilla/mux
40 # git clone https://github.com/kr/pty .gopath/src/github.com/kr/pty
41 mv pty-master .gopath/src/github.com/kr/pty
42
43 %build
44 # avoid interfering with builder env
45 unset GIT_WORK_TREE
46 unset GIT_DIR
47 %{__make} VERBOSE=1
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/var/lib/docker/{containers,graph,volumes}}
52 install -p bin/docker $RPM_BUILD_ROOT%{_bindir}/lxc-docker
53 cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc README.md CHANGELOG.md CONTRIBUTING.md FIXME LICENSE AUTHORS NOTICE MAINTAINERS
61 %attr(755,root,root) %{_bindir}/lxc-docker
62 %{_mandir}/man1/lxc-docker.1*
63 %dir %attr(700,root,root) /var/lib/docker
64 %dir %attr(700,root,root) /var/lib/docker/containers
65 %dir %attr(700,root,root) /var/lib/docker/graph
66 %dir %attr(700,root,root) /var/lib/docker/volumes
This page took 0.041783 seconds and 4 git commands to generate.