]> git.pld-linux.org Git - packages/docker.git/blob - lxc-docker.spec
patch for bash-completions 2.0
[packages/docker.git] / lxc-docker.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        Docker: the Linux container engine
6 Name:           lxc-docker
7 Version:        0.6.1
8 Release:        1
9 License:        Apache v2.0
10 Group:          Applications/System
11 Source0:        https://github.com/dotcloud/docker/archive/v%{version}.tar.gz
12 # Source0-md5:  487262eae6627971e9181886d65fae1a
13 Source100:      https://raw.github.com/dotcloud/docker/v0.5.3/Makefile
14 # Source100-md5:        44cc86a37fc5dfe59596076d346da20d
15 Source1:        https://github.com/gorilla/context/archive/master.tar.gz?/gorilla-context.tgz
16 # Source1-md5:  621f599f7a49f56ca89c25a6d01ecc3a
17 Source2:        https://github.com/gorilla/mux/archive/master.tar.gz?/gorilla-mux.tgz
18 # Source2-md5:  e908c7da6b4b8b61b4733d4a348f015c
19 Source3:        https://github.com/kr/pty/archive/master.tar.gz?/kr-pty.tgz
20 # Source3-md5:  ffdcacc582c7b6404e71c2dce638869e
21 Source4:        https://github.com/dotcloud/tar/archive/master.tar.gz?/tar.tgz
22 # Source4-md5:  7458ecaa777e56d124b61638d597b37f
23 # $ PKG=code.google.com/p/go.net/ REV=84a4013f96e0; hg clone http://$PKG go.net && cd go.net && hg checkout $REV && cd .. && tar -cjf go.net.tar.gz2 --exclude-vcs go.net
24 Source5:        go.net.tar.bz2
25 # Source5-md5:  c8fd9d068430ddfa42d28d4772260eda
26 Patch0: bash-comp-2.patch
27 URL:            http://github.com/dotcloud/docker
28 BuildRequires:  golang >= 1.1
29 Requires:       iptables
30 Requires:       lxc
31 Requires:       tar
32 Requires:       uname(release) >= 3.8
33 Requires:       xz
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         bash_compdir    %{_datadir}/bash-completion/completions
37
38 # binary stripped or something
39 %define         _enable_debug_packages 0
40
41 %description
42 Docker complements LXC with a high-level API which operates at the
43 process level. It runs unix processes with strong guarantees of
44 isolation and repeatability across servers.
45
46 Docker is a great building block for automating distributed systems:
47 large-scale web deployments, database clusters, continuous deployment
48 systems, private PaaS, service-oriented architectures, etc.
49
50 %package -n bash-completion-lxc-docker
51 Summary:        bash-completion for Docker
52 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla Dockera
53 Group:          Applications/Shells
54 Requires:       %{name}
55 Requires:       bash-completion >= 2.0
56 %if "%{_rpmversion}" >= "5"
57 BuildArch:      noarch
58 %endif
59
60 %description -n bash-completion-lxc-docker
61 This package provides bash-completion for Docker.
62
63 %description -n bash-completion-lxc-docker -l pl.UTF-8
64 Pakiet ten dostarcza bashowe uzupełnianie nazw dla Dockera.
65
66 %prep
67 %setup -q -n docker-%{version} -a1 -a2 -a3 -a4 -a5
68 cp -p %{SOURCE100} .
69 %patch0 -p1
70
71 # handle external deps offline, these are taken from Dockerfile
72 install -d .gopath/src/github.com/{gorilla,kr,dotcloud}
73 # git clone https://github.com/gorilla/context .gopath/src/github.com/gorilla/context
74 mv context-master .gopath/src/github.com/gorilla/context
75 # git clone https://github.com/gorilla/mux .gopath/src/github.com/gorilla/mux
76 mv mux-master .gopath/src/github.com/gorilla/mux
77 # git clone https://github.com/kr/pty .gopath/src/github.com/kr/pty
78 mv pty-master .gopath/src/github.com/kr/pty
79 # git clone https://github.com/dotcloud/tar .gopath/src/github.com/dotcloud/tar
80 mv tar-master .gopath/src/github.com/dotcloud/tar
81 # PKG=code.google.com/p/go.net/
82 install -d .gopath/src/code.google.com/p
83 mv go.net .gopath/src/code.google.com/p/go.net
84
85 %build
86 # avoid interfering with builder env
87 unset GIT_WORK_TREE
88 unset GIT_DIR
89 %{__make} VERBOSE=1
90
91 %if %{with tests}
92 %{__make} test
93 %endif
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/var/lib/docker/{containers,graph,volumes}}
98 install -p bin/docker $RPM_BUILD_ROOT%{_bindir}/lxc-docker
99 ln -s lxc-docker $RPM_BUILD_ROOT%{_bindir}/docker
100 cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
101
102 # bash completion
103 install -d $RPM_BUILD_ROOT%{bash_compdir}
104 cp -p contrib/docker.bash $RPM_BUILD_ROOT%{bash_compdir}/lxc-docker
105 ln -s lxc-docker $RPM_BUILD_ROOT%{bash_compdir}/docker
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 %defattr(644,root,root,755)
112 %doc README.md CHANGELOG.md CONTRIBUTING.md FIXME LICENSE AUTHORS NOTICE MAINTAINERS
113 %attr(755,root,root) %{_bindir}/lxc-docker
114 %attr(755,root,root) %{_bindir}/docker
115 %{_mandir}/man1/lxc-docker.1*
116 %dir %attr(700,root,root) /var/lib/docker
117 %dir %attr(700,root,root) /var/lib/docker/containers
118 %dir %attr(700,root,root) /var/lib/docker/graph
119 %dir %attr(700,root,root) /var/lib/docker/volumes
120
121 %files -n bash-completion-lxc-docker
122 %defattr(644,root,root,755)
123 %{bash_compdir}/lxc-docker
124 %{bash_compdir}/docker
This page took 0.042754 seconds and 4 git commands to generate.