]> git.pld-linux.org Git - packages/docker.git/blob - lxc-docker.spec
uses tar and xz to download images
[packages/docker.git] / lxc-docker.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        Docker: the Linux container engine
6 Name:           lxc-docker
7 Version:        0.6.1
8 Release:        1
9 License:        Apache v2.0
10 Group:          Applications/System
11 Source0:        https://github.com/dotcloud/docker/archive/v%{version}.tar.gz
12 # Source0-md5:  487262eae6627971e9181886d65fae1a
13 Source100:      https://raw.github.com/dotcloud/docker/v0.5.3/Makefile
14 # Source100-md5:        44cc86a37fc5dfe59596076d346da20d
15 Source1:        https://github.com/gorilla/context/archive/master.tar.gz?/gorilla-context.tgz
16 # Source1-md5:  621f599f7a49f56ca89c25a6d01ecc3a
17 Source2:        https://github.com/gorilla/mux/archive/master.tar.gz?/gorilla-mux.tgz
18 # Source2-md5:  e908c7da6b4b8b61b4733d4a348f015c
19 Source3:        https://github.com/kr/pty/archive/master.tar.gz?/kr-pty.tgz
20 # Source3-md5:  ffdcacc582c7b6404e71c2dce638869e
21 Source4:        https://github.com/dotcloud/tar/archive/master.tar.gz?/tar.tgz
22 # Source4-md5:  7458ecaa777e56d124b61638d597b37f
23 # $ PKG=code.google.com/p/go.net/ REV=84a4013f96e0; hg clone http://$PKG go.net && cd go.net && hg checkout $REV && cd .. && tar -cjf go.net.tar.gz2 --exclude-vcs go.net
24 Source5:        go.net.tar.bz2
25 # Source5-md5:  c8fd9d068430ddfa42d28d4772260eda
26 URL:            http://github.com/dotcloud/docker
27 BuildRequires:  golang >= 1.1
28 Requires:       iptables
29 Requires:       lxc
30 Requires:       tar
31 Requires:       uname(release) >= 3.8
32 Requires:       xz
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         bash_compdir    %{_datadir}/bash-completion/completions
36
37 # binary stripped or something
38 %define         _enable_debug_packages 0
39
40 %description
41 Docker complements LXC with a high-level API which operates at the
42 process level. It runs unix processes with strong guarantees of
43 isolation and repeatability across servers.
44
45 Docker is a great building block for automating distributed systems:
46 large-scale web deployments, database clusters, continuous deployment
47 systems, private PaaS, service-oriented architectures, etc.
48
49 %package -n bash-completion-lxc-docker
50 Summary:        bash-completion for Docker
51 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla Dockera
52 Group:          Applications/Shells
53 Requires:       %{name}
54 Requires:       bash-completion >= 2.0
55 %if "%{_rpmversion}" >= "5"
56 BuildArch:      noarch
57 %endif
58
59 %description -n bash-completion-lxc-docker
60 This package provides bash-completion for Docker.
61
62 %description -n bash-completion-lxc-docker -l pl.UTF-8
63 Pakiet ten dostarcza bashowe uzupełnianie nazw dla Dockera.
64
65 %prep
66 %setup -q -n docker-%{version} -a1 -a2 -a3 -a4 -a5
67 cp -p %{SOURCE100} .
68
69 # handle external deps offline, these are taken from Dockerfile
70 install -d .gopath/src/github.com/{gorilla,kr,dotcloud}
71 # git clone https://github.com/gorilla/context .gopath/src/github.com/gorilla/context
72 mv context-master .gopath/src/github.com/gorilla/context
73 # git clone https://github.com/gorilla/mux .gopath/src/github.com/gorilla/mux
74 mv mux-master .gopath/src/github.com/gorilla/mux
75 # git clone https://github.com/kr/pty .gopath/src/github.com/kr/pty
76 mv pty-master .gopath/src/github.com/kr/pty
77 # git clone https://github.com/dotcloud/tar .gopath/src/github.com/dotcloud/tar
78 mv tar-master .gopath/src/github.com/dotcloud/tar
79 # PKG=code.google.com/p/go.net/
80 install -d .gopath/src/code.google.com/p
81 mv go.net .gopath/src/code.google.com/p/go.net
82
83 %build
84 # avoid interfering with builder env
85 unset GIT_WORK_TREE
86 unset GIT_DIR
87 %{__make} VERBOSE=1
88
89 %if %{with tests}
90 %{__make} test
91 %endif
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/var/lib/docker/{containers,graph,volumes}}
96 install -p bin/docker $RPM_BUILD_ROOT%{_bindir}/lxc-docker
97 ln -s lxc-docker $RPM_BUILD_ROOT%{_bindir}/docker
98 cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
99
100 # bash completion
101 install -d $RPM_BUILD_ROOT%{bash_compdir}
102 cp -p contrib/docker.bash $RPM_BUILD_ROOT%{bash_compdir}/lxc-docker
103 ln -s lxc-docker $RPM_BUILD_ROOT%{bash_compdir}/docker
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %defattr(644,root,root,755)
110 %doc README.md CHANGELOG.md CONTRIBUTING.md FIXME LICENSE AUTHORS NOTICE MAINTAINERS
111 %attr(755,root,root) %{_bindir}/lxc-docker
112 %attr(755,root,root) %{_bindir}/docker
113 %{_mandir}/man1/lxc-docker.1*
114 %dir %attr(700,root,root) /var/lib/docker
115 %dir %attr(700,root,root) /var/lib/docker/containers
116 %dir %attr(700,root,root) /var/lib/docker/graph
117 %dir %attr(700,root,root) /var/lib/docker/volumes
118
119 %files -n bash-completion-lxc-docker
120 %defattr(644,root,root,755)
121 %{bash_compdir}/lxc-docker
122 %{bash_compdir}/docker
This page took 0.04349 seconds and 3 git commands to generate.