]> git.pld-linux.org Git - packages/docker.git/blob - lxc-docker.spec
package bash-completions
[packages/docker.git] / lxc-docker.spec
1 Summary:        Docker: the Linux container engine
2 Name:           lxc-docker
3 Version:        0.6.0
4 Release:        1
5 License:        Apache v2.0
6 Group:          Applications/System
7 Source0:        https://github.com/dotcloud/docker/archive/v%{version}.tar.gz
8 # Source0-md5:  1aedc1fcbb743cd44330a54334db221e
9 Source100:      https://raw.github.com/dotcloud/docker/v0.5.3/Makefile
10 # Source100-md5:        44cc86a37fc5dfe59596076d346da20d
11 Source1:        https://github.com/gorilla/context/archive/master.tar.gz?/gorilla-context.tgz
12 # Source1-md5:  621f599f7a49f56ca89c25a6d01ecc3a
13 Source2:        https://github.com/gorilla/mux/archive/master.tar.gz?/gorilla-mux.tgz
14 # Source2-md5:  e908c7da6b4b8b61b4733d4a348f015c
15 Source3:        https://github.com/kr/pty/archive/master.tar.gz?/kr-pty.tgz
16 # Source3-md5:        ffdcacc582c7b6404e71c2dce638869e
17 Source4:        https://github.com/dotcloud/tar/archive/master.tar.gz?/tar.tgz
18 # Source4-md5:  7458ecaa777e56d124b61638d597b37f
19 # $ PKG=code.google.com/p/go.net/ REV=84a4013f96e0; hg clone http://$PKG go.net && cd go.net && hg checkout $REV && cd .. && tar -cjf go.net.tar.gz2 --exclude-vcs go.net
20 Source5:        go.net.tar.bz2
21 # Source5-md5:  c8fd9d068430ddfa42d28d4772260eda
22 URL:            http://github.com/dotcloud/docker
23 BuildRequires:  golang >= 1.1
24 Requires:       iptables
25 Requires:       lxc
26 Requires:       uname(release) >= 3.8
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         bash_compdir    %{_datadir}/bash-completion/completions
30
31 # binary stripped or something
32 %define         _enable_debug_packages 0
33
34 %description
35 Docker complements LXC with a high-level API which operates at the
36 process level. It runs unix processes with strong guarantees of
37 isolation and repeatability across servers.
38
39 Docker is a great building block for automating distributed systems:
40 large-scale web deployments, database clusters, continuous deployment
41 systems, private PaaS, service-oriented architectures, etc.
42
43 %package -n bash-completion-lxc-docker
44 Summary:        bash-completion for Docker
45 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla Dockera
46 Group:          Applications/Shells
47 Requires:       %{name}
48 Requires:       bash-completion >= 2.0
49 %if "%{_rpmversion}" >= "5"
50 BuildArch:      noarch
51 %endif
52
53 %description -n bash-completion-lxc-docker
54 This package provides bash-completion for Docker.
55
56 %description -n bash-completion-lxc-docker -l pl.UTF-8
57 Pakiet ten dostarcza bashowe uzupełnianie nazw dla Dockera.
58
59 %prep
60 %setup -q -n docker-%{version} -a1 -a2 -a3 -a4 -a5
61 cp -p %{SOURCE100} .
62
63 # handle external deps offline, these are taken from Dockerfile
64 install -d .gopath/src/github.com/{gorilla,kr,dotcloud}
65 # git clone https://github.com/gorilla/context .gopath/src/github.com/gorilla/context
66 mv context-master .gopath/src/github.com/gorilla/context
67 # git clone https://github.com/gorilla/mux .gopath/src/github.com/gorilla/mux
68 mv mux-master .gopath/src/github.com/gorilla/mux
69 # git clone https://github.com/kr/pty .gopath/src/github.com/kr/pty
70 mv pty-master .gopath/src/github.com/kr/pty
71 # git clone https://github.com/dotcloud/tar .gopath/src/github.com/dotcloud/tar
72 mv tar-master .gopath/src/github.com/dotcloud/tar
73 # PKG=code.google.com/p/go.net/
74 install -d .gopath/src/code.google.com/p
75 mv go.net .gopath/src/code.google.com/p/go.net
76
77 %build
78 # avoid interfering with builder env
79 unset GIT_WORK_TREE
80 unset GIT_DIR
81 %{__make} VERBOSE=1
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/var/lib/docker/{containers,graph,volumes}}
86 install -p bin/docker $RPM_BUILD_ROOT%{_bindir}/lxc-docker
87 ln -s lxc-docker $RPM_BUILD_ROOT%{_bindir}/docker
88 cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
89
90 # bash completion
91 install -d $RPM_BUILD_ROOT%{bash_compdir}
92 cp -p contrib/docker.bash $RPM_BUILD_ROOT%{bash_compdir}/lxc-docker
93 ln -s lxc-docker $RPM_BUILD_ROOT%{bash_compdir}/docker
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %doc README.md CHANGELOG.md CONTRIBUTING.md FIXME LICENSE AUTHORS NOTICE MAINTAINERS
101 %attr(755,root,root) %{_bindir}/lxc-docker
102 %attr(755,root,root) %{_bindir}/docker
103 %{_mandir}/man1/lxc-docker.1*
104 %dir %attr(700,root,root) /var/lib/docker
105 %dir %attr(700,root,root) /var/lib/docker/containers
106 %dir %attr(700,root,root) /var/lib/docker/graph
107 %dir %attr(700,root,root) /var/lib/docker/volumes
108
109 %files -n bash-completion-lxc-docker
110 %defattr(644,root,root,755)
111 %{bash_compdir}/lxc-docker
112 %{bash_compdir}/docker
This page took 0.069437 seconds and 3 git commands to generate.