]> git.pld-linux.org Git - packages/docker.git/blob - docker.spec
add runc and containerd required for docker 1.11
[packages/docker.git] / docker.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4 %bcond_with     vim                     # build vim syntax package
5 %bcond_with     doc                     # build manual pages
6
7 # NOTES
8 # https://github.com/docker/docker/blob/master/project/PACKAGERS.md#build-dependencies
9
10 # v0.1.1
11 %define runc_commit baf6536
12 # v0.2.2
13 %define containerd_commit 9dc2b32
14 Summary:        Docker: the open-source application container engine
15 Name:           docker
16 Version:        1.11.2
17 Release:        0.8
18 License:        Apache v2.0
19 Group:          Applications/System
20 Source0:        https://github.com/docker/docker/archive/v%{version}/%{name}-%{version}.tar.gz
21 # Source0-md5:  ada4a756f71886049ad793cab8787de8
22 Source1:        https://github.com/opencontainers/runc/archive/%{runc_commit}/runc-%{runc_commit}.tar.gz
23 # Source1-md5:  b6b2f2e5722666e7d1a1d5062ff996e3
24 Source2:        https://github.com/docker/containerd/archive/%{containerd_commit}/containerd-%{containerd_commit}.tar.gz
25 # Source2-md5:  76c1e68052b35a3dcfbc6d76d61f17cd
26 Source4:        %{name}.sh
27 Source5:        %{name}.service
28 Source6:        %{name}.init
29 Source7:        %{name}.sysconfig
30 URL:            http://www.docker.com/
31 BuildRequires:  btrfs-progs-devel >= 3.16.1
32 BuildRequires:  device-mapper-devel >= 2.02.89
33 BuildRequires:  golang >= 1.4
34 BuildRequires:  libseccomp-devel >= 2.2.1
35 BuildRequires:  rpmbuild(macros) >= 1.228
36 BuildRequires:  sqlite3-devel >= 3.7.9
37 Requires(post,preun):   /sbin/chkconfig
38 Requires(postun):       /usr/sbin/groupdel
39 Requires(pre):  /usr/bin/getgid
40 Requires(pre):  /usr/sbin/groupadd
41 Requires:       iproute2 >= 3.5
42 Requires:       iptables
43 Requires:       rc-scripts >= 0.4.0.10
44 Requires:       tar >= 1:1.26
45 Requires:       uname(release) >= 3.8
46 Requires:       xz
47 Suggests:       git-core >= 1.7
48 Suggests:       libcgroup
49 Suggests:       xz >= 1:4.9
50 Provides:       group(docker)
51 Obsoletes:      lxc-docker < 1.1.1
52 Patch0:         lxc-%{name}-nosha.patch
53 # only runs on x64 hosts for now:
54 # https://github.com/docker/docker/issues/136
55 # https://github.com/docker/docker/issues/611
56 ExclusiveArch:  %{x8664}
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         bash_compdir    %{_datadir}/bash-completion/completions
60 %define         _vimdatadir             %{_datadir}/vim
61 %define         _libexecdir             %{_prefix}/lib
62
63 # binary stripped or something
64 %define         _enable_debug_packages 0
65
66 %description
67 Docker is an open source project to pack, ship and run any application
68 as a lightweight container
69
70 Docker containers are both hardware-agnostic and platform-agnostic.
71 This means that they can run anywhere, from your laptop to the largest
72 EC2 compute instance and everything in between - and they don't
73 require that you use a particular language, framework or packaging
74 system. That makes them great building blocks for deploying and
75 scaling web apps, databases and backend services without depending on
76 a particular stack or provider.
77
78 Docker is an open-source implementation of the deployment engine which
79 powers dotCloud, a popular Platform-as-a-Service. It benefits directly
80 from the experience accumulated over several years of large-scale
81 operation and support of hundreds of thousands of applications and
82 databases.
83
84 %package -n bash-completion-%{name}
85 Summary:        bash-completion for Docker
86 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla Dockera
87 Group:          Applications/Shells
88 Requires:       %{name}
89 Requires:       bash-completion >= 2.0
90 Obsoletes:      bash-completion-lxc-docker < 1.1.1
91 %if "%{_rpmversion}" >= "5"
92 BuildArch:      noarch
93 %endif
94
95 %description -n bash-completion-%{name}
96 This package provides bash-completion for Docker.
97
98 %description -n bash-completion-%{name} -l pl.UTF-8
99 Pakiet ten dostarcza bashowe uzupełnianie nazw dla Dockera.
100
101 %package -n vim-syntax-%{name}
102 Summary:        Vim syntax: Docker
103 Group:          Applications/Editors/Vim
104 Requires:       %{name} = %{version}-%{release}
105 Requires:       vim-rt >= 4:7.2.170
106 Obsoletes:      vim-syntax-lxc-docker < 1.1.1
107 %if "%{_rpmversion}" >= "5"
108 BuildArch:      noarch
109 %endif
110
111 %description -n vim-syntax-%{name}
112 This plugin provides syntax highlighting in Dockerfile.
113
114 %prep
115 %setup -q -a1 -a2
116 #%patch0 -p1 why is this patch needed?
117
118 mv runc-%{runc_commit}* runc
119 mv containerd-%{containerd_commit}* containerd
120
121 install -d vendor/src/github.com/docker
122 ln -s $(pwd) vendor/src/github.com/docker/docker
123 ln -s $(pwd)/containerd containerd/vendor/src/github.com/docker/containerd
124
125 %build
126 v=$(awk '/ENV RUNC_COMMIT/ {print $3}' Dockerfile)
127 echo "$v" | grep "^%{runc_commit}"
128 v=$(awk '/ENV CONTAINERD_COMMIT/ {print $3}' Dockerfile)
129 echo "$v" | grep "^%{containerd_commit}"
130
131 export GOPATH=$(pwd)/vendor:$(pwd)/containerd/vendor
132 export DOCKER_GITCOMMIT="pld/%{version}"
133
134 # build docker-runc
135 %{__make} -C runc
136
137 # build docker-containerd
138 %{__make} -C containerd
139
140 bash -x hack/make.sh dynbinary
141 %if %{with doc}
142 man/md2man-all.sh
143 %endif
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man1,/etc/{rc.d/init.d,sysconfig},%{systemdunitdir}} \
148         $RPM_BUILD_ROOT%{_libexecdir} \
149         $RPM_BUILD_ROOT/var/lib/docker/{aufs,containers,execdriver,graph,image,init,network,overlay,tmp,trust,vfs,volumes}
150
151 install -p bundles/%{version}/dynbinary/docker-%{version} $RPM_BUILD_ROOT%{_bindir}/docker
152
153 # install docker-runc
154 install -p runc/runc $RPM_BUILD_ROOT%{_sbindir}/docker-runc
155
156 # install docker-containerd
157 install -p containerd/bin/containerd $RPM_BUILD_ROOT%{_sbindir}/docker-containerd
158 install -p containerd/bin/containerd-shim $RPM_BUILD_ROOT%{_sbindir}/docker-containerd-shim
159 install -p containerd/bin/ctr $RPM_BUILD_ROOT%{_sbindir}/docker-ctr
160
161 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}
162 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/docker
163 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_libexecdir}/docker
164 cp -p %{SOURCE7} $RPM_BUILD_ROOT/etc/sysconfig/docker
165 #cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
166
167 # install udev rules
168 install -d $RPM_BUILD_ROOT/lib/udev/rules.d
169 cp -p contrib/udev/80-docker.rules $RPM_BUILD_ROOT/lib/udev/rules.d
170
171 # bash completion
172 install -d $RPM_BUILD_ROOT%{bash_compdir}
173 cp -p contrib/completion/bash/docker $RPM_BUILD_ROOT%{bash_compdir}/docker
174
175 # vim syntax
176 %if %{with vim}
177 install -d $RPM_BUILD_ROOT%{_vimdatadir}
178 cp -a contrib/syntax/vim/* $RPM_BUILD_ROOT%{_vimdatadir}
179 %{__rm} $RPM_BUILD_ROOT%{_vimdatadir}/{LICENSE,README.md}
180 %endif
181
182 %pre
183 %groupadd -g 296 docker
184
185 %post
186 /sbin/chkconfig --add %{name}
187 %service -n %{name} restart
188
189 %preun
190 if [ "$1" = "0" ]; then
191         %service -q %{name} stop
192         /sbin/chkconfig --del %{name}
193 fi
194
195 %postun
196 if [ "$1" = "0" ]; then
197         %groupremove docker
198 fi
199
200 %clean
201 rm -rf $RPM_BUILD_ROOT
202
203 %files
204 %defattr(644,root,root,755)
205 %doc README.md CHANGELOG.md CONTRIBUTING.md LICENSE AUTHORS NOTICE MAINTAINERS
206 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/docker
207 %attr(754,root,root) /etc/rc.d/init.d/docker
208 %attr(755,root,root) %{_bindir}/docker
209 %attr(755,root,root) %{_sbindir}/docker-runc
210 %attr(755,root,root) %{_sbindir}/docker-containerd
211 %attr(755,root,root) %{_sbindir}/docker-containerd-shim
212 %attr(755,root,root) %{_sbindir}/docker-ctr
213 %attr(755,root,root) %{_libexecdir}/docker
214 %{systemdunitdir}/docker.service
215 /lib/udev/rules.d/80-docker.rules
216 #%{_mandir}/man1/lxc-docker.1*
217
218
219 %dir %attr(700,root,root) /var/lib/docker
220 %dir %attr(700,root,root) /var/lib/docker/aufs
221 %dir %attr(700,root,root) /var/lib/docker/containers
222 %dir %attr(700,root,root) /var/lib/docker/execdriver
223 %dir %attr(700,root,root) /var/lib/docker/graph
224 %dir %attr(700,root,root) /var/lib/docker/image
225 %dir %attr(700,root,root) /var/lib/docker/init
226 %dir %attr(700,root,root) /var/lib/docker/network
227 %dir %attr(700,root,root) /var/lib/docker/overlay
228 %dir %attr(700,root,root) /var/lib/docker/tmp
229 %dir %attr(700,root,root) /var/lib/docker/trust
230 %dir %attr(700,root,root) /var/lib/docker/vfs
231 %dir %attr(700,root,root) /var/lib/docker/volumes
232
233 %files -n bash-completion-%{name}
234 %defattr(644,root,root,755)
235 %{bash_compdir}/docker
236
237 %if %{with vim}
238 %files -n vim-syntax-%{name}
239 %defattr(644,root,root,755)
240 %doc contrib/syntax/vim/{README.md,LICENSE}
241 %{_vimdatadir}/doc/dockerfile.txt
242 %{_vimdatadir}/ftdetect/dockerfile.vim
243 %{_vimdatadir}/syntax/dockerfile.vim
244 %endif
This page took 0.083817 seconds and 4 git commands to generate.