]> git.pld-linux.org Git - packages/docker.git/blob - docker.spec
f25e092acd474b409384079f73925caff33bd2df
[packages/docker.git] / docker.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4 %bcond_with     vim                     # build vim syntax package
5
6 # NOTES
7 # https://github.com/docker/docker/blob/master/project/PACKAGERS.md#build-dependencies
8
9 Summary:        Docker: the open-source application container engine
10 Name:           docker
11 Version:        1.10.1
12 Release:        0.1
13 License:        Apache v2.0
14 Group:          Applications/System
15 Source0:        https://github.com/docker/docker/archive/v%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  19f027d937069b104dfb0a4a01f2e30f
17 Source5:        %{name}.service
18 Source6:        %{name}.init
19 Source7:        %{name}.sysconfig
20 URL:            https://github.com/docker/docker
21 BuildRequires:  btrfs-progs-devel >= 3.16.1
22 BuildRequires:  device-mapper-devel >= 2.02.89
23 BuildRequires:  golang >= 1.4
24 BuildRequires:  libseccomp-devel >= 2.2.1
25 BuildRequires:  rpmbuild(macros) >= 1.228
26 BuildRequires:  sqlite3-devel >= 3.7.9
27 Requires(post,preun):   /sbin/chkconfig
28 Requires(postun):       /usr/sbin/groupdel
29 Requires(pre):  /usr/bin/getgid
30 Requires(pre):  /usr/sbin/groupadd
31 Requires:       iproute2 >= 3.5
32 Requires:       iptables
33 Requires:       rc-scripts >= 0.4.0.10
34 Requires:       tar >= 1:1.26
35 Requires:       uname(release) >= 3.8
36 Requires:       xz
37 Suggests:       git-core >= 1.7
38 Suggests:       libcgroup
39 Suggests:       xz >= 1:4.9
40 Provides:       group(docker)
41 Obsoletes:      lxc-docker < 1.1.1
42 Patch0:         lxc-%{name}-nosha.patch
43 # only runs on x64 hosts for now:
44 # https://github.com/docker/docker/issues/136
45 # https://github.com/docker/docker/issues/611
46 ExclusiveArch:  %{x8664}
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         bash_compdir    %{_datadir}/bash-completion/completions
50 %define         _vimdatadir             %{_datadir}/vim
51
52 # binary stripped or something
53 %define         _enable_debug_packages 0
54
55 %description
56 Docker is an open source project to pack, ship and run any application
57 as a lightweight container
58
59 Docker containers are both hardware-agnostic and platform-agnostic.
60 This means that they can run anywhere, from your laptop to the largest
61 EC2 compute instance and everything in between - and they don't
62 require that you use a particular language, framework or packaging
63 system. That makes them great building blocks for deploying and
64 scaling web apps, databases and backend services without depending on
65 a particular stack or provider.
66
67 Docker is an open-source implementation of the deployment engine which
68 powers dotCloud, a popular Platform-as-a-Service. It benefits directly
69 from the experience accumulated over several years of large-scale
70 operation and support of hundreds of thousands of applications and
71 databases.
72
73 %package -n bash-completion-%{name}
74 Summary:        bash-completion for Docker
75 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla Dockera
76 Group:          Applications/Shells
77 Requires:       %{name}
78 Requires:       bash-completion >= 2.0
79 Obsoletes:      bash-completion-lxc-docker < 1.1.1
80 %if "%{_rpmversion}" >= "5"
81 BuildArch:      noarch
82 %endif
83
84 %description -n bash-completion-%{name}
85 This package provides bash-completion for Docker.
86
87 %description -n bash-completion-%{name} -l pl.UTF-8
88 Pakiet ten dostarcza bashowe uzupełnianie nazw dla Dockera.
89
90 %package -n vim-syntax-%{name}
91 Summary:        Vim syntax: Docker
92 Group:          Applications/Editors/Vim
93 Requires:       %{name} = %{version}-%{release}
94 Requires:       vim-rt >= 4:7.2.170
95 Obsoletes:      vim-syntax-lxc-docker < 1.1.1
96 %if "%{_rpmversion}" >= "5"
97 BuildArch:      noarch
98 %endif
99
100 %description -n vim-syntax-%{name}
101 This plugin provides syntax highlighting in Dockerfile.
102
103 %prep
104 %setup -q
105 %patch0 -p1
106
107 install -d vendor/src/github.com/docker
108 ln -s $(pwd) vendor/src/github.com/docker/docker
109
110 %build
111 export GOPATH=$(pwd)/vendor
112 export DOCKER_GITCOMMIT="pld/%{version}"
113
114 DEBUG=1 hack/make.sh dynbinary
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/etc/{rc.d/init.d,sysconfig},%{systemdunitdir}} \
119         $RPM_BUILD_ROOT/var/lib/docker/{aufs,containers,execdriver,graph,init,tmp,trust,vfs,volumes}
120
121 install -p bundles/%{version}/dynbinary/docker-%{version} $RPM_BUILD_ROOT%{_bindir}/docker
122 install -p bundles/%{version}/dynbinary/dockerinit-%{version} $RPM_BUILD_ROOT%{_bindir}/dockerinit
123 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}
124 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/docker
125 cp -p %{SOURCE7} $RPM_BUILD_ROOT/etc/sysconfig/docker
126 #cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
127
128 # install udev rules
129 install -d $RPM_BUILD_ROOT/lib/udev/rules.d
130 cp -p contrib/udev/80-docker.rules $RPM_BUILD_ROOT/lib/udev/rules.d
131
132 # bash completion
133 install -d $RPM_BUILD_ROOT%{bash_compdir}
134 cp -p contrib/completion/bash/docker $RPM_BUILD_ROOT%{bash_compdir}/docker
135
136 # vim syntax
137 %if %{with vim}
138 install -d $RPM_BUILD_ROOT%{_vimdatadir}
139 cp -a contrib/syntax/vim/* $RPM_BUILD_ROOT%{_vimdatadir}
140 %{__rm} $RPM_BUILD_ROOT%{_vimdatadir}/{LICENSE,README.md}
141 %endif
142
143 %pre
144 %groupadd -g 296 docker
145
146 %post
147 /sbin/chkconfig --add %{name}
148 %service -n %{name} restart
149
150 %preun
151 if [ "$1" = "0" ]; then
152         %service -q %{name} stop
153         /sbin/chkconfig --del %{name}
154 fi
155
156 %postun
157 if [ "$1" = "0" ]; then
158         %groupremove docker
159 fi
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %files
165 %defattr(644,root,root,755)
166 %doc README.md CHANGELOG.md CONTRIBUTING.md LICENSE AUTHORS NOTICE MAINTAINERS
167 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/docker
168 %attr(754,root,root) /etc/rc.d/init.d/docker
169 %attr(755,root,root) %{_bindir}/docker
170 %attr(755,root,root) %{_bindir}/dockerinit
171 %{systemdunitdir}/docker.service
172 /lib/udev/rules.d/80-docker.rules
173 #%{_mandir}/man1/lxc-docker.1*
174
175 %dir %attr(700,root,root) /var/lib/docker
176 %dir %attr(700,root,root) /var/lib/docker/aufs
177 %dir %attr(700,root,root) /var/lib/docker/containers
178 %dir %attr(700,root,root) /var/lib/docker/execdriver
179 %dir %attr(700,root,root) /var/lib/docker/graph
180 %dir %attr(700,root,root) /var/lib/docker/init
181 %dir %attr(700,root,root) /var/lib/docker/tmp
182 %dir %attr(700,root,root) /var/lib/docker/trust
183 %dir %attr(700,root,root) /var/lib/docker/vfs
184 %dir %attr(700,root,root) /var/lib/docker/volumes
185
186 %files -n bash-completion-%{name}
187 %defattr(644,root,root,755)
188 %{bash_compdir}/docker
189
190 %if %{with vim}
191 %files -n vim-syntax-%{name}
192 %defattr(644,root,root,755)
193 %doc contrib/syntax/vim/{README.md,LICENSE}
194 %{_vimdatadir}/doc/dockerfile.txt
195 %{_vimdatadir}/ftdetect/dockerfile.vim
196 %{_vimdatadir}/syntax/dockerfile.vim
197 %endif
This page took 0.064571 seconds and 2 git commands to generate.