]> git.pld-linux.org Git - packages/docker-compose.git/commitdiff
- commit updated patch auto/th/docker-compose-1.15.0-2
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 26 Aug 2017 07:39:44 +0000 (09:39 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 26 Aug 2017 07:39:44 +0000 (09:39 +0200)
- rel 2

docker-compose.spec
remove-requires-upper-bound.patch

index 021bf420effda57dac1f349d08c5ba5b2ae43718..0391478572761378be99c1bf7fab9b585230fd14 100644 (file)
@@ -8,7 +8,7 @@
 Summary:       Multi-container orchestration for Docker
 Name:          docker-compose
 Version:       1.15.0
-Release:       1
+Release:       2
 License:       Apache v2.0
 Group:         Applications/System
 # https://github.com/docker/compose/releases
index ab3d747819141e5cdf1cf4d0eee626b5368438f4..2627804b5b3a9ad3c48c0f69395e387b4270be19 100644 (file)
@@ -1,15 +1,79 @@
---- docker-compose-1.14.0/setup.py~    2017-06-06 22:33:59.000000000 +0300
-+++ docker-compose-1.14.0/setup.py     2017-07-18 09:16:49.407422438 +0300
-@@ -50,10 +50,10 @@
+diff -up docker-compose-1.15.0/requirements.txt.orig docker-compose-1.15.0/requirements.txt
+--- docker-compose-1.15.0/requirements.txt.orig        2017-07-25 19:05:04.000000000 -0400
++++ docker-compose-1.15.0/requirements.txt     2017-07-28 18:25:47.282974273 -0400
+@@ -1,22 +1,22 @@
+-PySocks==1.6.7
+-PyYAML==3.12
+-backports.ssl-match-hostname==3.5.0.1; python_version < '3'
+-cached-property==1.3.0
++PySocks
++PyYAML
++backports.ssl-match-hostname; python_version < '3'
++cached-property
+ certifi==2017.4.17
+-chardet==3.0.4
+-colorama==0.3.9
+-docker==2.4.2
+-docker-pycreds==0.2.1
+-dockerpty==0.4.1
+-docopt==0.6.2
+-enum34==1.1.6; python_version < '3.4'
+-functools32==3.2.3.post2; python_version < '3.2'
+-idna==2.5
+-ipaddress==1.0.18
+-jsonschema==2.6.0
+-pypiwin32==219; sys_platform == 'win32'
+-requests==2.11.1
+-six==1.10.0
+-texttable==0.8.8
+-urllib3==1.21.1
+-websocket-client==0.32.0
++chardet
++colorama
++docker
++docker-pycreds
++dockerpty
++docopt
++enum34; python_version < '3.4'
++functools32; python_version < '3.2'
++idna
++ipaddress
++jsonschema
++pypiwin32; sys_platform == 'win32'
++requests
++six
++texttable
++urllib3
++websocket-client
+diff -up docker-compose-1.15.0/setup.py.orig docker-compose-1.15.0/setup.py
+--- docker-compose-1.15.0/setup.py.orig        2017-07-25 19:05:03.000000000 -0400
++++ docker-compose-1.15.0/setup.py     2017-07-28 18:19:22.561055698 -0400
+@@ -30,17 +30,17 @@ def find_version(*file_paths):
  
  
- if sys.version_info[:2] < (3, 4):
--    tests_require.append('mock >= 1.0.1')
-+    tests_require.append('mock')
+ install_requires = [
+-    'cached-property >= 1.2.0, < 2',
+-    'colorama >= 0.3.7, < 0.4',
+-    'docopt >= 0.6.1, < 0.7',
+-    'PyYAML >= 3.10, < 4',
+-    'requests >= 2.6.1, != 2.11.0, < 2.12',
+-    'texttable >= 0.8.1, < 0.9',
+-    'websocket-client >= 0.32.0, < 1.0',
+-    'docker >= 2.4.2, < 3.0',
+-    'dockerpty >= 0.4.1, < 0.5',
+-    'six >= 1.3.0, < 2',
+-    'jsonschema >= 2.5.1, < 3',
++    'cached-property >= 1.2.0',
++    'colorama >= 0.3.7',
++    'docopt >= 0.6.1',
++    'PyYAML >= 3.10',
++    'requests >= 2.6.1, != 2.11.0',
++    'texttable >= 0.8.1',
++    'websocket-client >= 0.32.0',
++    'docker >= 2.4.2',
++    'dockerpty >= 0.4.1',
++    'six >= 1.3.0',
++    'jsonschema >= 2.5.1',
+ ]
  
- extras_require = {
--    ':python_version < "3.4"': ['enum34 >= 1.0.4, < 2'],
-+    ':python_version < "3.4"': ['enum34'],
-     ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
-     ':python_version < "3.3"': ['ipaddress >= 1.0.16'],
- }
This page took 0.217794 seconds and 4 git commands to generate.