]> git.pld-linux.org Git - packages/docker-compose.git/blob - docker-compose.spec
fix deps
[packages/docker-compose.git] / docker-compose.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4
5 Summary:        Multi-container orchestration for Docker
6 Name:           docker-compose
7 Version:        1.6.2
8 Release:        1
9 License:        Apache v2.0
10 Source0:        https://pypi.python.org/packages/source/d/docker-compose/%{name}-%{version}.tar.gz
11 # Source0-md5:  1c80fd99f2dc393e8ac5313c9a2fa4c7
12 Group:          Applications/System
13 URL:            https://docs.docker.com/compose/
14 Patch0:         remove-requires-upper-bound.patch
15 %if %{with tests}
16 BuildRequires:  python-PyYAML
17 BuildRequires:  python-docker
18 BuildRequires:  python-docopt
19 BuildRequires:  python-requests
20 BuildRequires:  python-setuptools
21 BuildRequires:  python-texttable
22 BuildRequires:  python-websocket-client
23 %endif
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.714
26 Requires:       python-PyYAML
27 Requires:       python-cached_property
28 Requires:       python-docker >= 1.7.0
29 Requires:       python-dockerpty >= 0.4.1
30 Requires:       python-docopt
31 Requires:       python-enum34
32 Requires:       python-jsonschema
33 Requires:       python-requests
34 Requires:       python-setuptools
35 Requires:       python-six
36 Requires:       python-texttable
37 Requires:       python-websocket-client
38 BuildArch:      noarch
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Multi-container orchestration for Docker
43
44 Docker-compose allows you to:
45 - Define your application's environment with Docker so it can be
46   reproduced anywhere.
47 - Define the services that make up your app so they can be run
48   together in an isolated environment.
49 - Run 'docker-compose up', and docker-compose will start and run your
50   entire app.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55
56 # Upstream uses an underscore here
57 rm -r docker_compose.egg-info
58
59 %build
60 %py_build
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %py_install
65 %py_postclean
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc CHANGES.md CONTRIBUTING.md README.rst SWARM.md LICENSE
73 %attr(755,root,root) %{_bindir}/%{name}
74 %{py_sitescriptdir}/compose
75 %{py_sitescriptdir}/docker_compose-%{version}-py*.egg-info
This page took 0.113917 seconds and 4 git commands to generate.