]> git.pld-linux.org Git - packages/docker-compose.git/blob - docker-compose.spec
new, version 1.6.2
[packages/docker-compose.git] / docker-compose.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4
5 Summary:        Multi-container orchestration for Docker
6 Name:           docker-compose
7 Version:        1.6.2
8 Release:        1
9 License:        Apache v2.0
10 Source0:        https://pypi.python.org/packages/source/d/docker-compose/%{name}-%{version}.tar.gz
11 # Source0-md5:  1c80fd99f2dc393e8ac5313c9a2fa4c7
12 Group:          Applications/System
13 URL:            https://docs.docker.com/compose/
14 Patch0:         remove-requires-upper-bound.patch
15 %if %{with tests}
16 BuildRequires:  python-PyYAML
17 BuildRequires:  python-docker-py
18 BuildRequires:  python-docopt
19 BuildRequires:  python-requests
20 BuildRequires:  python-setuptools
21 BuildRequires:  python-texttable
22 BuildRequires:  python-websocket-client
23 %endif
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.714
26 Requires:       python-PyYAML
27 Requires:       python-cached_property
28 # Version required due to upstream requirement; see BZ#1300106
29 Requires:       python-docker-py >= 1.7.0-1
30 # Version required due to upstream requirement; see BZ#1300106
31 Requires:       python-dockerpty >= 0.4.1-1
32 Requires:       python-docopt
33 Requires:       python-enum34
34 Requires:       python-jsonschema
35 Requires:       python-requests
36 Requires:       python-setuptools
37 Requires:       python-six
38 Requires:       python-texttable
39 Requires:       python-websocket-client
40 BuildArch:      noarch
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Multi-container orchestration for Docker
45
46 Docker-compose allows you to:
47 - Define your application's environment with Docker so it can be
48   reproduced anywhere.
49 - Define the services that make up your app so they can be run
50   together in an isolated environment.
51 - Run 'docker-compose up', and docker-compose will start and run your
52   entire app.
53
54 %prep
55 %setup -q
56 %patch0 -p1
57
58 # Upstream uses an underscore here
59 rm -r docker_compose.egg-info
60
61 %build
62 %py_build
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 %py_install
67 %py_postclean
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc CHANGES.md CONTRIBUTING.md README.rst SWARM.md LICENSE
75 %attr(755,root,root) %{_bindir}/%{name}
76 %{py_sitescriptdir}/compose
77 %{py_sitescriptdir}/docker_compose-%{version}-py*.egg-info
This page took 0.057232 seconds and 4 git commands to generate.