]> git.pld-linux.org Git - packages/docker-compose.git/blob - docker-compose.spec
up to 1.7.1
[packages/docker-compose.git] / docker-compose.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4
5 Summary:        Multi-container orchestration for Docker
6 Name:           docker-compose
7 Version:        1.7.1
8 Release:        1
9 License:        Apache v2.0
10 Group:          Applications/System
11 # https://github.com/docker/compose/releases
12 # https://pypi.python.org/pypi/docker-compose
13 Source0:        https://pypi.python.org/packages/b6/20/0a65e13ac06c4693f28ded22b87882ca1750239bdc0a05d4a4df4e3a9faa/%{name}-%{version}.tar.gz
14 # Source0-md5:  8c2b9a88c3aa46dbef422c7eb6802108
15 Patch0:         remove-requires-upper-bound.patch
16 URL:            https://docs.docker.com/compose/
17 %if %{with tests}
18 BuildRequires:  python-PyYAML
19 BuildRequires:  python-docker
20 BuildRequires:  python-docopt
21 BuildRequires:  python-requests
22 BuildRequires:  python-setuptools
23 BuildRequires:  python-texttable
24 BuildRequires:  python-websocket-client
25 %endif
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.714
28 Requires:       docker >= 1.10.0
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Multi-container orchestration for Docker
34
35 Docker-compose allows you to:
36 - Define your application's environment with Docker so it can be
37   reproduced anywhere.
38 - Define the services that make up your app so they can be run
39   together in an isolated environment.
40 - Run 'docker-compose up', and docker-compose will start and run your
41   entire app.
42
43 %prep
44 %setup -q
45 %patch0 -p1
46
47 rm -r docker_compose.egg-info
48
49 %build
50 %py_build
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 %py_install
55 %py_postclean
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc CHANGES.md CONTRIBUTING.md README.rst SWARM.md LICENSE
63 %attr(755,root,root) %{_bindir}/%{name}
64 %{py_sitescriptdir}/compose
65 %{py_sitescriptdir}/docker_compose-%{version}-py*.egg-info
This page took 0.066765 seconds and 3 git commands to generate.