]> git.pld-linux.org Git - packages/dnssec-tools.git/blobdiff - dnssec-tools.spec
- updated to 1.14 (note: new sonames)
[packages/dnssec-tools.git] / dnssec-tools.spec
index a4b8c397b43fc9d792c98b468b7ef9d070ec2e6f..6113baebd1cfa6f5113f58ee2405eb1d1dc8d2a7 100644 (file)
@@ -1,14 +1,19 @@
+#
+# Conditional build:
+%bcond_without qt      # Qt-based GUI tools
+#
 %include       /usr/lib/rpm/macros.perl
 Summary:       DNSSEC tools
 Summary(pl.UTF-8):     Narzędzia DNSSEC
 Name:          dnssec-tools
-Version:       1.10
+Version:       1.14
 Release:       1
 License:       BSD
-Group:         Applications/Network
+Group:         Applications/Networking
 Source0:       http://www.dnssec-tools.org/download/%{name}-%{version}.tar.gz
-# Source0-md5: dbb69af82fe3425eab845670528df3ce
+# Source0-md5: ae5b854ecc586f61eba890e3b430de08
 Patch0:                %{name}-link.patch
+Patch1:                %{name}-qt.patch
 URL:           http://www.dnssec-tools.org/
 BuildRequires: openssl-devel
 BuildRequires: perl-ExtUtils-MakeMaker
@@ -18,6 +23,15 @@ BuildRequires:       perl-TimeDate
 BuildRequires: perl-base
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
+%if %{with qt}
+BuildRequires: QtCore-devel >= 4
+BuildRequires: QtDeclarative-devel >= 4
+BuildRequires: QtGui-devel >= 4
+BuildRequires: QtNetwork-devel >= 4
+BuildRequires: QtSvg-devel >= 4
+BuildRequires: QtXml-devel >= 4
+BuildRequires: qt4-qmake >= 4
+%endif
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      perl-%{name} = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -32,6 +46,20 @@ Celem projektu DNSSEC-Tools jest stworzenie zbioru narzędzi, łatek,
 aplikacji, wrapperów, rozszerzeń i wtyczek pomagających przy wdrażaniu
 technologii związanych z DNSSEC.
 
+%package gui
+Summary:       DNSSEC tools with GUI
+Summary(pl.UTF-8):     Narzędzia DNSSEC z GUI
+Group:         X11/Applications
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description gui
+DNSSEC tools with Qt-based GUI: dnssec-check, dnssec-nodes,
+dnssec-system-tray and lookup.
+
+%description gui -l pl.UTF-8
+Narzędzia DNSSEC z opartym na Qt graficznym interfejsem użytkownika:
+dnssec-check, dnssec-nodes, dnssec-system-tray oraz lookup.
+
 %package libs
 Summary:       DNSSEC libraries
 Summary(pl.UTF-8):     Biblioteki DNSSEC
@@ -85,6 +113,7 @@ Moduły Perla wspierające DNSSEC.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %configure \
@@ -95,13 +124,34 @@ Moduły Perla wspierające DNSSEC.
        --with-perl-build-args='INSTALLDIRS=vendor'
 %{__make}
 
+%if %{with qt}
+cd validator/apps
+for d in dnssec-check dnssec-nodes dnssec-system-tray lookup ; do
+       cd $d
+       qmake-qt4 \
+               QMAKE_CXX="%{__cxx}" \
+               QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}" \
+               QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
+       %{__make}
+       cd ..
+done
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%if %{with qt}
+for d in dnssec-check dnssec-nodes dnssec-system-tray lookup ; do
+       %{__make} install -C validator/apps/$d \
+               INSTALL_ROOT=$RPM_BUILD_ROOT
+done
+%endif
+
 find $RPM_BUILD_ROOT%{perl_vendorarch}/auto -name .packlist | xargs -r %{__rm}
+# bugfix
+%{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/{dt-,}libval_check_conf.1
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -114,6 +164,8 @@ rm -rf $RPM_BUILD_ROOT
 %doc COPYING ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/blinkenlights
 %attr(755,root,root) %{_bindir}/bubbles
+%attr(755,root,root) %{_bindir}/buildrealms
+%attr(755,root,root) %{_bindir}/check-zone-expiration
 %attr(755,root,root) %{_bindir}/cleanarch
 %attr(755,root,root) %{_bindir}/cleankrf
 %attr(755,root,root) %{_bindir}/convertar
@@ -121,30 +173,40 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/donuts
 %attr(755,root,root) %{_bindir}/donutsd
 %attr(755,root,root) %{_bindir}/drawvalmap
+%attr(755,root,root) %{_bindir}/dt-danechk
+%attr(755,root,root) %{_bindir}/dt-getaddr
+%attr(755,root,root) %{_bindir}/dt-gethost
+%attr(755,root,root) %{_bindir}/dt-getname
+%attr(755,root,root) %{_bindir}/dt-getquery
+%attr(755,root,root) %{_bindir}/dt-getrrset
+%attr(755,root,root) %{_bindir}/dt-validate
 %attr(755,root,root) %{_bindir}/dtck
 %attr(755,root,root) %{_bindir}/dtconf
 %attr(755,root,root) %{_bindir}/dtconfchk
 %attr(755,root,root) %{_bindir}/dtdefs
 %attr(755,root,root) %{_bindir}/dtinitconf
+%attr(755,root,root) %{_bindir}/dtrealms
 %attr(755,root,root) %{_bindir}/expchk
 %attr(755,root,root) %{_bindir}/fixkrf
 %attr(755,root,root) %{_bindir}/genkrf
-%attr(755,root,root) %{_bindir}/getaddr
 %attr(755,root,root) %{_bindir}/getdnskeys
 %attr(755,root,root) %{_bindir}/getds
-%attr(755,root,root) %{_bindir}/gethost
-%attr(755,root,root) %{_bindir}/getname
-%attr(755,root,root) %{_bindir}/getquery
-%attr(755,root,root) %{_bindir}/getrrset
+%attr(755,root,root) %{_bindir}/grandvizier
 %attr(755,root,root) %{_bindir}/keyarch
+%attr(755,root,root) %{_bindir}/keymod
 %attr(755,root,root) %{_bindir}/krfcheck
 %attr(755,root,root) %{_bindir}/libval_check_conf
 %attr(755,root,root) %{_bindir}/lights
 %attr(755,root,root) %{_bindir}/lsdnssec
 %attr(755,root,root) %{_bindir}/lskrf
+%attr(755,root,root) %{_bindir}/lsrealm
 %attr(755,root,root) %{_bindir}/lsroll
 %attr(755,root,root) %{_bindir}/maketestzone
 %attr(755,root,root) %{_bindir}/mapper
+%attr(755,root,root) %{_bindir}/realmchk
+%attr(755,root,root) %{_bindir}/realmctl
+%attr(755,root,root) %{_bindir}/realminit
+%attr(755,root,root) %{_bindir}/realmset
 %attr(755,root,root) %{_bindir}/rollchk
 %attr(755,root,root) %{_bindir}/rollctl
 %attr(755,root,root) %{_bindir}/rollerd
@@ -156,14 +218,15 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/tachk
 %attr(755,root,root) %{_bindir}/timetrans
 %attr(755,root,root) %{_bindir}/trustman
-%attr(755,root,root) %{_bindir}/validate
 %attr(755,root,root) %{_bindir}/zonesigner
 %dir %{_sysconfdir}/dnssec-tools
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dnssec-tools/dnssec-tools.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dnssec-tools/validator-testcases
 %{_datadir}/%{name}
 %{_mandir}/man1/blinkenlights.1p*
+%{_mandir}/man1/buildrealms.1p*
 %{_mandir}/man1/bubbles.1p*
+%{_mandir}/man1/check-zone-expiration.1p*
 %{_mandir}/man1/cleanarch.1p*
 %{_mandir}/man1/cleankrf.1p*
 %{_mandir}/man1/convertar.1p*
@@ -172,30 +235,39 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/donuts.1p*
 %{_mandir}/man1/donutsd.1p*
 %{_mandir}/man1/drawvalmap.1p*
+%{_mandir}/man1/dt-getaddr.1*
+%{_mandir}/man1/dt-gethost.1*
+%{_mandir}/man1/dt-getname.1*
+%{_mandir}/man1/dt-getquery.1*
+%{_mandir}/man1/dt-getrrset.1*
+%{_mandir}/man1/dt-validate.1*
 %{_mandir}/man1/dtck.1p*
 %{_mandir}/man1/dtconf.1p*
 %{_mandir}/man1/dtconfchk.1p*
 %{_mandir}/man1/dtdefs.1p*
 %{_mandir}/man1/dtinitconf.1p*
+%{_mandir}/man1/dtrealms.1p*
 %{_mandir}/man1/expchk.1p*
 %{_mandir}/man1/fixkrf.1p*
 %{_mandir}/man1/genkrf.1p*
-%{_mandir}/man1/getaddr.1*
 %{_mandir}/man1/getdnskeys.1p*
 %{_mandir}/man1/getds.1p*
-%{_mandir}/man1/gethost.1*
-%{_mandir}/man1/getname.1*
-%{_mandir}/man1/getquery.1*
-%{_mandir}/man1/getrrset.1*
+%{_mandir}/man1/grandvizier.1p*
 %{_mandir}/man1/keyarch.1p*
+%{_mandir}/man1/keymod.1p*
 %{_mandir}/man1/krfcheck.1p*
 %{_mandir}/man1/libval_check_conf.1*
 %{_mandir}/man1/lights.1p*
 %{_mandir}/man1/lsdnssec.1p*
 %{_mandir}/man1/lskrf.1p*
+%{_mandir}/man1/lsrealm.1p*
 %{_mandir}/man1/lsroll.1p*
 %{_mandir}/man1/maketestzone.1p*
 %{_mandir}/man1/mapper.1p*
+%{_mandir}/man1/realmchk.1p*
+%{_mandir}/man1/realmctl.1p*
+%{_mandir}/man1/realminit.1p*
+%{_mandir}/man1/realmset.1p*
 %{_mandir}/man1/rollchk.1p*
 %{_mandir}/man1/rollctl.1p*
 %{_mandir}/man1/rollerd.1p*
@@ -207,17 +279,30 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/tachk.1p*
 %{_mandir}/man1/timetrans.1p*
 %{_mandir}/man1/trustman.1p*
-%{_mandir}/man1/validate.1*
 %{_mandir}/man1/zonesigner.1p*
 
+%if %{with qt}
+%files gui
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/dnssec-check
+%attr(755,root,root) %{_bindir}/dnssec-nodes
+%attr(755,root,root) %{_bindir}/dnssec-system-tray
+%attr(755,root,root) %{_bindir}/lookup
+%{_desktopdir}/dnssec-check.desktop
+%{_desktopdir}/lookup.desktop
+%{_iconsdir}/hicolor/48x48/apps/lookup.png
+%{_iconsdir}/hicolor/64x64/apps/dnssec-check.png
+%{_pixmapsdir}/lookup.xpm
+%endif
+
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libsres.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libsres.so.10
+%attr(755,root,root) %ghost %{_libdir}/libsres.so.13
 %attr(755,root,root) %{_libdir}/libval-threads.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libval-threads.so.10
+%attr(755,root,root) %ghost %{_libdir}/libval-threads.so.13
 %attr(755,root,root) %{_libdir}/libval_shim.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libval_shim.so.10
+%attr(755,root,root) %ghost %{_libdir}/libval_shim.so.13
 
 %files devel
 %defattr(644,root,root,755)
@@ -258,6 +343,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{perl_vendorarch}/auto/Net/DNS/SEC/Validator
 %{perl_vendorarch}/auto/Net/DNS/SEC/Validator/Validator.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Net/DNS/SEC/Validator/Validator.so
+%dir %{perl_vendorarch}/auto/Net/addrinfo
 %{perl_vendorarch}/auto/Net/addrinfo/addrinfo.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Net/addrinfo/addrinfo.so
 %{perl_vendorlib}/Net/DNS/SEC/Tools
This page took 0.105199 seconds and 4 git commands to generate.