]> git.pld-linux.org Git - packages/dnssec-tools.git/blame - dnssec-tools.spec
- updated to 1.14 (note: new sonames)
[packages/dnssec-tools.git] / dnssec-tools.spec
CommitLineData
b8f9ed2a
JB
1#
2# Conditional build:
3%bcond_without qt # Qt-based GUI tools
4#
d29da4dc
JB
5%include /usr/lib/rpm/macros.perl
6Summary: DNSSEC tools
7Summary(pl.UTF-8): Narzędzia DNSSEC
8Name: dnssec-tools
7c2c9caa 9Version: 1.14
ac2b58bd 10Release: 1
d29da4dc 11License: BSD
e355058c 12Group: Applications/Networking
d29da4dc 13Source0: http://www.dnssec-tools.org/download/%{name}-%{version}.tar.gz
7c2c9caa 14# Source0-md5: ae5b854ecc586f61eba890e3b430de08
d29da4dc 15Patch0: %{name}-link.patch
b8f9ed2a 16Patch1: %{name}-qt.patch
d29da4dc
JB
17URL: http://www.dnssec-tools.org/
18BuildRequires: openssl-devel
19BuildRequires: perl-ExtUtils-MakeMaker
20BuildRequires: perl-Net-DNS
21BuildRequires: perl-Net-DNS-SEC
22BuildRequires: perl-TimeDate
23BuildRequires: perl-base
24BuildRequires: perl-devel >= 1:5.8.0
25BuildRequires: rpm-perlprov >= 4.1-13
b8f9ed2a
JB
26%if %{with qt}
27BuildRequires: QtCore-devel >= 4
28BuildRequires: QtDeclarative-devel >= 4
29BuildRequires: QtGui-devel >= 4
30BuildRequires: QtNetwork-devel >= 4
31BuildRequires: QtSvg-devel >= 4
32BuildRequires: QtXml-devel >= 4
33BuildRequires: qt4-qmake >= 4
34%endif
d29da4dc
JB
35Requires: %{name}-libs = %{version}-%{release}
36Requires: perl-%{name} = %{version}-%{release}
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
40The goal of the DNSSEC-Tools project is to create a set of tools,
41patches, applications, wrappers, extensions, and plugins that will
42help ease the deployment of DNSSEC-related technologies.
43
44%description -l pl.UTF-8
45Celem projektu DNSSEC-Tools jest stworzenie zbioru narzędzi, łatek,
46aplikacji, wrapperów, rozszerzeń i wtyczek pomagających przy wdrażaniu
47technologii związanych z DNSSEC.
48
b8f9ed2a
JB
49%package gui
50Summary: DNSSEC tools with GUI
51Summary(pl.UTF-8): Narzędzia DNSSEC z GUI
52Group: X11/Applications
53Requires: %{name}-libs = %{version}-%{release}
54
55%description gui
56DNSSEC tools with Qt-based GUI: dnssec-check, dnssec-nodes,
57dnssec-system-tray and lookup.
58
59%description gui -l pl.UTF-8
60Narzędzia DNSSEC z opartym na Qt graficznym interfejsem użytkownika:
61dnssec-check, dnssec-nodes, dnssec-system-tray oraz lookup.
62
d29da4dc
JB
63%package libs
64Summary: DNSSEC libraries
65Summary(pl.UTF-8): Biblioteki DNSSEC
66Group: Libraries
67
68%description libs
69DNSSEC libraries.
70
71%description libs -l pl.UTF-8
72Biblioteki DNSSEC.
73
74%package devel
75Summary: Header files for DNSSEC libraries
76Summary(pl.UTF-8): Pliki nagłówkowe bibliotek DNSSEC
77Group: Development/Libraries
78Requires: %{name}-libs = %{version}-%{release}
79Requires: openssl-devel
80
81%description devel
82Header files for DNSSEC libraries.
83
84%description devel -l pl.UTF-8
85Pliki nagłówkowe bibliotek DNSSEC.
86
87%package static
88Summary: Static DNSSEC libraries
89Summary(pl.UTF-8): Statyczne biblioteki DNSSEC
90Group: Development/Libraries
91Requires: %{name}-devel = %{version}-%{release}
92
93%description static
94Static DNSSEC libraries.
95
96%description static -l pl.UTF-8
97Statyczne biblioteki DNSSEC.
98
99%package -n perl-%{name}
100Summary: Perl modules supporting DNSSEC
101Summary(pl.UTF-8): Moduły Perla wspierające DNSSEC
102Group: Development/Languages/Perl
103Requires: %{name}-libs = %{version}-%{release}
104Requires: perl-Net-DNS
105Requires: perl-Net-DNS-SEC
106
107%description -n perl-%{name}
108Perl modules supporting DNSSEC.
109
110%description -n perl-%{name} -l pl.UTF-8
111Moduły Perla wspierające DNSSEC.
112
113%prep
114%setup -q
115%patch0 -p1
b8f9ed2a 116%patch1 -p1
d29da4dc
JB
117
118%build
119%configure \
120 --disable-bind-checks \
121 --with-dlv \
122 --with-ipv6 \
123 --with-nsec3 \
124 --with-perl-build-args='INSTALLDIRS=vendor'
125%{__make}
126
b8f9ed2a
JB
127%if %{with qt}
128cd validator/apps
129for d in dnssec-check dnssec-nodes dnssec-system-tray lookup ; do
130 cd $d
131 qmake-qt4 \
132 QMAKE_CXX="%{__cxx}" \
133 QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}" \
134 QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
135 %{__make}
136 cd ..
137done
138%endif
139
d29da4dc
JB
140%install
141rm -rf $RPM_BUILD_ROOT
d29da4dc
JB
142%{__make} -j1 install \
143 DESTDIR=$RPM_BUILD_ROOT
144
b8f9ed2a
JB
145%if %{with qt}
146for d in dnssec-check dnssec-nodes dnssec-system-tray lookup ; do
147 %{__make} install -C validator/apps/$d \
148 INSTALL_ROOT=$RPM_BUILD_ROOT
149done
150%endif
151
d29da4dc 152find $RPM_BUILD_ROOT%{perl_vendorarch}/auto -name .packlist | xargs -r %{__rm}
421c53e3
JB
153# bugfix
154%{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/{dt-,}libval_check_conf.1
d29da4dc
JB
155
156%clean
157rm -rf $RPM_BUILD_ROOT
158
159%post libs -p /sbin/ldconfig
160%postun libs -p /sbin/ldconfig
161
162%files
163%defattr(644,root,root,755)
164%doc COPYING ChangeLog NEWS README
165%attr(755,root,root) %{_bindir}/blinkenlights
166%attr(755,root,root) %{_bindir}/bubbles
421c53e3
JB
167%attr(755,root,root) %{_bindir}/buildrealms
168%attr(755,root,root) %{_bindir}/check-zone-expiration
d29da4dc
JB
169%attr(755,root,root) %{_bindir}/cleanarch
170%attr(755,root,root) %{_bindir}/cleankrf
171%attr(755,root,root) %{_bindir}/convertar
172%attr(755,root,root) %{_bindir}/dnspktflow
173%attr(755,root,root) %{_bindir}/donuts
174%attr(755,root,root) %{_bindir}/donutsd
175%attr(755,root,root) %{_bindir}/drawvalmap
7c2c9caa 176%attr(755,root,root) %{_bindir}/dt-danechk
421c53e3
JB
177%attr(755,root,root) %{_bindir}/dt-getaddr
178%attr(755,root,root) %{_bindir}/dt-gethost
179%attr(755,root,root) %{_bindir}/dt-getname
180%attr(755,root,root) %{_bindir}/dt-getquery
181%attr(755,root,root) %{_bindir}/dt-getrrset
182%attr(755,root,root) %{_bindir}/dt-validate
d29da4dc
JB
183%attr(755,root,root) %{_bindir}/dtck
184%attr(755,root,root) %{_bindir}/dtconf
185%attr(755,root,root) %{_bindir}/dtconfchk
186%attr(755,root,root) %{_bindir}/dtdefs
187%attr(755,root,root) %{_bindir}/dtinitconf
421c53e3 188%attr(755,root,root) %{_bindir}/dtrealms
d29da4dc
JB
189%attr(755,root,root) %{_bindir}/expchk
190%attr(755,root,root) %{_bindir}/fixkrf
191%attr(755,root,root) %{_bindir}/genkrf
d29da4dc
JB
192%attr(755,root,root) %{_bindir}/getdnskeys
193%attr(755,root,root) %{_bindir}/getds
421c53e3 194%attr(755,root,root) %{_bindir}/grandvizier
d29da4dc 195%attr(755,root,root) %{_bindir}/keyarch
421c53e3 196%attr(755,root,root) %{_bindir}/keymod
d29da4dc
JB
197%attr(755,root,root) %{_bindir}/krfcheck
198%attr(755,root,root) %{_bindir}/libval_check_conf
199%attr(755,root,root) %{_bindir}/lights
200%attr(755,root,root) %{_bindir}/lsdnssec
201%attr(755,root,root) %{_bindir}/lskrf
421c53e3 202%attr(755,root,root) %{_bindir}/lsrealm
d29da4dc
JB
203%attr(755,root,root) %{_bindir}/lsroll
204%attr(755,root,root) %{_bindir}/maketestzone
205%attr(755,root,root) %{_bindir}/mapper
421c53e3
JB
206%attr(755,root,root) %{_bindir}/realmchk
207%attr(755,root,root) %{_bindir}/realmctl
208%attr(755,root,root) %{_bindir}/realminit
209%attr(755,root,root) %{_bindir}/realmset
d29da4dc
JB
210%attr(755,root,root) %{_bindir}/rollchk
211%attr(755,root,root) %{_bindir}/rollctl
212%attr(755,root,root) %{_bindir}/rollerd
213%attr(755,root,root) %{_bindir}/rollinit
214%attr(755,root,root) %{_bindir}/rolllog
215%attr(755,root,root) %{_bindir}/rollrec-editor
216%attr(755,root,root) %{_bindir}/rollset
217%attr(755,root,root) %{_bindir}/signset-editor
218%attr(755,root,root) %{_bindir}/tachk
219%attr(755,root,root) %{_bindir}/timetrans
220%attr(755,root,root) %{_bindir}/trustman
d29da4dc
JB
221%attr(755,root,root) %{_bindir}/zonesigner
222%dir %{_sysconfdir}/dnssec-tools
223%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dnssec-tools/dnssec-tools.conf
224%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dnssec-tools/validator-testcases
225%{_datadir}/%{name}
226%{_mandir}/man1/blinkenlights.1p*
421c53e3 227%{_mandir}/man1/buildrealms.1p*
d29da4dc 228%{_mandir}/man1/bubbles.1p*
421c53e3 229%{_mandir}/man1/check-zone-expiration.1p*
d29da4dc
JB
230%{_mandir}/man1/cleanarch.1p*
231%{_mandir}/man1/cleankrf.1p*
232%{_mandir}/man1/convertar.1p*
233%{_mandir}/man1/dnspktflow.1p*
234%{_mandir}/man1/dnssec-tools.1*
235%{_mandir}/man1/donuts.1p*
236%{_mandir}/man1/donutsd.1p*
237%{_mandir}/man1/drawvalmap.1p*
421c53e3
JB
238%{_mandir}/man1/dt-getaddr.1*
239%{_mandir}/man1/dt-gethost.1*
240%{_mandir}/man1/dt-getname.1*
241%{_mandir}/man1/dt-getquery.1*
242%{_mandir}/man1/dt-getrrset.1*
243%{_mandir}/man1/dt-validate.1*
d29da4dc
JB
244%{_mandir}/man1/dtck.1p*
245%{_mandir}/man1/dtconf.1p*
246%{_mandir}/man1/dtconfchk.1p*
247%{_mandir}/man1/dtdefs.1p*
248%{_mandir}/man1/dtinitconf.1p*
421c53e3 249%{_mandir}/man1/dtrealms.1p*
d29da4dc
JB
250%{_mandir}/man1/expchk.1p*
251%{_mandir}/man1/fixkrf.1p*
252%{_mandir}/man1/genkrf.1p*
d29da4dc
JB
253%{_mandir}/man1/getdnskeys.1p*
254%{_mandir}/man1/getds.1p*
421c53e3 255%{_mandir}/man1/grandvizier.1p*
d29da4dc 256%{_mandir}/man1/keyarch.1p*
421c53e3 257%{_mandir}/man1/keymod.1p*
d29da4dc
JB
258%{_mandir}/man1/krfcheck.1p*
259%{_mandir}/man1/libval_check_conf.1*
260%{_mandir}/man1/lights.1p*
261%{_mandir}/man1/lsdnssec.1p*
262%{_mandir}/man1/lskrf.1p*
421c53e3 263%{_mandir}/man1/lsrealm.1p*
d29da4dc
JB
264%{_mandir}/man1/lsroll.1p*
265%{_mandir}/man1/maketestzone.1p*
266%{_mandir}/man1/mapper.1p*
421c53e3
JB
267%{_mandir}/man1/realmchk.1p*
268%{_mandir}/man1/realmctl.1p*
269%{_mandir}/man1/realminit.1p*
270%{_mandir}/man1/realmset.1p*
d29da4dc
JB
271%{_mandir}/man1/rollchk.1p*
272%{_mandir}/man1/rollctl.1p*
273%{_mandir}/man1/rollerd.1p*
274%{_mandir}/man1/rollinit.1p*
275%{_mandir}/man1/rolllog.1p*
276%{_mandir}/man1/rollrec-editor.1p*
277%{_mandir}/man1/rollset.1p*
278%{_mandir}/man1/signset-editor.1p*
279%{_mandir}/man1/tachk.1p*
280%{_mandir}/man1/timetrans.1p*
281%{_mandir}/man1/trustman.1p*
d29da4dc
JB
282%{_mandir}/man1/zonesigner.1p*
283
b8f9ed2a
JB
284%if %{with qt}
285%files gui
286%defattr(644,root,root,755)
287%attr(755,root,root) %{_bindir}/dnssec-check
288%attr(755,root,root) %{_bindir}/dnssec-nodes
289%attr(755,root,root) %{_bindir}/dnssec-system-tray
290%attr(755,root,root) %{_bindir}/lookup
291%{_desktopdir}/dnssec-check.desktop
292%{_desktopdir}/lookup.desktop
293%{_iconsdir}/hicolor/48x48/apps/lookup.png
294%{_iconsdir}/hicolor/64x64/apps/dnssec-check.png
295%{_pixmapsdir}/lookup.xpm
296%endif
297
d29da4dc
JB
298%files libs
299%defattr(644,root,root,755)
300%attr(755,root,root) %{_libdir}/libsres.so.*.*.*
7c2c9caa 301%attr(755,root,root) %ghost %{_libdir}/libsres.so.13
d29da4dc 302%attr(755,root,root) %{_libdir}/libval-threads.so.*.*.*
7c2c9caa 303%attr(755,root,root) %ghost %{_libdir}/libval-threads.so.13
d29da4dc 304%attr(755,root,root) %{_libdir}/libval_shim.so.*.*.*
7c2c9caa 305%attr(755,root,root) %ghost %{_libdir}/libval_shim.so.13
d29da4dc
JB
306
307%files devel
308%defattr(644,root,root,755)
309%attr(755,root,root) %{_bindir}/libval-config
310%attr(755,root,root) %{_libdir}/libsres.so
311%attr(755,root,root) %{_libdir}/libval-threads.so
312%attr(755,root,root) %{_libdir}/libval_shim.so
313%{_libdir}/libsres.la
314%{_libdir}/libval-threads.la
315%{_libdir}/libval_shim.la
316%{_includedir}/validator
317%{_mandir}/man3/dnsval.conf.3*
318%{_mandir}/man3/dnsval_conf*.3*
319%{_mandir}/man3/libsres.3*
320%{_mandir}/man3/libval.3*
321%{_mandir}/man3/libval_shim.3*
322%{_mandir}/man3/p_ac_status.3*
323%{_mandir}/man3/p_val_status.3*
324%{_mandir}/man3/resolv_conf_*.3*
325%{_mandir}/man3/root_hints_*.3*
326%{_mandir}/man3/val_*.3*
327
328%files static
329%defattr(644,root,root,755)
330%{_libdir}/libsres.a
331%{_libdir}/libval-threads.a
332%{_libdir}/libval_shim.a
333
334%files -n perl-%{name}
335%defattr(644,root,root,755)
336%dir %{perl_vendorarch}/Net/DNS/SEC
337%{perl_vendorarch}/Net/DNS/SEC/Tools
338%{perl_vendorarch}/Net/DNS/SEC/Validator.pm
339%{perl_vendorarch}/Net/DNS/SEC/defines.pl
340%{perl_vendorarch}/Net/DNS/ZoneFile
341%{perl_vendorarch}/Net/addrinfo.pm
342%dir %{perl_vendorarch}/auto/Net/DNS/SEC
343%dir %{perl_vendorarch}/auto/Net/DNS/SEC/Validator
344%{perl_vendorarch}/auto/Net/DNS/SEC/Validator/Validator.bs
345%attr(755,root,root) %{perl_vendorarch}/auto/Net/DNS/SEC/Validator/Validator.so
e355058c 346%dir %{perl_vendorarch}/auto/Net/addrinfo
d29da4dc
JB
347%{perl_vendorarch}/auto/Net/addrinfo/addrinfo.bs
348%attr(755,root,root) %{perl_vendorarch}/auto/Net/addrinfo/addrinfo.so
349%{perl_vendorlib}/Net/DNS/SEC/Tools
350%{_mandir}/man3/Net::DNS::SEC::Tools::*.3pm*
351%{_mandir}/man3/Net::DNS::SEC::Validator.3pm*
352%{_mandir}/man3/Net::DNS::ZoneFile::Fast.3pm*
353%{_mandir}/man3/Net::addrinfo.3pm*
This page took 0.134601 seconds and 4 git commands to generate.