]> git.pld-linux.org Git - packages/dnprogs.git/blob - dnprogs.spec
- removed spaces from %attr macros parameters.
[packages/dnprogs.git] / dnprogs.spec
1 Summary: DECnet tools and libraries
2 Name: dnprogs
3
4 %define dnet_major 1
5 %define dnet_version %{dnet_major}.2
6
7 %define dap_major 1
8 %define dap_version %{dap_major}.05a
9
10 %define dnprogs_version %{dap_version}
11
12 Version: %{dnprogs_version}
13 Release: 2
14 Copyright: GPL
15 Group: Networking/Utilities
16 URL: http://linux.dreamtime.org/decnet/
17 Source: ftp://ftp.dreamtime.org/pub/decnet/%{name}-%{version}.tar.gz
18 Patch0: dnprogs-1.05a-make.patch.gz
19 Patch1: dnprogs-1.05a-rc.patch.gz
20 ExclusiveOS: Linux
21 Prereq: /sbin/chkconfig /sbin/ldconfig
22 BuildRoot: /var/tmp/%{name}-root
23
24 %description
25 DECnet programs for Linux.
26
27 These tools are the application layer interface for DECnet on Linux systems.
28 They provide file/terminal access facilities between OpenVMS and Linux and 
29 remote execution of commands.
30
31 To use them you will need to have DECnet built into your kernel.
32 See http://linux.dreamtime.org/decnet/ to get the kernel patch and
33 instructions on how to apply it.
34
35 %changelog
36 * Thu Apr  1 1999 Maciej W. Rozycki <macro@ds2.pg.gda.pl>
37 - initial build based on the spec file included in dnprogs 1.05a
38   distribution
39 - added a patch to clean up makefiles
40 - modified configuration to link against external uulib
41 - added a patch to customize the rc script
42
43 %prep
44 %setup
45 %patch0 -p1 -b .make~
46 %patch1 -p1 -b .rc~
47
48 find . -type f -name '*~' -print0 | xargs -0 rm -f
49
50 %build
51 make "DFLAGS=$RPM_OPT_FLAGS" LIBCRYPT=-lcrypt SHADOWDEFS=-DSHADOW_PWD \
52         prefix=/usr libprefix=/usr sysconfprefix=
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 mkdir -p $RPM_BUILD_ROOT
57 chmod go= $RPM_BUILD_ROOT
58
59 mkdir -p $RPM_BUILD_ROOT/{etc/rc.d/{init,rc{0,1,2,3,4,5,6}}.d,lib,sbin}
60 make prefix=$RPM_BUILD_ROOT/usr libprefix=$RPM_BUILD_ROOT/usr \
61         sysconfprefix=$RPM_BUILD_ROOT install
62
63 rm -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so
64 rm -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so.%{dnet_major}
65 mv -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so.%{dnet_version} \
66         $RPM_BUILD_ROOT/lib/libdnet.so.%{dnet_version}
67 ln -s libdnet.so.%{dnet_version} \
68         $RPM_BUILD_ROOT/lib/libdnet.so.%{dnet_major}
69 ln -s ../../lib/libdnet.so.%{dnet_major} \
70         $RPM_BUILD_ROOT%{_libdir}/libdnet.so
71
72 mv -f $RPM_BUILD_ROOT%{_sbindir}/startnet $RPM_BUILD_ROOT/sbin/startnet
73
74 touch $RPM_BUILD_ROOT/etc/decnet.proxy
75
76 install -m 755 scripts/decnet.sh $RPM_BUILD_ROOT/etc/rc.d/init.d/decnet
77 ln -fs ../init.d/decnet $RPM_BUILD_ROOT/etc/rc.d/rc0.d/K90decnet
78 ln -fs ../init.d/decnet $RPM_BUILD_ROOT/etc/rc.d/rc1.d/K90decnet
79 ln -fs ../init.d/decnet $RPM_BUILD_ROOT/etc/rc.d/rc2.d/K90decnet
80 ln -fs ../init.d/decnet $RPM_BUILD_ROOT/etc/rc.d/rc3.d/K90decnet
81 ln -fs ../init.d/decnet $RPM_BUILD_ROOT/etc/rc.d/rc4.d/K90decnet
82 ln -fs ../init.d/decnet $RPM_BUILD_ROOT/etc/rc.d/rc5.d/K90decnet
83 ln -fs ../init.d/decnet $RPM_BUILD_ROOT/etc/rc.d/rc6.d/K90decnet
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post 
89 /sbin/chkconfig --add decnet
90 /sbin/ldconfig
91
92 %postun
93 /sbin/ldconfig
94 if [ $1 = 0 ]; then
95     /sbin/chkconfig --del decnet
96 fi
97
98 %files
99 %defattr(644,root,root,755)
100 %doc Documentation/* README NEWS dnprogs.lsm
101
102 %config(noreplace) /etc/decnet.conf
103 %config(noreplace) %verify(not md5 mtime size) /etc/decnet.proxy
104
105 %attr(755,root,root) %config /etc/rc.d/init.d/decnet
106 %attr(-,root,root) %config(missingok) /etc/rc.d/rc0.d/K90decnet
107 %attr(-,root,root) %config(missingok) /etc/rc.d/rc1.d/K90decnet
108 %attr(-,root,root) %config(missingok) /etc/rc.d/rc2.d/K90decnet
109 %attr(-,root,root) %config(missingok) /etc/rc.d/rc3.d/K90decnet
110 %attr(-,root,root) %config(missingok) /etc/rc.d/rc4.d/K90decnet
111 %attr(-,root,root) %config(missingok) /etc/rc.d/rc5.d/K90decnet
112 %attr(-,root,root) %config(missingok) /etc/rc.d/rc6.d/K90decnet
113
114 %attr(-,root,root) /lib/libdnet.so.%{dnet_major}
115 %attr(755,root,root) /lib/libdnet.so.%{dnet_version}
116
117 %attr(755,root,root) /sbin/startnet
118
119 %attr(755,root,root) %{_bindir}/dncopy
120 %attr(755,root,root) %{_bindir}/dndel
121 %attr(755,root,root) %{_bindir}/dndir
122 %attr(755,root,root) %{_bindir}/dnping
123 %attr(-,root,root) %{_bindir}/dnprint
124 %attr(755,root,root) %{_bindir}/dnsubmit
125 %attr(755,root,root) %{_bindir}/dntask
126 %attr(-,root,root) %{_bindir}/dntype
127 %attr(755,root,root) %{_bindir}/phone
128 %attr(755,root,root) %{_bindir}/sethost
129
130 %{_includedir}/netdnet
131
132 %{_libdir}/libdnet.a
133 %attr(-,root,root) %{_libdir}/libdnet.so
134 %{_libdir}/libdap.a
135 %attr(-,root,root) %{_libdir}/libdap.so
136 %attr(-,root,root) %{_libdir}/libdap.so.%{dap_major}
137 %attr(755,root,root) %{_libdir}/libdap.so.%{dap_version}
138
139 %{_mandir}/man1/ctermd.1
140 %{_mandir}/man1/dncopy.1
141 %{_mandir}/man1/dndel.1
142 %{_mandir}/man1/dndir.1
143 %{_mandir}/man1/dnmirror.1
144 #%{_mandir}/man1/dnmount.1
145 %{_mandir}/man1/dnping.1
146 %attr(-,root,root) %{_mandir}/man1/dnprint.1
147 %{_mandir}/man1/dnsubmit.1
148 %{_mandir}/man1/dntask.1
149 %attr(-,root,root) %{_mandir}/man1/dntype.1
150 %{_mandir}/man1/phone.1
151 %{_mandir}/man1/sethost.1
152 %{_mandir}/man1/startnet.1
153
154 %{_mandir}/man3/dnet_addr.3
155 %{_mandir}/man3/dnet_conn.3
156 %{_mandir}/man3/dnet_htoa.3
157 %{_mandir}/man3/dnet_ntoa.3
158 %{_mandir}/man3/getnodeadd.3
159 %{_mandir}/man3/getnodebyaddr.3
160 %{_mandir}/man3/getnodebyname.3
161 %{_mandir}/man3/libdnet.3
162 %{_mandir}/man3/setnodeent.3
163
164 %{_mandir}/man5/decnet.conf.5
165 %{_mandir}/man5/decnet.proxy.5
166
167 %{_mandir}/man8/fal.8
168 %{_mandir}/man8/phoned.8
169
170 %attr(755,root,root) %{_sbindir}/ctermd
171 %attr(755,root,root) %{_sbindir}/dnmirror
172 %attr(755,root,root) %{_sbindir}/fal
173 %attr(755,root,root) %{_sbindir}/phoned
174 %attr(755,root,root) %{_sbindir}/sendvmsmail
175 %attr(755,root,root) %{_sbindir}/vmsmaild
This page took 0.104502 seconds and 3 git commands to generate.