]> git.pld-linux.org Git - packages/dnprogs.git/blob - dnprogs.spec
- reverting last change: removing new macros from %p{re,ost}{,un}
[packages/dnprogs.git] / dnprogs.spec
1 Summary:        DECnet tools and libraries
2 Summary(pl):    Narzêdzia i biblioteki DECnet
3 Name:           dnprogs
4
5 %define dnet_major 1
6 %define dnet_version %{dnet_major}.2
7
8 %define dap_major 1
9 %define dap_version %{dap_major}.05a
10
11 %define dnprogs_version %{dap_version}
12
13 Version:        %{dnprogs_version}
14 Release:        2
15 License:        GPL
16 Group:          Networking/Utilities
17 Group(de):      Netzwerkwesen/Werkzeuge
18 Group(pl):      Sieciowe/Narzêdzia
19 URL:            http://linux.dreamtime.org/decnet/
20 Source0:        ftp://ftp.dreamtime.org/pub/decnet/%{name}-%{version}.tar.gz
21 Patch0:         %{name}-1.05a-make.patch.gz
22 Patch1:         %{name}-1.05a-rc.patch.gz
23 ExclusiveOS:    Linux
24 Prereq:         /sbin/chkconfig
25 Prereq:         /sbin/ldconfig
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 DECnet programs for Linux.
30
31 These tools are the application layer interface for DECnet on Linux
32 systems. They provide file/terminal access facilities between OpenVMS
33 and Linux and remote execution of commands.
34
35 To use them you will need to have DECnet built into your kernel. See
36 http://linux.dreamtime.org/decnet/ to get the kernel patch and
37 instructions on how to apply it.
38
39 %description -l pl
40 Programy DECnet dla Linuksa. Narzêdzia te stanowi± warstwê interfejsu
41 aplikacji dla DECnetu na systemach linuksowych. Udostêpniaj± pewne
42 u³atwienia w dostêpie terminalowym i plikowym miêdzy OpenVMS-em a
43 Linuksem oraz zdalnym wykonywaniem poleceñ. Aby ich u¿yæ musi siê mieæ
44 wbudowan± w j±do obs³ugê DECnetu. £atê oraz instrukcje dotycz±ce jej
45 instalacji mo¿na uzyskaæ na stronie:
46 http://linux.dreamtime.org/decnet/.
47
48 %prep
49 %setup -q
50 %patch0 -p1 -b .make~
51 %patch1 -p1 -b .rc~
52
53 find . -type f -name '*~' -print0 | xargs -0 rm -f
54
55 %build
56 %{__make} DFLAGS="%{rpmcflags}" LIBCRYPT=-lcrypt SHADOWDEFS=-DSHADOW_PWD \
57         prefix=%{_prefix} libprefix=%{_prefix} sysconfprefix=
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT
62 chmod go= $RPM_BUILD_ROOT
63
64 install -d $RPM_BUILD_ROOT/{etc/rc.d/{init,rc{0,1,2,3,4,5,6}}.d,lib,sbin}
65 %{__make} prefix=$RPM_BUILD_ROOT%{_prefix} libprefix=$RPM_BUILD_ROOT%{_prefix} \
66         sysconfprefix=$RPM_BUILD_ROOT install
67
68 rm -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so
69 rm -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so.%{dnet_major}
70 mv -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so.%{dnet_version} \
71         $RPM_BUILD_ROOT/lib/libdnet.so.%{dnet_version}
72 ln -sf libdnet.so.%{dnet_version} \
73         $RPM_BUILD_ROOT/lib/libdnet.so.%{dnet_major}
74 ln -sf ../../lib/libdnet.so.%{dnet_major} \
75         $RPM_BUILD_ROOT%{_libdir}/libdnet.so
76
77 mv -f $RPM_BUILD_ROOT%{_sbindir}/startnet $RPM_BUILD_ROOT/sbin/startnet
78
79 touch $RPM_BUILD_ROOT%{_sysconfdir}/decnet.proxy
80
81 install scripts/decnet.sh $RPM_BUILD_ROOT/etc/rc.d/init.d/decnet
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post 
87 /sbin/chkconfig --add decnet
88 /sbin/ldconfig
89
90 %postun
91 /sbin/ldconfig
92 if [ $1 = 0 ]; then
93     /sbin/chkconfig --del decnet
94 fi
95
96 %files
97 %defattr(644,root,root,755)
98 %doc Documentation/* README NEWS dnprogs.lsm
99
100 %config(noreplace) %{_sysconfdir}/decnet.conf
101 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/decnet.proxy
102
103 %attr(754,root,root) /etc/rc.d/init.d/decnet
104 %attr(-,root,root) /lib/libdnet.so.%{dnet_major}
105 %attr(755,root,root) /lib/libdnet.so.%{dnet_version}
106
107 %attr(755,root,root) /sbin/startnet
108
109 %attr(755,root,root) %{_bindir}/dncopy
110 %attr(755,root,root) %{_bindir}/dndel
111 %attr(755,root,root) %{_bindir}/dndir
112 %attr(755,root,root) %{_bindir}/dnping
113 %attr(-,root,root) %{_bindir}/dnprint
114 %attr(755,root,root) %{_bindir}/dnsubmit
115 %attr(755,root,root) %{_bindir}/dntask
116 %attr(-,root,root) %{_bindir}/dntype
117 %attr(755,root,root) %{_bindir}/phone
118 %attr(755,root,root) %{_bindir}/sethost
119
120 %{_includedir}/netdnet
121
122 %{_libdir}/libdnet.a
123 %attr(-,root,root) %{_libdir}/libdnet.so
124 %{_libdir}/libdap.a
125 %attr(-,root,root) %{_libdir}/libdap.so
126 %attr(-,root,root) %{_libdir}/libdap.so.%{dap_major}
127 %attr(755,root,root) %{_libdir}/libdap.so.%{dap_version}
128
129 %{_mandir}/man1/ctermd.1*
130 %{_mandir}/man1/dncopy.1*
131 %{_mandir}/man1/dndel.1*
132 %{_mandir}/man1/dndir.1*
133 %{_mandir}/man1/dnmirror.1*
134 #%{_mandir}/man1/dnmount.1*
135 %{_mandir}/man1/dnping.1*
136 %{_mandir}/man1/dnprint.1*
137 %{_mandir}/man1/dnsubmit.1*
138 %{_mandir}/man1/dntask.1*
139 %{_mandir}/man1/dntype.1*
140 %{_mandir}/man1/phone.1*
141 %{_mandir}/man1/sethost.1*
142 %{_mandir}/man1/startnet.1*
143
144 %{_mandir}/man3/dnet_addr.3*
145 %{_mandir}/man3/dnet_conn.3*
146 %{_mandir}/man3/dnet_htoa.3*
147 %{_mandir}/man3/dnet_ntoa.3*
148 %{_mandir}/man3/getnodeadd.3*
149 %{_mandir}/man3/getnodebyaddr.3*
150 %{_mandir}/man3/getnodebyname.3*
151 %{_mandir}/man3/libdnet.3*
152 %{_mandir}/man3/setnodeent.3*
153
154 %{_mandir}/man5/decnet.conf.5*
155 %{_mandir}/man5/decnet.proxy.5*
156
157 %{_mandir}/man8/fal.8*
158 %{_mandir}/man8/phoned.8*
159
160 %attr(755,root,root) %{_sbindir}/ctermd
161 %attr(755,root,root) %{_sbindir}/dnmirror
162 %attr(755,root,root) %{_sbindir}/fal
163 %attr(755,root,root) %{_sbindir}/phoned
164 %attr(755,root,root) %{_sbindir}/sendvmsmail
165 %attr(755,root,root) %{_sbindir}/vmsmaild
This page took 0.085935 seconds and 3 git commands to generate.