]> git.pld-linux.org Git - packages/dnprogs.git/blob - dnprogs.spec
- massive attack: perl -pi -e "s/^#+\%\{/#\%\%\{/"
[packages/dnprogs.git] / dnprogs.spec
1 Summary:        DECnet tools and libraries
2 Summary(pl):    Narzêdzia i biblioteki DECnet
3 Name:           dnprogs
4
5 %define dnet_major 1
6 %define dnet_version %{dnet_major}.2
7
8 %define dap_major 1
9 %define dap_version %{dap_major}.05a
10
11 %define dnprogs_version %{dap_version}
12
13 Version:        %{dnprogs_version}
14 Release:        2
15 License:        GPL
16 Group:          Networking/Utilities
17 URL:            http://linux.dreamtime.org/decnet/
18 Source0:        ftp://ftp.dreamtime.org/pub/decnet/%{name}-%{version}.tar.gz
19 Patch0:         %{name}-1.05a-make.patch.gz
20 Patch1:         %{name}-1.05a-rc.patch.gz
21 ExclusiveOS:    Linux
22 Prereq:         /sbin/chkconfig
23 Prereq:         /sbin/ldconfig
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 DECnet programs for Linux.
28
29 These tools are the application layer interface for DECnet on Linux
30 systems. They provide file/terminal access facilities between OpenVMS
31 and Linux and remote execution of commands.
32
33 To use them you will need to have DECnet built into your kernel. See
34 http://linux.dreamtime.org/decnet/ to get the kernel patch and
35 instructions on how to apply it.
36
37 %description -l pl
38 Programy DECnet dla Linuksa. Narzêdzia te stanowi± warstwê interfejsu
39 aplikacji dla DECnetu na systemach linuksowych. Udostêpniaj± pewne
40 u³atwienia w dostêpie terminalowym i plikowym miêdzy OpenVMS-em a
41 Linuksem oraz zdalnym wykonywaniem poleceñ. Aby ich u¿yæ musi siê mieæ
42 wbudowan± w j±do obs³ugê DECnetu. £atê oraz instrukcje dotycz±ce jej
43 instalacji mo¿na uzyskaæ na stronie:
44 http://linux.dreamtime.org/decnet/.
45
46 %prep
47 %setup -q
48 %patch0 -p1 -b .make~
49 %patch1 -p1 -b .rc~
50
51 find . -type f -name '*~' -print0 | xargs -0 rm -f
52
53 %build
54 %{__make} DFLAGS="%{rpmcflags}" LIBCRYPT=-lcrypt SHADOWDEFS=-DSHADOW_PWD \
55         prefix=%{_prefix} libprefix=%{_prefix} sysconfprefix=
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT
60 chmod go= $RPM_BUILD_ROOT
61
62 install -d $RPM_BUILD_ROOT/{etc/rc.d/{init,rc{0,1,2,3,4,5,6}}.d,lib,sbin}
63 %{__make} prefix=$RPM_BUILD_ROOT%{_prefix} libprefix=$RPM_BUILD_ROOT%{_prefix} \
64         sysconfprefix=$RPM_BUILD_ROOT install
65
66 rm -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so
67 rm -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so.%{dnet_major}
68 mv -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so.%{dnet_version} \
69         $RPM_BUILD_ROOT/lib/libdnet.so.%{dnet_version}
70 ln -sf libdnet.so.%{dnet_version} \
71         $RPM_BUILD_ROOT/lib/libdnet.so.%{dnet_major}
72 ln -sf ../../lib/libdnet.so.%{dnet_major} \
73         $RPM_BUILD_ROOT%{_libdir}/libdnet.so
74
75 mv -f $RPM_BUILD_ROOT%{_sbindir}/startnet $RPM_BUILD_ROOT/sbin/startnet
76
77 touch $RPM_BUILD_ROOT%{_sysconfdir}/decnet.proxy
78
79 install scripts/decnet.sh $RPM_BUILD_ROOT/etc/rc.d/init.d/decnet
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post
85 /sbin/chkconfig --add decnet
86 /sbin/ldconfig
87
88 %postun
89 /sbin/ldconfig
90 if [ $1 = 0 ]; then
91     /sbin/chkconfig --del decnet
92 fi
93
94 %files
95 %defattr(644,root,root,755)
96 %doc Documentation/* README NEWS dnprogs.lsm
97
98 %config(noreplace) %{_sysconfdir}/decnet.conf
99 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/decnet.proxy
100
101 %attr(754,root,root) /etc/rc.d/init.d/decnet
102 %attr(-,root,root) /lib/libdnet.so.%{dnet_major}
103 %attr(755,root,root) /lib/libdnet.so.%{dnet_version}
104
105 %attr(755,root,root) /sbin/startnet
106
107 %attr(755,root,root) %{_bindir}/dncopy
108 %attr(755,root,root) %{_bindir}/dndel
109 %attr(755,root,root) %{_bindir}/dndir
110 %attr(755,root,root) %{_bindir}/dnping
111 %attr(-,root,root) %{_bindir}/dnprint
112 %attr(755,root,root) %{_bindir}/dnsubmit
113 %attr(755,root,root) %{_bindir}/dntask
114 %attr(-,root,root) %{_bindir}/dntype
115 %attr(755,root,root) %{_bindir}/phone
116 %attr(755,root,root) %{_bindir}/sethost
117
118 %{_includedir}/netdnet
119
120 %{_libdir}/libdnet.a
121 %attr(-,root,root) %{_libdir}/libdnet.so
122 %{_libdir}/libdap.a
123 %attr(-,root,root) %{_libdir}/libdap.so
124 %attr(-,root,root) %{_libdir}/libdap.so.%{dap_major}
125 %attr(755,root,root) %{_libdir}/libdap.so.%{dap_version}
126
127 %{_mandir}/man1/ctermd.1*
128 %{_mandir}/man1/dncopy.1*
129 %{_mandir}/man1/dndel.1*
130 %{_mandir}/man1/dndir.1*
131 %{_mandir}/man1/dnmirror.1*
132 #%%{_mandir}/man1/dnmount.1*
133 %{_mandir}/man1/dnping.1*
134 %{_mandir}/man1/dnprint.1*
135 %{_mandir}/man1/dnsubmit.1*
136 %{_mandir}/man1/dntask.1*
137 %{_mandir}/man1/dntype.1*
138 %{_mandir}/man1/phone.1*
139 %{_mandir}/man1/sethost.1*
140 %{_mandir}/man1/startnet.1*
141
142 %{_mandir}/man3/dnet_addr.3*
143 %{_mandir}/man3/dnet_conn.3*
144 %{_mandir}/man3/dnet_htoa.3*
145 %{_mandir}/man3/dnet_ntoa.3*
146 %{_mandir}/man3/getnodeadd.3*
147 %{_mandir}/man3/getnodebyaddr.3*
148 %{_mandir}/man3/getnodebyname.3*
149 %{_mandir}/man3/libdnet.3*
150 %{_mandir}/man3/setnodeent.3*
151
152 %{_mandir}/man5/decnet.conf.5*
153 %{_mandir}/man5/decnet.proxy.5*
154
155 %{_mandir}/man8/fal.8*
156 %{_mandir}/man8/phoned.8*
157
158 %attr(755,root,root) %{_sbindir}/ctermd
159 %attr(755,root,root) %{_sbindir}/dnmirror
160 %attr(755,root,root) %{_sbindir}/fal
161 %attr(755,root,root) %{_sbindir}/phoned
162 %attr(755,root,root) %{_sbindir}/sendvmsmail
163 %attr(755,root,root) %{_sbindir}/vmsmaild
This page took 0.100039 seconds and 3 git commands to generate.