]> git.pld-linux.org Git - packages/dnprogs.git/blob - dnprogs.spec
25d4af93b43d3cf4c0669c37ce93fd3f495c107a
[packages/dnprogs.git] / dnprogs.spec
1 %define dnet_major 1
2 %define dnet_version %{dnet_major}.2
3 %define dap_major 2
4 %define dap_version %{dap_major}.23
5 %define dnprogs_version %{dap_version}
6 Summary:        DECnet tools and libraries
7 Summary(pl):    Narzêdzia i biblioteki DECnet
8 Name:           dnprogs
9 Version:        %{dnprogs_version}
10 Release:        0.1
11 License:        GPL
12 Group:          Networking/Utilities
13 Source0:        http://dl.sourceforge.net/linux-decnet/%{name}-%{version}.tar.gz
14 # Source0-md5:  666e1479f60f7f0fe3bf8da3abab98bd
15 URL:            http://linux-decnet.sourceforge.net/
16 ExclusiveOS:    Linux
17 PreReq:         rc-scripts
18 Requires(post,preun):   /sbin/chkconfig
19 Requires(post): /sbin/ldconfig
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 DECnet programs for Linux.
24
25 These tools are the application layer interface for DECnet on Linux
26 systems. They provide file/terminal access facilities between OpenVMS
27 and Linux and remote execution of commands.
28
29 To use them you will need to have DECnet built into your kernel. See
30 http://linux.dreamtime.org/decnet/ to get the kernel patch and
31 instructions on how to apply it.
32
33 %description -l pl
34 Programy DECnet dla Linuksa. Narzêdzia te stanowi± warstwê interfejsu
35 aplikacji dla DECnetu na systemach linuksowych. Udostêpniaj± pewne
36 u³atwienia w dostêpie terminalowym i plikowym miêdzy OpenVMS-em a
37 Linuksem oraz zdalnym wykonywaniem poleceñ. Aby ich u¿yæ trzeba mieæ
38 wbudowan± w j±dro obs³ugê DECnetu. £atê oraz instrukcje dotycz±ce jej
39 instalacji mo¿na uzyskaæ na stronie:
40 http://linux.dreamtime.org/decnet/.
41
42 %prep
43 %setup -q
44
45 find . -type f -name '*~' -print0 | xargs -0 rm -f
46
47 %build
48 %{__make} DFLAGS="%{rpmcflags}" LIBCRYPT=-lcrypt SHADOWDEFS=-DSHADOW_PWD \
49         prefix=%{_prefix} libprefix=%{_prefix} sysconfprefix=
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT
54 chmod go= $RPM_BUILD_ROOT
55
56 install -d $RPM_BUILD_ROOT/{etc/rc.d/{init,rc{0,1,2,3,4,5,6}}.d,lib,sbin}
57 %{__make} prefix=$RPM_BUILD_ROOT%{_prefix} libprefix=$RPM_BUILD_ROOT%{_prefix} \
58         sysconfprefix=$RPM_BUILD_ROOT install
59
60 rm -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so
61 rm -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so.%{dnet_major}
62 mv -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so.%{dnet_version} \
63         $RPM_BUILD_ROOT/lib/libdnet.so.%{dnet_version}
64 ln -sf libdnet.so.%{dnet_version} \
65         $RPM_BUILD_ROOT/lib/libdnet.so.%{dnet_major}
66 ln -sf ../../lib/libdnet.so.%{dnet_major} \
67         $RPM_BUILD_ROOT%{_libdir}/libdnet.so
68
69 mv -f $RPM_BUILD_ROOT%{_sbindir}/startnet $RPM_BUILD_ROOT/sbin/startnet
70
71 touch $RPM_BUILD_ROOT%{_sysconfdir}/decnet.proxy
72
73 install scripts/decnet.sh $RPM_BUILD_ROOT/etc/rc.d/init.d/decnet
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post
79 /sbin/chkconfig --add decnet
80 /sbin/ldconfig
81
82 %postun
83 /sbin/ldconfig
84 if [ "$1" = "0" ]; then
85         /sbin/chkconfig --del decnet
86 fi
87
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc Documentation/* README NEWS dnprogs.lsm
93 %config(noreplace) %{_sysconfdir}/decnet.conf
94 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/decnet.proxy
95 %attr(754,root,root) /etc/rc.d/init.d/decnet
96 %attr(-,root,root) /lib/libdnet.so.%{dnet_major}
97 %attr(755,root,root) /lib/libdnet.so.%{dnet_version}
98 %attr(755,root,root) /sbin/startnet
99 %attr(755,root,root) %{_bindir}/dncopy
100 %attr(755,root,root) %{_bindir}/dndel
101 %attr(755,root,root) %{_bindir}/dndir
102 %attr(755,root,root) %{_bindir}/dnping
103 %attr(-,root,root) %{_bindir}/dnprint
104 %attr(755,root,root) %{_bindir}/dnsubmit
105 %attr(755,root,root) %{_bindir}/dntask
106 %attr(-,root,root) %{_bindir}/dntype
107 %attr(755,root,root) %{_bindir}/phone
108 %attr(755,root,root) %{_bindir}/sethost
109 %{_includedir}/netdnet
110 %{_libdir}/libdnet.a
111 %attr(-,root,root) %{_libdir}/libdnet.so
112 %{_libdir}/libdap.a
113 %attr(-,root,root) %{_libdir}/libdap.so
114 %attr(-,root,root) %{_libdir}/libdap.so.%{dap_major}
115 %attr(755,root,root) %{_libdir}/libdap.so.%{dap_version}
116 %{_mandir}/man1/ctermd.1*
117 %{_mandir}/man1/dncopy.1*
118 %{_mandir}/man1/dndel.1*
119 %{_mandir}/man1/dndir.1*
120 %{_mandir}/man1/dnmirror.1*
121 #%%{_mandir}/man1/dnmount.1*
122 %{_mandir}/man1/dnping.1*
123 %{_mandir}/man1/dnprint.1*
124 %{_mandir}/man1/dnsubmit.1*
125 %{_mandir}/man1/dntask.1*
126 %{_mandir}/man1/dntype.1*
127 %{_mandir}/man1/phone.1*
128 %{_mandir}/man1/sethost.1*
129 %{_mandir}/man1/startnet.1*
130 %{_mandir}/man3/dnet_addr.3*
131 %{_mandir}/man3/dnet_conn.3*
132 %{_mandir}/man3/dnet_htoa.3*
133 %{_mandir}/man3/dnet_ntoa.3*
134 %{_mandir}/man3/getnodeadd.3*
135 %{_mandir}/man3/getnodebyaddr.3*
136 %{_mandir}/man3/getnodebyname.3*
137 %{_mandir}/man3/libdnet.3*
138 %{_mandir}/man3/setnodeent.3*
139 %{_mandir}/man5/decnet.conf.5*
140 %{_mandir}/man5/decnet.proxy.5*
141 %{_mandir}/man8/fal.8*
142 %{_mandir}/man8/phoned.8*
143 %attr(755,root,root) %{_sbindir}/ctermd
144 %attr(755,root,root) %{_sbindir}/dnmirror
145 %attr(755,root,root) %{_sbindir}/fal
146 %attr(755,root,root) %{_sbindir}/phoned
147 %attr(755,root,root) %{_sbindir}/sendvmsmail
148 %attr(755,root,root) %{_sbindir}/vmsmaild
This page took 0.051128 seconds and 2 git commands to generate.