]> git.pld-linux.org Git - packages/dnf.git/commitdiff
- treat uname() and cpuinfo() deps the same way as rpmlib() deps, rel 2 auto/th/dnf-4.12.0-2
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 13 May 2022 10:21:56 +0000 (12:21 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 13 May 2022 10:21:56 +0000 (12:21 +0200)
dnf.spec
uname-cpuinfo-deps.patch [new file with mode: 0644]

index 265cbcc81513c0dfed77d2e936e637000665e684..22d2534b35d22ebbcdd28e7882429ce5416c85e5 100644 (file)
--- a/dnf.spec
+++ b/dnf.spec
@@ -13,7 +13,7 @@ Summary:      Package manager
 Summary(pl.UTF-8):     Zarządca pakietów
 Name:          dnf
 Version:       4.12.0
-Release:       1
+Release:       2
 Group:         Base
 # GPL v2+ with GPL v2 and GPL parts; for a breakdown of the licensing, see PACKAGE-LICENSING
 License:       GPL v2 (parts on GPL v2+ or GPL)
@@ -25,6 +25,7 @@ Source3:      pld-debuginfo.repo
 Source4:       pld-multilib.repo
 Patch0:                install.patch
 Patch1:                repos.d.patch
+Patch2:                uname-cpuinfo-deps.patch
 URL:           https://github.com/rpm-software-management/dnf
 BuildRequires: bash-completion-devel
 BuildRequires: cmake >= 2.4
@@ -115,6 +116,7 @@ Warstwa zgodności z YUM-em dla DNF-a.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 install -d build
diff --git a/uname-cpuinfo-deps.patch b/uname-cpuinfo-deps.patch
new file mode 100644 (file)
index 0000000..f598fbf
--- /dev/null
@@ -0,0 +1,24 @@
+--- dnf-4.12.0/dnf/cli/commands/check.py~      2022-04-27 11:46:45.000000000 +0200
++++ dnf-4.12.0/dnf/cli/commands/check.py       2022-05-13 12:17:21.812109592 +0200
+@@ -80,6 +80,10 @@
+                 for require in set(pkg.regular_requires) | set(set(pkg.requires_pre) - set(pkg.prereq_ignoreinst)):
+                     if str(require).startswith('rpmlib'):
+                         continue
++                    if str(require).startswith('uname('):
++                        continue
++                    if str(require).startswith('cpuinfo('):
++                        continue
+                     if not len(q.filter(provides=[require])):
+                         if str(require).startswith('('):
+                             # rich deps can be only tested by solver
+--- dnf-4.12.0/dnf/cli/commands/repoquery.py~  2022-04-27 11:46:45.000000000 +0200
++++ dnf-4.12.0/dnf/cli/commands/repoquery.py   2022-05-13 12:18:24.088053591 +0200
+@@ -674,6 +674,8 @@
+             usedpkgs = set() if usedpkgs is None or level == -1 else usedpkgs
+             if pkg.name.startswith("rpmlib") or pkg.name.startswith("solvable"):
+                 return
++            if pkg.name.startswith("uname(") or pkg.name.startswith("cpuinfo("):
++                return
+             self.grow_tree(level, pkg, opts)
+             if pkg not in usedpkgs:
+                 usedpkgs.add(pkg)
This page took 0.210135 seconds and 4 git commands to generate.