]> git.pld-linux.org Git - packages/dnf.git/blame - dnf.spec
- release 4 (by relup.sh)
[packages/dnf.git] / dnf.spec
CommitLineData
f637201a
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4#
1abae8cd
JR
5%define hawkey_ver 0.59.0
6%define libcomps_ver 0.1.8
7%define libmodulemd_ver 2.9.3
8%define rpm_ver 4.14.0
9
10Summary: Package manager
11Summary(pl.UTF-8): Zarządca pakietów
feb41732 12Name: dnf
1abae8cd 13Version: 4.6.1
87d06764 14Release: 4
feb41732 15Group: Base
a1a5f7dd
JB
16# GPL v2+ with GPL v2 and GPL parts; for a breakdown of the licensing, see PACKAGE-LICENSING
17License: GPL v2 (parts on GPL v2+ or GPL)
1abae8cd
JR
18Source0: https://github.com/rpm-software-management/dnf/archive/%{version}/%{name}-%{version}.tar.gz
19# Source0-md5: 21880d44905d6aa67ab6bee1e86380b3
20Patch0: install.patch
70e5df64 21URL: https://github.com/rpm-software-management/dnf
5aa69e21 22BuildRequires: bash-completion-devel
a1a5f7dd 23BuildRequires: cmake >= 2.4
cebdb6a6 24BuildRequires: gettext-tools
1abae8cd
JR
25BuildRequires: python3
26BuildRequires: python3-gpg
27BuildRequires: python3-hawkey >= %{hawkey_ver}
28BuildRequires: python3-libcomps >= %{libcomps_ver}
29BuildRequires: python3-libdnf >= %{hawkey_ver}
30BuildRequires: python3-modules
31BuildRequires: python3-nose
32BuildRequires: python3-rpm >= %{rpm_ver}
a1b662bf 33BuildRequires: libmodulemd >= %{libmodulemd_ver}
feb41732 34BuildRequires: rpmbuild(macros) >= 1.647
1abae8cd 35BuildRequires: rpm-pythonprov
feb41732
ER
36BuildRequires: sed >= 4.0
37BuildRequires: sphinx-pdg
38BuildRequires: systemd-devel
39Requires(post,preun,postun): systemd-units >= 38
1abae8cd
JR
40Requires: python3-gpg
41Requires: python3-hawkey >= %{hawkey_ver}
42Requires: python3-libcomps >= %{libcomps_ver}
43Requires: python3-libdnf >= %{hawkey_ver}
44Requires: python3-rpm
feb41732 45Requires: systemd-units >= 0.38
a1b662bf 46Requires: libmodulemd >= %{libmodulemd_ver}
1abae8cd
JR
47Recommends: deltarpm
48Recommends: python3-dbus
49Recommends: python3-unbound
50Recommends: rpm-plugin-systemd-inhibit
feb41732
ER
51BuildArch: noarch
52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54%description
1abae8cd
JR
55Utility that allows users to manage packages on their systems. It
56supports RPMs, modules and comps groups & environments.
feb41732 57
d3326039 58%description -l pl.UTF-8
1abae8cd
JR
59Marzędzie umożliwiające użytkownikom zarządzanie pakietami w systemie.
60
61%package common
62Summary: Common data and configuration files for DNF
63Requires: libreport-filesystem
64
65%description common
66Common data and configuration files for DNF.
d3326039 67
70e5df64
ER
68%package automatic
69Summary: Alternative CLI to "dnf upgrade" suitable for automatic, regular execution
d3326039 70Summary(pl.UTF-8): Alternatywny interfejs do "dnf upgrade" nadający się do automatycznego wywoływania
70e5df64 71Group: Base
70e5df64
ER
72Requires(post): systemd
73Requires(preun): systemd
74Requires(postun): systemd
d3326039 75Requires: %{name} = %{version}-%{release}
70e5df64
ER
76
77%description automatic
78Alternative CLI to "dnf upgrade" suitable for automatic, regular
79execution.
80
d3326039
JB
81%description automatic -l pl.UTF-8
82Alternatywny interfejs linii poleceń do "dnf upgrade", nadający się do
83automatycznego, regularnego wywoływania.
84
a1a5f7dd
JB
85%package -n bash-completion-dnf
86Summary: Bash completion for dnf command
87Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla polecenia dnf
88Group: Applications/Shells
89Requires: %{name} = %{version}-%{release}
90Requires: bash-completion
91
92%description -n bash-completion-dnf
93Bash completion for dnf command.
94
95%description -n bash-completion-dnf -l pl.UTF-8
96Bashowe uzupełnianie parametrów dla polecenia dnf.
97
1abae8cd
JR
98%package -n yum
99Summary: Package manager
100Summary(pl.UTF-8): Zarządca pakietów
a1a5f7dd 101Requires: %{name} = %{version}-%{release}
1abae8cd
JR
102Recommends: sqlite3
103Conflicts: yum < 3.4.3-505
a1a5f7dd 104
1abae8cd
JR
105%description -n yum
106Utility that allows users to manage packages on their systems. It
107supports RPMs, modules and comps groups & environments.
a1a5f7dd 108
1abae8cd
JR
109%description -n yum -l pl.UTF-8
110Marzędzie umożliwiające użytkownikom zarządzanie pakietami w systemie.
a1a5f7dd 111
feb41732 112%prep
1abae8cd 113%setup -q
38fbb761 114%patch0 -p1
feb41732 115
feb41732 116%build
1abae8cd
JR
117install -d build
118cd build
a1a5f7dd 119%cmake .. \
1abae8cd
JR
120 -DPYTHON_DESIRED:FILEPATH=%{__python3} \
121 -DPYTHON_INSTALL_DIR:PATH=%{py3_sitescriptdir} \
122 -DDNF_VERSION=%{version} \
a1a5f7dd 123 -DSYSTEMD_DIR=%{systemdunitdir}
feb41732
ER
124
125%{__make}
126%{__make} doc-man
127
feb41732
ER
128%install
129rm -rf $RPM_BUILD_ROOT
748413d4
JR
130install -d $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/{vars,aliases.d,plugins,modules.d,modules.defaults.d},yum} \
131 -d $RPM_BUILD_ROOT{%{_localstatedir}/log/,%{_var}/cache/dnf/} \
132 -d $RPM_BUILD_ROOT%{py3_sitescriptdir}/dnf-plugins/__pycache__
a1a5f7dd 133
1abae8cd 134%{__make} -C build install \
feb41732
ER
135 DESTDIR=$RPM_BUILD_ROOT
136
1abae8cd 137touch $RPM_BUILD_ROOT%{_localstatedir}/log/%{name}.log
feb41732 138
1abae8cd
JR
139%{__mv} $RPM_BUILD_ROOT%{_bindir}/dnf-3 $RPM_BUILD_ROOT%{_bindir}/dnf
140%{__mv} $RPM_BUILD_ROOT%{_bindir}/dnf-automatic-3 $RPM_BUILD_ROOT%{_bindir}/dnf-automatic
feb41732 141
1abae8cd 142%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{%{name}-strict.conf,aliases.d/zypper.conf}
a1a5f7dd 143
1abae8cd
JR
144# YUM compat layer
145ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/%{name}.conf,yum.conf}
146ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/plugins,yum/pluginconf.d}
147ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/protected.d,yum/protected.d}
148ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/vars,yum/vars}
149ln -s dnf-3 $RPM_BUILD_ROOT%{_bindir}/yum
a1a5f7dd 150
748413d4
JR
151%py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}/dnf
152%py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}/dnf
153
1abae8cd 154%find_lang %{name}
feb41732
ER
155
156%clean
157rm -rf $RPM_BUILD_ROOT
158
159%post
160%systemd_post dnf-makecache.timer
161
162%preun
163%systemd_preun dnf-makecache.timer
164
165%postun
166%systemd_reload
167
70e5df64 168%post automatic
1abae8cd 169%systemd_post dnf-automatic.timer dnf-automatic-download.timer dnf-automatic-install.timer dnf-automatic-notifyonly.timer
70e5df64
ER
170
171%preun automatic
1abae8cd 172%systemd_preun dnf-automatic.timer dnf-automatic-download.timer dnf-automatic-install.timer dnf-automatic-notifyonly.timer
70e5df64
ER
173
174%postun automatic
175%systemd_reload
176
feb41732
ER
177%files -f %{name}.lang
178%defattr(644,root,root,755)
a1a5f7dd 179%doc AUTHORS PACKAGE-LICENSING README.rst
feb41732
ER
180%attr(755,root,root) %{_bindir}/dnf
181%dir %{_sysconfdir}/%{name}
70e5df64
ER
182%dir %{_sysconfdir}/%{name}/plugins
183%dir %{_sysconfdir}/%{name}/protected.d
feb41732 184%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/dnf.conf
70e5df64 185%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/protected.d/dnf.conf
feb41732
ER
186%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/collect_dnf.conf
187%config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
1abae8cd
JR
188%{_mandir}/man5/dnf.conf.5*
189%{_mandir}/man5/dnf-transaction-json.5*
190%{_mandir}/man7/dnf.modularity.7*
feb41732 191%{_mandir}/man8/dnf.8*
1abae8cd 192%{_mandir}/man8/yum2dnf.8*
feb41732
ER
193%{systemdunitdir}/dnf-makecache.service
194%{systemdunitdir}/dnf-makecache.timer
1abae8cd
JR
195%{systemdtmpfilesdir}/dnf.conf
196%{py3_sitescriptdir}/dnf
748413d4 197%{py3_sitescriptdir}/dnf-plugins
1abae8cd 198%exclude %{py3_sitescriptdir}/dnf/automatic
feb41732
ER
199
200%ghost %{_localstatedir}/log/%{name}.log
70e5df64
ER
201
202%files automatic
203%defattr(644,root,root,755)
204%attr(755,root,root) %{_bindir}/dnf-automatic
205%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/automatic.conf
1abae8cd
JR
206%{_mandir}/man8/dnf-automatic.8*
207%{systemdunitdir}/dnf-automatic-download.service
208%{systemdunitdir}/dnf-automatic-download.timer
209%{systemdunitdir}/dnf-automatic-install.service
210%{systemdunitdir}/dnf-automatic-install.timer
211%{systemdunitdir}/dnf-automatic-notifyonly.service
212%{systemdunitdir}/dnf-automatic-notifyonly.timer
70e5df64
ER
213%{systemdunitdir}/dnf-automatic.service
214%{systemdunitdir}/dnf-automatic.timer
1abae8cd 215%{py3_sitescriptdir}/dnf/automatic
a1a5f7dd
JB
216
217%files -n bash-completion-dnf
218%defattr(644,root,root,755)
5aa69e21 219%{bash_compdir}/dnf
a1a5f7dd 220
1abae8cd 221%files -n yum
a1a5f7dd 222%defattr(644,root,root,755)
1abae8cd
JR
223%attr(755,root,root) %{_bindir}/yum
224%{_sysconfdir}/yum.conf
3524bf68 225%dir %{_sysconfdir}/yum
1abae8cd
JR
226%{_sysconfdir}/yum/pluginconf.d
227%{_sysconfdir}/yum/protected.d
228%{_sysconfdir}/yum/vars
229%{_mandir}/man8/yum.8*
230%{_mandir}/man5/yum.conf.5.*
231%{_mandir}/man8/yum-shell.8*
232%{_mandir}/man1/yum-aliases.1*
233%config(noreplace) %{_sysconfdir}/%{name}/protected.d/yum.conf
This page took 0.121402 seconds and 4 git commands to generate.