]> git.pld-linux.org Git - packages/dml.git/blob - dml.spec
ca81e80ddd39eba30efb6d3bba89013ebd81109c
[packages/dml.git] / dml.spec
1 # _without_embed - don't build uClibc version
2 Summary:        Tool for displaying dialogs from shell
3 Summary(pl):    Narzêdzie do wy¶wietlania okien dialogowych z shella
4 Name:           dml
5 Version:        0.0.15
6 Release:        1
7 License:        GPL
8 Group:          Applications/Terminal
9 Source0:        ftp://ftp.pld.org.pl/people/malekith/%{name}-%{version}.tar.gz
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 %if %{!?_without_embed:1}%{?_without_embed:0}
13 BuildRequires:  slang-devel-embed
14 BuildRequires:  uClibc-devel
15 BuildRequires:  uClibc-static
16 %endif
17 BuildRequires:  slang-devel
18 BuildRequires:  gettext-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20 Requires:       slang
21
22 %define embed_path      /usr/lib/embed
23 %define embed_cc        %{_arch}-uclibc-cc
24 %define embed_cflags    %{rpmcflags} -Os
25 %define uclibc_prefix   /usr/%{_arch}-linux-uclibc
26
27 %description
28 Tool for displaying dialogs from shell.
29
30 %description -l pl
31 Narzêdzie do wy¶wietlania okien dialogowych z shella.
32
33 %package embed
34 Summary:        Tool for displaying dialogs from shell - BOOT
35 Summary(pl):    Narzêdzie do wy¶wietlania okien dialogowych z shella -BOOT
36 Group:          Applications/Terminal
37
38 %description embed
39 Tool for displaying dialogs from shell. Bootdisk version.
40
41 %description embed -l pl
42 Narzêdzie do wy¶wietlania okien dialogowych z shella. Wersja na
43 bootkietkê.
44
45 %prep
46 %setup -q
47
48 %build
49 autoheader
50 aclocal
51 autoconf
52 automake -a -c
53
54 %if %{!?_without_embed:1}%{?_without_embed:0}
55 %configure --disable-nls
56 %{__make} -C src \
57         CC=%{embed_cc} \
58         CFLAGS="%{embed_cflags}" \
59         LDADD="-lslang"
60 mv -f src/dml dml-shared
61 %{__make} -C src \
62         CC=%{embed_cc} \
63         CFLAGS="%{embed_cflags}" \
64         LDFLAGS="-static" \
65         LDADD="-lslang"
66 mv -f src/dml dml-static
67 %{__make} distclean
68 %endif
69
70 %configure
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %if %{!?_without_embed:1}%{?_without_embed:0}
79 install -d $RPM_BUILD_ROOT%{embed_path}/{shared,static}
80 install dml-shared $RPM_BUILD_ROOT%{embed_path}/shared/dml
81 install dml-static $RPM_BUILD_ROOT%{embed_path}/static/dml
82 %endif
83
84 gzip -9nf AUTHORS TODO NEWS README ChangeLog
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc *.gz
92 %attr(755,root,root) %{_bindir}/*
93 %{_mandir}/man1/*
94
95 %if %{!?_without_embed:1}%{?_without_embed:0}
96 %files embed
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{embed_path}/*/dml
99 %endif
This page took 0.05271 seconds and 2 git commands to generate.