]> git.pld-linux.org Git - packages/dml.git/blob - dml.spec
- %desc
[packages/dml.git] / dml.spec
1 # _without_embed - don't build uClibc version
2 Summary:        Tool for displaying dialogs from shell
3 Summary(pl):    Narzêdzie do wy¶wietlania okien dialogowych z shella
4 Name:           dml
5 Version:        0.0.14
6 Release:        3
7 License:        GPL
8 Group:          Applications/Terminal
9 Group(de):      Applikationen/Terminal
10 Group(pl):      Aplikacje/Terminal
11 Source0:        ftp://ftp.pld.org.pl/people/malekith/%{name}-%{version}.tar.gz
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 %if %{!?_without_embed:1}%{?_without_embed:0}
15 BuildRequires:  slang-devel-embed
16 BuildRequires:  uClibc-devel
17 BuildRequires:  uClibc-static
18 %endif
19 BuildRequires:  slang-devel
20 BuildRequires:  gettext-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22 Requires:       slang
23
24 %define embed_path      /usr/lib/embed
25 %define embed_cc        %{_arch}-uclibc-cc
26 %define embed_cflags    %{rpmcflags} -Os
27 %define uclibc_prefix   /usr/%{_arch}-linux-uclibc
28
29 %description
30 Tool for displaying dialogs from shell.
31
32 %description -l pl
33 Narzêdzie do wy¶wietlania okien dialogowych z shella.
34
35 %package embed
36 Summary:        Tool for displaying dialogs from shell - BOOT
37 Summary(pl):    Narzêdzie do wy¶wietlania okien dialogowych z shella -BOOT
38 Group:          Applications/Terminal
39 Group(de):      Applikationen/Terminal
40 Group(pl):      Aplikacje/Terminal
41
42 %description embed
43 Tool for displaying dialogs from shell. Bootdisk version.
44
45 %description embed -l pl
46 Narzêdzie do wy¶wietlania okien dialogowych z shella. Wersja na
47 bootkietkê.
48
49 %prep
50 %setup -q
51
52 %build
53 autoheader
54 aclocal
55 autoconf
56 automake -a -c
57
58 %if %{!?_without_embed:1}%{?_without_embed:0}
59 %configure --disable-nls
60 %{__make} -C src \
61         CC=%{embed_cc} \
62         CFLAGS="%{embed_cflags}" \
63         LDADD="-lslang"
64 mv -f src/dml dml-shared
65 %{__make} -C src \
66         CC=%{embed_cc} \
67         CFLAGS="%{embed_cflags}" \
68         LDFLAGS="-static" \
69         LDADD="-lslang"
70 mv -f src/dml dml-static
71 %{__make} distclean
72 %endif
73
74 %configure
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %if %{!?_without_embed:1}%{?_without_embed:0}
83 install -d $RPM_BUILD_ROOT%{embed_path}/{shared,static}
84 install dml-shared $RPM_BUILD_ROOT%{embed_path}/shared/dml
85 install dml-static $RPM_BUILD_ROOT%{embed_path}/static/dml
86 %endif
87
88 gzip -9nf AUTHORS TODO NEWS README ChangeLog
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc *.gz
96 %attr(755,root,root) %{_bindir}/*
97 %{_mandir}/man1/*
98
99 %if %{!?_without_embed:1}%{?_without_embed:0}
100 %files embed
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{embed_path}/*/dml
103 %endif
This page took 0.033816 seconds and 3 git commands to generate.