]> git.pld-linux.org Git - packages/dml.git/blob - dml.spec
- removed -s from install -s, stripping is done by rpm
[packages/dml.git] / dml.spec
1 Summary:        Tool for displaying dialogs from shell
2 Summary(pl):    Narzêdzie do wy¶wietlania okien dialogowych z shella
3 Name:           dml
4 Version:        0.0.12
5 Release:        2
6 License:        GPL
7 Group:          Applications/Terminal
8 Group(de):      Applikationen/Terminal
9 Group(pl):      Aplikacje/Terminal
10 Source0:        ftp://ftp.pld.org.pl/people/malekith/%{name}-%{version}.tar.gz
11 Patch0:         %{name}-no_new_am.patch
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 %if %{?BOOT:1}%{!?BOOT:0}
15 BuildRequires:  slang-devel-BOOT
16 BuildRequires:  uClibc-devel-BOOT
17 %endif
18 BuildRequires:  slang-devel
19 BuildRequires:  gettext-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21 Requires:       slang
22
23 %description
24 Tool for displaying dialogs from shell.
25
26 %description -l pl
27 Narzêdzie do wy¶wietlania okien dialogowych z shella.
28
29 %package BOOT
30 Summary:        Tool for displaying dialogs from shell - BOOT
31 Summary(pl):    Narzêdzie do wy¶wietlania okien dialogowych z shella -BOOT
32 Group:          Applications/Terminal
33 Group(de):      Applikationen/Terminal
34 Group(pl):      Aplikacje/Terminal
35
36 %description BOOT
37 Tool for displaying dialogs from shell. Bootdisk version.
38
39 %prep
40 %setup -q
41 %patch -p1
42
43 %build
44 autoheader
45 aclocal
46 autoconf 
47 automake -a -c
48
49 %if %{?BOOT:1}%{!?BOOT:0}
50 %configure --disable-nls
51 %{__make} -C src \
52         CFLAGS="-m386 -I%{_libdir}/bootdisk%{_includedir}" \
53         LDFLAGS="-nostdlib -static -s" \
54         LDADD=" %{_libdir}/bootdisk%{_libdir}/libslang.a \
55                 %{_libdir}/bootdisk%{_libdir}/crt0.o \
56                 %{_libdir}/bootdisk%{_libdir}/libc.a -lgcc "
57 mv -f src/dml dml-BOOT
58
59 %{__make} distclean
60 %endif
61
62 %configure
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT 
69
70 %if %{?BOOT:1}%{!?BOOT:0}
71 install -d $RPM_BUILD_ROOT/usr/lib/bootdisk/bin
72 install dml-BOOT $RPM_BUILD_ROOT/usr/lib/bootdisk/bin/dml
73 %endif
74
75 gzip -9nf AUTHORS TODO NEWS README ChangeLog
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc *.gz
83 %attr(755,root,root) %{_bindir}/*
84 %{_mandir}/man1/*
85
86 %if %{?BOOT:1}%{!?BOOT:0}
87 %files BOOT
88 %defattr(644,root,root,755)
89 %attr(755,root,root) /usr/lib/bootdisk/bin/dml
90 %endif
This page took 0.061653 seconds and 3 git commands to generate.