]> git.pld-linux.org Git - packages/dml.git/blob - dml.spec
- linked -BOOT against uClibc
[packages/dml.git] / dml.spec
1 Summary:        Tool for displaying dialogs from shell
2 Summary(pl):    Narzêdzie do wy¶wietlania okien dialogowych z shella
3 Name:           dml
4 Version:        0.0.5
5 Release:        1
6 License:        GPL
7 Group:          Applications/Terminal
8 Group(de):      Applikationen/Terminal
9 Group(pl):      Aplikacje/Terminal
10 Source0:        ftp://ftp.pld.org.pl/people/malekith/%{name}-%{version}.tar.gz
11 BuildRequires:  slang-devel-BOOT
12 #BuildRequires: gettext-devel
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Tool for displaying dialogs from shell.
17
18 %description -l pl
19 Narzêdzie do wy¶wietlania okien dialogowych z shella.
20
21 %package BOOT
22 Summary:        Tool for displaying dialogs from shell - BOOT
23 Summary(pl):    Narzêdzie do wy¶wietlania okien dialogowych z shella -BOOT
24 Group:          Applications/Terminal
25 Group(de):      Applikationen/Terminal
26 Group(pl):      Aplikacje/Terminal
27
28 %description BOOT
29 Tool for displaying dialogs from shell. Bootdisk version.
30
31 %prep
32 %setup -q
33
34 %build
35 autoheader
36 automake --add-missing
37 autoconf 
38
39 %configure --disable-nls
40
41 # uClibc does not have two functions referenced in libslang
42 # they are not critical for bootdisk, let's create some fake ones
43 cat <<EOF >src/setsf.c
44 int setfsuid (void *foo) { return 0; }
45 int setfsgid (void *foo) { return 0; }
46 EOF
47 ( cd src; gcc -c setsf.c; )
48
49 %{__make} -C src \
50         CFLAGS="-I%{_libdir}/bootdisk%{_includedir} " \
51         LDFLAGS="-nostdlib -static -s" \
52         LDADD="setsf.o  \
53                 %{_libdir}/bootdisk%{_libdir}/libslang.a \
54                 %{_libdir}/bootdisk%{_libdir}/crt0.o \
55                 %{_libdir}/bootdisk%{_libdir}/libc.a -lgcc "
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT 
61 install -d -m 755 $RPM_BUILD_ROOT/usr/lib/bootdisk/bin
62 install -m 755 src/dml $RPM_BUILD_ROOT/usr/lib/bootdisk/bin/dml
63
64 #gzip -9nf AUTHORS TODO ChangeLog
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %attr(755,root,root) %{_bindir}/*
72 %{_mandir}/man1/*
73
74 %files BOOT
75 %defattr(644,root,root,755)
76 %attr(755,root,root) /usr/lib/bootdisk/bin/dml
This page took 0.412857 seconds and 3 git commands to generate.