]> git.pld-linux.org Git - packages/dmalloc.git/commitdiff
- compile files for sgared libraries with -fPIC (patch from rawhide).
authorkloczek <kloczek@pld-linux.org>
Wed, 10 Apr 2002 19:40:12 +0000 (19:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    dmalloc-pic.patch -> 1.1

dmalloc-pic.patch [new file with mode: 0644]

diff --git a/dmalloc-pic.patch b/dmalloc-pic.patch
new file mode 100644 (file)
index 0000000..c46e983
--- /dev/null
@@ -0,0 +1,41 @@
+--- dmalloc-4.8.1/Makefile.in.foo      Mon Dec 11 17:55:43 2000
++++ dmalloc-4.8.1/Makefile.in  Mon Dec 11 17:55:20 2000
+@@ -312,17 +312,17 @@
+ # special _th versions of objects with the LOCK_THREADS variable defined to 1
+ chunk_th.o : $(srcdir)/chunk.c
+       rm -f $@
+-      $(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) $(INCS) -DLOCK_THREADS=1 \
++      $(CC) $(CFLAGS) -fPIC $(CPPFLAGS) $(DEFS) $(INCS) -DLOCK_THREADS=1 \
+               -c $(srcdir)/chunk.c -o ./$@
+ error_th.o : $(srcdir)/error.c
+       rm -f $@
+-      $(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) $(INCS) -DLOCK_THREADS=1 \
++      $(CC) $(CFLAGS) -fPIC $(CPPFLAGS) $(DEFS) $(INCS) -DLOCK_THREADS=1 \
+               -c $(srcdir)/error.c -o ./$@
+ malloc_th.o : $(srcdir)/malloc.c
+       rm -f $@
+-      $(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) $(INCS) -DLOCK_THREADS=1 \
++      $(CC) $(CFLAGS) -fPIC $(CPPFLAGS) $(DEFS) $(INCS) -DLOCK_THREADS=1 \
+               -c $(srcdir)/malloc.c -o ./$@
+ tests : $(TEST)
+@@ -348,7 +348,7 @@
+ .c.o :
+       rm -f $@
+-      $(CC) $(CFLAGS) $(CPPFLAGS) $(DEFS) $(INCS) -c $< -o ./$@
++      $(CC) $(CFLAGS) -fPIC $(CPPFLAGS) $(DEFS) $(INCS) -c $< -o ./$@
+ #
+ # .cc.o auto-target doesn't work on some systems. 
+@@ -356,7 +356,7 @@
+ #
+ dmallocc.o : $(srcdir)/dmallocc.cc
+       rm -f $@
+-      $(CXX) $(CFLAGS) $(CPPFLAGS) $(DEFS) $(INCS) -c $(srcdir)/dmallocc.cc \
++      $(CXX) $(CFLAGS) -fPIC $(CPPFLAGS) $(DEFS) $(INCS) -c $(srcdir)/dmallocc.cc \
+               -o ./$@
+ .texi.info :
This page took 0.736614 seconds and 4 git commands to generate.