]> git.pld-linux.org Git - packages/dmalloc.git/blob - dmalloc.spec
nicer %install
[packages/dmalloc.git] / dmalloc.spec
1 Summary:        A library for controlling and tracing dynamic memory allocations
2 Summary(pl):    Biblioteka do kontroli i ¶ledzenia dynamicznej alokacji pamiêcie
3 Name:           dmalloc
4 Version:        4.8.2
5 Release:        1
6 License:        LGPL
7 Group:          Development/Debuggers
8 Group(de):      Entwicklung/Debugger
9 Group(pl):      Programowanie/Odpluskwiacze
10 Source0:        http://download.sourceforge.net/dmalloc/%{name}-%{version}.tgz
11 URL:            http://dmalloc.com/
12 BuildRequires:  texinfo
13 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 The debug memory allocation or "dmalloc" library has been designed as
17 a drop in replacement for the system's `malloc', `realloc', `calloc',
18 `free' and other memory management routines while providing powerful
19 debugging facilities configurable at runtime. These facilities include
20 such things as memory-leak tracking, fence-post write detection,
21 file/line number reporting, and general logging of statistics. It also
22 provides support for the debugging of threaded programs.
23
24 %description -l pl
25 Biblioteka do odpluskwiania programów zastêpuje systemowe funkcje
26 takie jak `malloc', `realloc', `calloc', `free' i inne funkcje do
27 zarz±dzania pamiêci±. Mo¿liwo¶ci to wykrywanie wycieków pamiêci,
28 wykrywanie zapisów poza zaalokowanym obszarem, informowanie o
29 pliku/numerze linii, w której wystêpuje problem oraz generalne
30 statystyki. Biblioteka umo¿liwia odpluskwianie programów w±tkowych.
31
32
33 %prep
34 %setup -q
35
36 %build
37 %configure \
38         --enable-cxx \
39         --enable-threads \
40         --enable-shlib
41         
42 %{__make} dmalloc_t all light dmalloc.info
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{_infodir}
47
48 %{makeinstall} \
49         installsl installcxx installth installinfo \
50         shlibdir=$RPM_BUILD_ROOT%{_libdir} \
51         incdir=$RPM_BUILD_ROOT%{_includedir}
52
53 gzip -9nf README NEWS ChangeLog
54
55 %post
56 /sbin/ldconfig
57 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
58
59 %postun
60 /sbin/ldconfig
61 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc *.gz
69 %attr(755,root,root) %{_bindir}/*
70 %{_includedir}/*
71 %{_libdir}/*
72 %{_infodir}/*
This page took 0.053745 seconds and 3 git commands to generate.