]> git.pld-linux.org Git - packages/dmalloc.git/blob - dmalloc.spec
81dfac4d5ac4d4b8ae63627382e907bbf270c2fb
[packages/dmalloc.git] / dmalloc.spec
1 Summary:        A library for controlling and tracing dynamic memory allocations
2 Summary(pl):    Biblioteka do kontroli i ¶ledzenia dynamicznej alokacji pamiêcie
3 Name:           dmalloc
4 Version:        5.3.0
5 Release:        1
6 License:        LGPL
7 Group:          Development/Debuggers
8 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tgz
9 # Source0-md5:  d11a4a5d5bd258ef7461babec9e177fa
10 Source1:        %{name}.1
11 Patch0:         %{name}-info.patch
12 Patch1:         %{name}-pic.patch
13 Patch2:         %{name}-4.8.2-pld_man.patch
14 URL:            http://dmalloc.com/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  texinfo
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 The debug memory allocation or "dmalloc" library has been designed as
22 a drop in replacement for the system's `malloc', `realloc', `calloc',
23 `free' and other memory management routines while providing powerful
24 debugging facilities configurable at runtime. These facilities include
25 such things as memory-leak tracking, fence-post write detection,
26 file/line number reporting, and general logging of statistics. It also
27 provides support for the debugging of threaded programs.
28
29 %description -l pl
30 Biblioteka do odpluskwiania programów zastêpuje systemowe funkcje
31 takie jak `malloc', `realloc', `calloc', `free' i inne funkcje do
32 zarz±dzania pamiêci±. Mo¿liwo¶ci to wykrywanie wycieków pamiêci,
33 wykrywanie zapisów poza zaalokowanym obszarem, informowanie o
34 pliku/numerze linii, w której wystêpuje problem oraz generalne
35 statystyki. Biblioteka umo¿liwia odpluskwianie programów w±tkowych.
36
37 %package static
38 Summary:        Static dmalloc libraries
39 Summary(pl):    Biblioteki statyczne dmalloc
40 Group:          Development/Debuggers
41 Requires:       %{name} = %{version}
42
43 %description static
44 Static dmalloc libraries.
45
46 %description static -l pl
47 Biblioteki statyczne dmalloc.
48
49 %prep
50 %setup -q
51 install %{SOURCE1} .
52 cd docs
53 %patch0 -p1
54 cd ..
55 %patch1 -p1
56 %patch2 -p0
57
58 %build
59 %{__aclocal}
60 %{__autoconf}
61 %configure \
62         --enable-cxx \
63         --enable-threads \
64         --enable-shlib
65
66 %{__make}
67 %{__make} docs/%{name}.info
68 ln -s docs/%{name}.info %{name}.info
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1}
73
74 %{makeinstall} \
75         installsl installcxx installth installinfo \
76         shlibdir=$RPM_BUILD_ROOT%{_libdir} \
77         incdir=$RPM_BUILD_ROOT%{_includedir}
78
79 install dmalloc.1 $RPM_BUILD_ROOT%{_mandir}/man1
80
81 %post
82 /sbin/ldconfig
83 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
84
85 %postun
86 /sbin/ldconfig
87 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc README NEWS ChangeLog*
95 %attr(755,root,root) %{_bindir}/*
96 %{_includedir}/*
97 %attr(755,root,root) %{_libdir}/lib*.so
98 %{_mandir}/man1/*
99 %{_infodir}/*
100
101 %files static
102 %defattr(644,root,root,755)
103 %{_libdir}/lib*.a
This page took 0.088886 seconds and 2 git commands to generate.