]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- rel 3
[packages/distcc.git] / distcc.spec
1 Summary:        Program to distribute compilation of C or C++
2 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
3 Name:           distcc
4 Group:          Development/Languages
5 Version:        2.0.1
6 Release:        3
7 License:        GPL
8 URL:            http://distcc.samba.org
9 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
10 Source1:        %{name}.inetd
11 Source2:        %{name}.sh
12 Source3:        %{name}.csh
13 Patch0:         %{name}-user.patch
14 Patch1:         %{name}-hostfile.patch
15 Patch2:         %{name}-hostopt.patch
16 Requires:       gcc
17 Requires:       gcc-c++
18 Requires:       inetdaemon
19 BuildRequires:  popt-devel
20 Prereq:         /sbin/chkconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 distcc is a program to distribute compilation of C or C++ code across
25 several machines on a network. distcc should always generate the same
26 results as a local compile, is simple to install and use, and is often
27 two or more times faster than a local compile.
28
29 %description -l pl
30 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
31 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
32 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
33 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
34
35 %prep
36 %setup -q
37
38 %patch -p1
39 %patch1 -p1
40 %patch2 -p0
41
42 %build
43 %configure
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd \
49            $RPM_BUILD_ROOT/etc/profile.d
50
51 %{makeinstall}
52 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
53 install %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT/etc/profile.d
54
55 %post
56 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
57 if [ -f /var/lock/subsys/rc-inetd ]; then
58         /etc/rc.d/init.d/rc-inetd reload 1>&2
59 else
60         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
61 fi
62
63 %postun
64 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
65 if [ -f /var/lock/subsys/rc-inetd ]; then
66         /etc/rc.d/init.d/rc-inetd reload
67 fi
68
69 %clean
70 rm -rf ${RPM_BUILD_ROOT}
71
72 %files
73 %defattr(644,root,root,755)
74 %doc AUTHORS NEWS README linuxdoc/html/*
75 %attr(755,root,root) %{_bindir}/*
76 %attr(644,root,root) %{_mandir}/man?/*
77 %attr(640,root,root) /etc/sysconfig/rc-inetd/distccd
78 %attr(644,root,root) /etc/profile.d/*sh
This page took 0.107231 seconds and 3 git commands to generate.