]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- dropped (by misi3k)
[packages/distcc.git] / distcc.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome   # build without gnome(monitor) support
4 #
5 Summary:        Program to distribute compilation of C or C++
6 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
7 Name:           distcc
8 Group:          Development/Languages
9 Version:        2.17.1
10 Release:        0.1
11 License:        GPL
12 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
13 # Source0-md5:  54e72f430ec44913b3fad2a0e7abd163
14 Source1:        %{name}.inetd
15 Source2:        %{name}.init
16 Source3:        %{name}.sh
17 Source4:        %{name}.csh
18 Source5:        %{name}.config
19 Source6:        %{name}.logrotate
20 Patch0:         %{name}-user.patch
21 URL:            http://distcc.samba.org/
22 BuildRequires:  autoconf >= 2.53
23 BuildRequires:  automake
24 %{?with_gnome:BuildRequires:    libgnomeui-devel >= 2.0}
25 BuildRequires:  pkgconfig
26 BuildRequires:  popt-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 distcc is a program to distribute compilation of C or C++ code across
31 several machines on a network. distcc should always generate the same
32 results as a local compile, is simple to install and use, and is often
33 two or more times faster than a local compile.
34
35 %description -l pl
36 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
37 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
38 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
39 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
40
41 %package common
42 Summary:        Common files for inetd and standalone versions of distcc
43 Summary(pl):    Pliki wspólne dla wersji inetd i standalone distcc
44 Group:          Daemons
45 Requires:       gcc
46 Requires:       gcc-c++
47 Obsoletes:      distcc < 2.1-2
48
49 %description common
50 distcc is a program to distribute compilation of C or C++ code across
51 several machines on a network. distcc should always generate the same
52 results as a local compile, is simple to install and use, and is often
53 two or more times faster than a local compile.
54
55 %description common -l pl
56 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
57 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
58 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
59 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
60
61 %package inetd
62 Summary:        inetd configs for distcc
63 Summary(pl):    Pliki konfiguracyjne do u¿ycia distcc poprzez inetd
64 Group:          Daemons
65 PreReq:         %{name}-common = %{version}-%{release}
66 PreReq:         rc-inetd
67 Obsoletes:      distcc < 2.1-2
68
69 %description inetd
70 distcc configs for running from inetd.
71
72 %description inetd -l pl
73 Pliki konfiguracyjna distcc do startowania demona poprzez inetd.
74
75 %package standalone
76 Summary:        Standalone daemon configs for distcc
77 Summary(pl):    Pliki konfiguracyjne do startowania distcc w trybie standalone
78 Group:          Daemons
79 PreReq:         %{name}-common = %{version}-%{release}
80 PreReq:         rc-scripts
81 Requires(post,preun):   /sbin/chkconfig
82 Obsoletes:      distcc < 2.1-2
83
84 %description standalone
85 distcc configs for running as a standalone daemon.
86
87 %description standalone -l pl
88 Pliki konfiguracyjne distcc do startowania demona w trybie
89 standalone.
90
91 %package monitor
92 Summary:        Monitor for distcc
93 Summary(pl):    Monitor dla distcc
94 Group:          Applications
95
96 %description monitor
97 Monitor for distcc.
98
99 %description monitor -l pl
100 Monitor dla distcc.
101
102 %package monitor-gnome
103 Summary:        gtk monitor for distcc
104 Summary(pl):    Monitor gtk dla distcc
105 Group:          X11/Applications
106
107 %description monitor-gnome
108 gtk monitor for distcc.
109
110 %description monitor-gnome -l pl
111 Monitor gtk dla distcc.
112
113 %prep
114 %setup -q
115 %patch0 -p1
116
117 sed -i -e 's#PKGDATADIR#"%{_pixmapsdir}"#g' src/mon-gnome.c
118
119 %build
120 cp -f /usr/share/automake/config.* .
121 %{__autoconf}
122 %{__autoheader}
123 %configure \
124         --enable-rfc2553 \
125         %{?with_gnome:--with-gnome} 
126
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d,profile.d,logrotate.d} \
132         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_var}/log}
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
138 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/distcc
139 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
140 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/distccd
141 install %{SOURCE6} $RPM_BUILD_ROOT/etc/logrotate.d/distccd
142
143 %if %{with gnome}
144 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/distccmon-gnome.desktop \
145         $RPM_BUILD_ROOT%{_desktopdir}
146 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/distccmon-gnome-icon.png \
147         $RPM_BUILD_ROOT%{_pixmapsdir}
148 %endif
149
150 touch $RPM_BUILD_ROOT%{_var}/log/distcc
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post inetd
156 if [ -f /var/lock/subsys/rc-inetd ]; then
157         /etc/rc.d/init.d/rc-inetd reload 1>&2
158 else
159         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
160 fi
161
162 %postun inetd
163 if [ -f /var/lock/subsys/rc-inetd ]; then
164         /etc/rc.d/init.d/rc-inetd reload
165 fi
166
167 %post standalone
168 /sbin/chkconfig --add distcc
169 if [ -f /var/lock/subsys/distccd ]; then
170         /etc/rc.d/init.d/distcc restart 1>&2
171 else
172         echo "Run \"/etc/rc.d/init.d/distcc start\" to start distcc daemon."
173 fi
174
175 %preun standalone
176 if [ "$1" = "0" ]; then
177         if [ -f /var/lock/subsys/distccd ]; then
178                 /etc/rc.d/init.d/distcc stop 1>&2
179         fi
180         /sbin/chkconfig --del distcc
181 fi
182
183 %files
184 %defattr(644,root,root,755)
185 %doc AUTHORS NEWS README *.txt
186 %attr(755,root,root) %{_bindir}/%{name}
187 %{_mandir}/man?/%{name}.*
188 %attr(755,root,root) /etc/profile.d/*sh
189
190 %files common
191 %defattr(644,root,root,755)
192 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/distccd
193 %attr(640,root,root) /etc/logrotate.d/distccd
194 %attr(755,root,root) %{_bindir}/%{name}d
195 %{_mandir}/man?/%{name}d.*
196 %attr(640,nobody,root) %ghost %{_var}/log/distcc
197
198 %files inetd
199 %defattr(644,root,root,755)
200 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rc-inetd/distccd
201
202 %files standalone
203 %defattr(644,root,root,755)
204 %attr(754,root,root) /etc/rc.d/init.d/distcc
205
206 %files monitor
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_bindir}/distccmon-text
209 %{_mandir}/man1/distccmon-text.*
210
211 %if %{with gnome}
212 %files monitor-gnome
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_bindir}/distccmon-gnome
215 %{_desktopdir}/*.desktop
216 %{_pixmapsdir}/*.png
217 %endif
This page took 0.034787 seconds and 3 git commands to generate.