]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
c59b78a186ffbbe83803ac39719e0d1f29c6d10a
[packages/distcc.git] / distcc.spec
1 Summary:        Program to distribute compilation of C or C++
2 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
3 Name:           distcc
4 Group:          Development/Languages
5 Version:        1.1
6 Release:        1
7 License:        GPL
8 URL:            http://distcc.samba.org
9 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
10 Source1:        %{name}.inetd
11 Requires:       gcc
12 Requires:       gcc-c++
13 Requires:       inetdaemon
14 BuildRequires:  popt-devel
15 Prereq:         /sbin/chkconfig
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 distcc is a program to distribute compilation of C or C++ code across
20 several machines on a network. distcc should always generate the same
21 results as a local compile, is simple to install and use, and is often
22 two or more times faster than a local compile.
23
24 %description -l pl
25 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
26 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
27 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
28 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
29
30 %prep
31 %setup -q
32
33 %build
34 %configure
35 %{__make}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd
40
41 %{makeinstall}
42 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
43
44 %post
45 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
46 if [ -f /var/lock/subsys/rc-inetd ]; then
47         /etc/rc.d/init.d/rc-inetd reload 1>&2
48 else
49         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
50 fi
51
52 %postun
53 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
54 if [ -f /var/lock/subsys/rc-inetd ]; then
55         /etc/rc.d/init.d/rc-inetd reload
56 fi
57
58 %clean
59 rm -rf ${RPM_BUILD_ROOT}
60
61 %files
62 %defattr(644,root,root,755)
63 %doc AUTHORS NEWS OLDNEWS README
64 %attr(755,root,root) %{_bindir}/*
65 %attr(644,root,root) %{_mandir}/man?/*
66 #%attr(644,root,root) %{_defaultdocdir}/*
67 %attr(640,root,root) /etc/sysconfig/rc-inetd/distccd
68 %{_infodir}/distcc*
This page took 0.160741 seconds and 2 git commands to generate.