]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
61eb2cad9ea877212034111fcad6ce695f892142
[packages/distcc.git] / distcc.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome   # build without gnome(monitor) support
4
5 Summary:        Program to distribute compilation of C or C++
6 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
7 Name:           distcc
8 Group:          Development/Languages
9 Version:        2.11
10 Release:        2
11 License:        GPL
12 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
13 # Source0-md5:  f3458779c13255d88ee89ea7ccddda29
14 Source1:        %{name}.inetd
15 Source2:        %{name}.init
16 Source3:        %{name}.sh
17 Source4:        %{name}.csh
18 Source5:        %{name}.config
19 Source6:        %{name}.logrotate
20 Patch0:         %{name}-user.patch
21 URL:            http://distcc.samba.org/
22 %{?with_gtk:BuildRequires:      libgnome-devel >= 2.0}
23 %{?with_gtk:BuildRequires:      pkg-config}
24 BuildRequires:  pkgconfig
25 BuildRequires:  popt-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _vardir         /var
29
30 %description
31 distcc is a program to distribute compilation of C or C++ code across
32 several machines on a network. distcc should always generate the same
33 results as a local compile, is simple to install and use, and is often
34 two or more times faster than a local compile.
35
36 %description -l pl
37 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
38 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
39 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
40 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
41
42 %package common
43 Summary:        Common files for inetd and standalone versions of distcc
44 Summary(pl):    Pliki wspólne dla wersji inetd i standalone distcc
45 Group:          Daemons
46 Requires:       gcc
47 Requires:       gcc-c++
48 Obsoletes:      %{name} < %{name}-2.1-2
49
50 %description common
51 distcc is a program to distribute compilation of C or C++ code across
52 several machines on a network. distcc should always generate the same
53 results as a local compile, is simple to install and use, and is often
54 two or more times faster than a local compile.
55
56 %description common -l pl
57 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
58 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
59 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
60 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
61
62
63 %package inetd
64 Summary:        inetd configs for distcc
65 Summary(pl):    Pliki konfiguracyjne do u¿ycia distcc poprzez inetd
66 Group:          Daemons
67 PreReq:         %{name}-common = %{version}
68 PreReq:         rc-inetd
69 Obsoletes:      %{name} < %{name}-2.1-2
70
71 %description inetd
72 distcc configs for running from inetd.
73
74 %description inetd -l pl
75 Pliki konfiguracyjna distcc do startowania demona poprzez inetd.
76
77 %package standalone
78 Summary:        Standalone daemon configs for distcc
79 Summary(pl):    Pliki konfiguracyjne do startowania distcc w trybie standalone
80 Group:          Daemons
81 PreReq:         %{name}-common = %{version}
82 PreReq:         rc-scripts
83 Requires(post,preun):   /sbin/chkconfig
84 Obsoletes:      %{name} < %{name}-2.1-2
85
86 %description standalone
87 distcc configs for running as a standalone daemon.
88
89 %description standalone -l pl
90 Pliki konfiguracyjne distcc do startowania demona w trybie
91 standalone.
92
93 %package monitor
94 Summary:        Monitor for distcc
95 Summary(pl):    Monitor dla distcc
96 Group:          Applications
97
98 %description monitor
99 Monitor for distcc.
100
101 %description monitor -l pl
102 Monitor dla distcc.
103
104 %package monitor-gnome
105 Summary:        gtk monitor for distcc
106 Summary(pl):    Monitor gtk dla distcc
107 Group:          X11/Applications
108
109 %description monitor-gnome
110 gtk monitor for distcc.
111
112 %description monitor-gnome -l pl
113 Monitor gtk dla distcc.
114
115 %prep
116 %setup -q
117 %patch -p1
118
119 %build
120 %{__autoconf}
121 %{__autoheader}
122 %configure \
123         %{?with_gnome:--with-gnome}
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d,profile.d,logrotate.d} \
130         $RPM_BUILD_ROOT%{_applnkdir}/Network/Misc $RPM_BUILD_ROOT%{_pixmapsdir} \
131         $RPM_BUILD_ROOT%{_vardir}/log
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
137 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/distcc
138 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
139 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/distccd
140 install %{SOURCE6} $RPM_BUILD_ROOT/etc/logrotate.d/distccd
141
142 %if 0%{with gnome}
143 mv $RPM_BUILD_ROOT%{_datadir}/distccmon-gnome.desktop \
144         $RPM_BUILD_ROOT%{_applnkdir}/Network/Misc
145 mv $RPM_BUILD_ROOT%{_datadir}/distccmon-gnome-icon.png \
146         $RPM_BUILD_ROOT%{_pixmapsdir}
147 %endif
148
149 touch $RPM_BUILD_ROOT%{_vardir}/log/distcc
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post inetd
155 if [ -f /var/lock/subsys/rc-inetd ]; then
156         /etc/rc.d/init.d/rc-inetd reload 1>&2
157 else
158         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
159 fi
160
161 %postun inetd
162 if [ -f /var/lock/subsys/rc-inetd ]; then
163         /etc/rc.d/init.d/rc-inetd reload
164 fi
165
166 %post standalone
167 /sbin/chkconfig --add distcc
168 if [ -f /var/lock/subsys/distccd ]; then
169         /etc/rc.d/init.d/distcc restart 1>&2
170 else
171         echo "Run \"/etc/rc.d/init.d/distcc start\" to start distcc daemon."
172 fi
173
174 %preun standalone
175 if [ "$1" = "0" ]; then
176         if [ -f /var/lock/subsys/distccd ]; then
177                 /etc/rc.d/init.d/distcc stop 1>&2
178         fi
179         /sbin/chkconfig --del distcc
180 fi
181
182 %files
183 %defattr(644,root,root,755)
184 %doc AUTHORS NEWS README *.txt
185 %attr(755,root,root) %{_bindir}/%{name}
186 %attr(644,root,root) %{_mandir}/man?/%{name}.*
187 %attr(644,root,root) /etc/profile.d/*sh
188
189 %files common
190 %defattr(644,root,root,755)
191 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/distccd
192 %attr(640,root,root) %ghost %{_vardir}/log/distcc
193 %attr(640,root,root) /etc/logrotate.d/distccd
194 %attr(755,root,root) %{_bindir}/%{name}d
195 %attr(644,root,root) %{_mandir}/man?/%{name}d.*
196
197 %files inetd
198 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rc-inetd/distccd
199
200 %files standalone
201 %attr(754,root,root) /etc/rc.d/init.d/distcc
202
203 %files monitor
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_bindir}/distccmon-text
206
207 %if 0%{with gnome}
208 %attr(755,root,root) %{_bindir}/distccmon-gnome
209 %{_applnkdir}/Network/Misc/*.desktop
210 %{_pixmapsdir}/*
211 %endif
This page took 0.065893 seconds and 3 git commands to generate.